Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 23 of 23
Like Tree1Likes
  • 1 Post By kbocek
  1. Thread Author  Thread Author    #1  

    Default External SD Card Not Mounting

    Just bought a 16GB Micro SD card for my A500 and the A500 is now refusing to mount *any* external SD cards.

    I had a 2GB card lying around and successfully installed and used it in the A500. When the 16GB card arrived, I copied the contents of the 2GB card to the new card, confirmed the 16GB was FAT32 formatted, and tested the new card on my PC.

    But after plugging it into the A500 and powering the A500 down several times, the Settings | Storage screen still shows "External SD card" as unavailable. And /mnt/external_sd is empty when checked with ES File Explorer.

    I have since gone back with the 2GB SD card and *it* won't mount. So it feels like something is borked with the A500.

    I'm running Acer's current official 3.1 firmware.

    Does anyone know how to get external cards to mount?

    Thanks.
    wolf90 likes this.
  2. #2  
    Moscow Desire's Avatar
    Troubleshooter

    Posts
    1,818 Posts
    ROM
    Jiffy Pop Roots 3.47.114

    Default Re: External SD Card Not Mounting

    Reformat your 16gb in your PC's card reader. And, run a checkdisk on it, along with your 2gb.
  3. Thread Author  Thread Author    #3  

    Default Re: External SD Card Not Mounting

    Yup, did that. Did one of the painfully slow, format-every-sector formats too. I have rechecked the card in my PC several times. It *is* formatted and it does contains readable files.

    As a test, I also plugged in a 4GB USB key. That mounted fine in just a few seconds and was perfectly readable.
  4. #4  
    Moscow Desire's Avatar
    Troubleshooter

    Posts
    1,818 Posts
    ROM
    Jiffy Pop Roots 3.47.114

    Default Re: External SD Card Not Mounting

    Interesting. If this were a phone, I would almost call it a USB semi-brick. Considering the SD shares somewhat of a pathway with the USB.

    Typically, we would run an adb command, but in this case, but that's on version2 android.

    I assume you have installed the sd both with the device off, and the device on, with same results?

    I would say to reset to the factory, but with a stock 500, that means pushing some little pin in the hole by the volume rocker, which I really have no faith in.

    In otherwords, I think it's a software issue. Will have to ponder on this some more tomorrow...
  5. Thread Author  Thread Author    #5  

    Default Re: External SD Card Not Mounting

    I am aware of the reset option but would like to avoid having to set everything up again.

    I also just tried the old 2GB card again. It too still isn't mounted. This feels like a problem with whatever process identifies and mounts the SD cards.
  6. Thread Author  Thread Author    #6  

    Default Re: External SD Card Not Mounting

    Here's some stuff I've tried:

    I tried the recessed reset button. In contrast to Acer's dire warnings about the use of this button, it is just a normal reset button like the one on your PC. It just caused the A500 to reboot. I did not lose any settings. I also did not regain access to my SD card.

    I tried rebooting several times with the SD card out then inserting the SD card.

    I tried the Power Button-Volume Button update reset boot in the hope that this would somehow "wake up" the SD card interface. The firmware starts the update process and ends on the Android logo with an exclamation point because, of course, there is no update.zip file.

    I have yet to try the "Fresh Boot" option under Privacy Settings that wipes out all your data. I'm hoping someone comes up with another suggestion. I'm also hoping the 3.2 update comes soon.
  7. #7  
    Moscow Desire's Avatar
    Troubleshooter

    Posts
    1,818 Posts
    ROM
    Jiffy Pop Roots 3.47.114

    Default Re: External SD Card Not Mounting

    Something interesting I found, unfortunately you would have to root your tab, pretty painless.

    https://market.android.com/details?i...ze.USBMountAll
  8. Thread Author  Thread Author    #8  

    Default Re: External SD Card Not Mounting

    Thanks for the link Moscow, I'll keep that in mind. I think at this point I'll wait for the 3.2 update which should be Real Soon Now and hope that fixes the problem.

    The other thing I would try is a roll-back to a recent official Acer 3.1 system update. But where can I find them? Lots of unofficial rooted images out there. But where are the Acer images?
  9. #9  
    Moscow Desire's Avatar
    Troubleshooter

    Posts
    1,818 Posts
    ROM
    Jiffy Pop Roots 3.47.114

    Default Re: External SD Card Not Mounting

    Quote Originally Posted by kbocek View Post
    Thanks for the link Moscow, I'll keep that in mind. I think at this point I'll wait for the 3.2 update which should be Real Soon Now and hope that fixes the problem.

    The other thing I would try is a roll-back to a recent official Acer 3.1 system update. But where can I find them? Lots of unofficial rooted images out there. But where are the Acer images?
    You can find a couple of stripped down roms over at the xda devlopers site in the Acer 500 forums. But, although they use various versions of the stock android, they are in fact considered somewhat custom roms, and thus require the painless root to install. But they are based on stock HC and kernel. I remember they use 3.1 and 3.2 HC.

    But some of them have been getting stock roms from the acer web site. Not sure how they do it as I haven't checked.

    But, not much good to you considering you can't use your sd right now, but maybe a usb drive??? Don't know as I never tried it that way or if it's possible. The Acer Recovery tool may work though. You can find it in the market. However, maybe some folks over there at xda can get it going for you.

    Keep in mind, with the OTA of 3.2, they changed the bootloader so as of now, OTA 3.2 installs cannot root, and if they were rooted before, they no longer are after updating. Just something to think about.

    Be warned, at the 500 forum at xda, there are some real "trolls" hanging around. Seems the mods aren't keeping tabs on things lately. Especially after this 3.2 OTA surprised them all.

    Sorry I couldn't get your sd working. I'm sure it's software related.
  10. #10  
    Moscow Desire's Avatar
    Troubleshooter

    Posts
    1,818 Posts
    ROM
    Jiffy Pop Roots 3.47.114

    Default Re: External SD Card Not Mounting

    One more note. After trolling through several places, I noticed a few posts where users who had your issue, formatted their sd's in a different computer.

    Honestly, I have no idea why this would have a difference, but hey, always worth a shot.
  11. Thread Author  Thread Author    #11  

    Default Re: External SD Card Not Mounting

    Good idea Moscow. I plugged it into a Linux server I have here and:

    - backed up the existing files
    - wrote a new blank DOS partition table with parted
    - created a FAT32 partition (type B)
    - created a FAT32 filesystem with mkdosfs
    - copied back the files
    - plugged the card into my windows box and checked the files
    - power cycled the A500
    - *Then* plugged the card in

    Still no love.

    The tell is that the 2GB card that *was* working won't mount now. It's filesystem was fine.
    Thanked by:
  12. #12  
    Moscow Desire's Avatar
    Troubleshooter

    Posts
    1,818 Posts
    ROM
    Jiffy Pop Roots 3.47.114

    Default Re: External SD Card Not Mounting

    No love sucks.

    Out of tricks for today.

    Under warranty?
  13. Thread Author  Thread Author    #13  

    Default Re: External SD Card Not Mounting

    Yeah, less than a month old. Hate to have to ship it around but maybe official support can help.

    What's your feeling about the unofficial 3.2 updates?
  14. #14  
    Moscow Desire's Avatar
    Troubleshooter

    Posts
    1,818 Posts
    ROM
    Jiffy Pop Roots 3.47.114

    Default Re: External SD Card Not Mounting

    As with 3.2, well, go to xda and see pandamonium in the acer forums. So far, if you like stock, it seems to be ok with the exception of 1 user who lost Wifi. But who knows what his issue is. Says he lost Wifi after the update, and wants to roll back to 3.1. No dice as the new bootloader has you locked in to only post 3.2 updates.

    But the OTA update seems to be ok. Not sure, as for right now, it seems to be just for the 500 users, and not the 501 like me (3g option). But, I already run 3.2, and tweakers should know, NEVER install OTA's if youre rooted, without waiting for one or two sacrificial lambs.

    But for you, not custom rommed, wait a couple days and see if you can install the update before sending it off.
  15. #15  
    jollyjoey's Avatar

    Posts
    5 Posts
    ROM
    CM 7 480/806

    Default Re: External SD Card Not Mounting

    Quote Originally Posted by kbocek View Post
    Just bought a 16GB Micro SD card for my A500 and the A500 is now refusing to mount *any* external SD cards.

    I had a 2GB card lying around and successfully installed and used it in the A500. When the 16GB card arrived, I copied the contents of the 2GB card to the new card, confirmed the 16GB was FAT32 formatted, and tested the new card on my PC.

    But after plugging it into the A500 and powering the A500 down several times, the Settings | Storage screen still shows "External SD card" as unavailable. And /mnt/external_sd is empty when checked with ES File Explorer.

    I have since gone back with the 2GB SD card and *it* won't mount. So it feels like something is borked with the A500.

    I'm running Acer's current official 3.1 firmware.

    Does anyone know how to get external cards to mount?

    Thanks.
    Same exact thing happened to my sd card. The thing that finally made it work was to move the sd card from tablet to my android phone. On the phone go to Settings--->Storage--->Unmount SD Card. Once it was done unmounting i moved the card back into Iconia tablet and the tabket recognized the card and under External_SD it now showed the data on the card instead of being blank.
  16. #16  
    Moscow Desire's Avatar
    Troubleshooter

    Posts
    1,818 Posts
    ROM
    Jiffy Pop Roots 3.47.114

    Default Re: External SD Card Not Mounting

    Nice idea, I would "hope" people just don't remove the sd without first unmounting it (with system on).

    You can get by without doing it, if the system is shut down.
  17. Thread Author  Thread Author    #17  

    Default Re: External SD Card Not Mounting

    Quote Originally Posted by jollyjoey View Post
    Same exact thing happened to my sd card. The thing that finally made it work was to move the sd card from tablet to my android phone. On the phone go to Settings--->Storage--->Unmount SD Card. Once it was done unmounting i moved the card back into Iconia tablet and the tabket recognized the card and under External_SD it now showed the data on the card instead of being blank.
    Thanks Jollyjoey. Tried it. But it didn't work.

    I unmounted the existing card in my phone. Installed the 16GB card. Powered up the phone and it showed the 14.xx GB. Unmounted it. Powered cycled the A500. Inserted the 16GB card it still shows unavailable.

    Good idea but Moscow's idea to completely reformat it would, I think, be about the same thing.
  18. #18  

    Angry Re: External SD Card Not Mounting

    I can confirm this problem, unfortunately.

    Bought A500 several days ago. Today plugged a 2GB Sandisk card, previously formatted in a Samsung phone, then all files deleted on a Windows machine.

    When I tap on "Mount SD card" in Settings -> storage, it says "Preparing SD card" for a moment and nothing happens.

    When I run the Camera app, it says "Please insert SD card" and refiuses to take pictures.

    I have two directories under /mnt :

    /mnt/sdcard : this seems to be the internal storage. It is full of directories with data of my apps.

    And there is /mnt/external_sd. It is empty, attempt to create there a new file fails.

    Directory /data is empty.

    So, a question: is /mnt/external_sd where the extermal SD of Iconia A500 should mount to?
    Can it be that the software is confused between these two dirs?

    Have not rooted it yet.
    Shutdown, reboot and other simple tricks do not help. USB storage seems to work.

    Any other ideas?
    Android isn't iOS, obviously... but if I won't find a solution, will just return the device.

    -- ddbug
  19. Thread Author  Thread Author    #19  

    Default Re: External SD Card Not Mounting

    I ended up RMAing the unit and they replaced the motherboard. It's working now.
  20. #20  

    Lightbulb Re: External SD Card Not Mounting

    Well I don't know why ... I was already going to take the Iconia to the service. I turned it off and it was powered off for couple of days. Then I just put the SD card again, turned on... and it found the card!

    dd.
  21. #21  

    Default Re: External SD Card Not Mounting

    I have an acer a100 with the same issue, and the weird thing is if i open up a terminal with root privs i can mount it with the following command but it wont mount no matter what i change it to in fstab.

    mount /dev/block/mmcblk1p1 /mnt/external_sd

    Any thoughts? Need to make a new ramdisk with different init?
  22. Thread Author  Thread Author    #22  

    Default Re: External SD Card Not Mounting

    As I said back in February, I ended up RMAing the unit and it worked after that. Acer replaced the motherboard so it looked like a hardware failure of some sort.
  23. #23  

    Default

    Can it really be a hardwara failure in my case if it still mounts? Has you new one received all the OTA updates yet? Mine started after stock ICS update

    Sent from my SCH-I500 using Android Central Forums

Tags for this Thread

Posting Permissions