hi there fellow android lovers ive been having some problems with my xperia play and the sd card. so i bought my xperia play used on ebay from a trusted reseller. (it was pre rooted )it worked fine for the first few days and i was able to load all the games and apps i wanted and put them on the sd card. the sd card is a class 10 pny 32gb micro. but a few days latter at a meeting at church my phone stopped working with the apps that where on the sd card. it then showed a message in my notifications that i had a blank sd card or unsupported file system. i took it home and plugged the sd card into my windows xp computer and formatted it. it then seemed to work fine. then about 3 hours later it wouldnt recognise any apps or games on it. so i plugged it into my cousins windows 8 laptop and formatted it and also auto fixed the issues. then reset my phone (still was rooted) and loaded it up again. it did the same things so i decided to plug it back into my windows xp computer and run chkdsk in cmd and it came back with no issues. and it still wouldnt recognise any apps. so i downloaded a in depth disk wipe program and ran the overnight. still not working so i finnally gave up and went to fred myers and bought the same sd card and class only 16gb this time. it worked for a few days and then did the exact same thing my other sd card did. so i dont know if its the brand of sd card or if my phone is screwing things up. i havent tried unrooting and restoring it yet but that may help. if anybody had an idea on what it could be please help
- pielover98