Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
Like Tree1Likes
  • 1 Post By srkmagnus
  1. Thread Author  Thread Author    #1  

    Default Mobile data seems to be connected but doesn't work

    Hello, I am encounting a mysterious problem:

    Sometimes, the mobile data connection seems to be connected (the arrows are coloured) but the connection doesn't work.
    I can't find a rule about a specific factor that causes this malfunction.

    I tried to solve the problem by:
    • disabling and re-enabling data connection
    • enabling and re-disabling flight mode
    • using some applications from google play which promises to fix data connection issues
    • cache cleaning
    • ram cleaning

    However, I discovered another solution that permanently solves the problem for specific apps:
    1. When the problem occurs, I open an application that needs internet connection.
    2. I test data internet connection through this application to be ensured that it doesn't work.
    3. I disable data connection, enable wifi and test if the application now has internet connection through wifi.
    4. I disable wifi connection, re-enable data connection and test again if the application now has internet connection through data connection.
    5. Data connection now works normally only for the specific application but not for other applications. Doing the same steps for another application the problem can be also solved for the other specific application.

    After these attempts I wonder:
    1. Which factor causes the problem?
    2. What exactly a reboot achieves that solves the malfunction?
    3. How can I solve the problem by acting similarly to a reboot but without rebooting the device?

    Any ideas??

    Device: Motorola Atrix 4G
    Custom Rom: Android 2.3.7 Cyanogenmod MROM -1-0.20130113-olympus
  2. #2  
    srkmagnus's Avatar

    10,051 Posts
    Global Posts
    10,055 Global Posts
    Stock 4.4 (KitKat)

    Default Re: Mobile data seems to be connected but doesn't work

    Can you reproduce the same issue with a stock ROM? If not, then it's likely the ROM and or the network. Check to make sure there are no issues with the ROM as reported by the developer or users. If not, then it could be a network problem, which you'll have to contact the carrier.

    Sent from my Nexus 5 using AC Forums mobile app
    Golfdriver97 likes this.
  3. #3  
    Golfdriver97's Avatar

    23,803 Posts
    Global Posts
    24,245 Global Posts

    Default Re: Mobile data seems to be connected but doesn't work

    When I went from Stock Samsung to Slim, I noticed a drop in cell quality. Everything I did had no effect, including flashing older modems. I took it as a nature of the beast as I wasn't totally without a signal. The same may be for you as well.

    Sent from my Nexus 5 using AC Forums mobile app

    Phone Timeline
    What could not be changed, must be endured - New Spring, by Robert Jordan
    Community Guidelines and also here, Developer Rules, and Marketplace
    Mobile Nations Sister Forums: iMore/Connectedly/Windows Central/Crackberry
  4. Thread Author  Thread Author    #4  

    Default Re: Mobile data seems to be connected but doesn't work

    It was finally a DNS issue.

Similar Threads

  1. Please Help! Can't Get Galaxy S4 Keyboards To Remember Words Now
    By amocksun in forum General Help and How To
    Replies: 11
    Last Post: 01-03-2015, 01:34 PM
  2. Trouble getting Google Chromecast to connect to second TV
    By cmualex in forum Google Chromecast
    Replies: 6
    Last Post: 10-26-2014, 04:02 PM
  3. No, I don't want Visual Voice Mail. How to stop pop up?
    By N2myN2 in forum Verizon Galaxy Note 2
    Replies: 6
    Last Post: 08-04-2014, 05:10 PM
  4. How to get rid of the Safety Care app?
    By Roy Berntsen in forum LG G2
    Replies: 8
    Last Post: 07-07-2014, 05:37 AM
  5. Copy stock 4.3 email app to another device?
    By Skip Tannen in forum Sprint Galaxy S3
    Replies: 2
    Last Post: 01-12-2014, 10:59 AM

Posting Permissions