1. misstoxic's Avatar
    I hate it
    02-27-2014 02:00 PM
  2. Google_Superuser's Avatar
    After a certain point I think its good that it isn't supported. A developer can put more resources into taking advantage of the features in the newest versions of the OS rather than unending backwards compatibility.
    02-27-2014 02:02 PM
  3. misstoxic's Avatar
    It's not good. Some people are still on gingerbread
    02-27-2014 02:09 PM
  4. flyer8493's Avatar
    Why are you still on gingerbread? You can at least get a 4.0 or 4.1 device for practically nothing nowadays.

    Sent from my Nexus 5 using Tapatalk
    msndrstood likes this.
    02-27-2014 02:44 PM
  5. misstoxic's Avatar
    Bec I like my phone
    brosko and stalemate1 like this.
    02-27-2014 03:05 PM
  6. zerkom122's Avatar
    Cyanogen it


    Sent from my iPod touch using Tapatalk
    03-01-2014 04:32 AM
  7. David Braggs's Avatar
    I think it is the demand of the time.When newer technologies arrive it is most obvious that older versions will not work.So it is better to upgrade to a newer version.
    05-06-2014 06:39 AM
  8. shevill88's Avatar
    Just remember that "technology gets better and cheaper over time." So just wait a few months and the OS that you could not have before, will be affordable, your old one obsolete. So it is best to "marry-up" so to speak.
    05-19-2014 04:43 AM

Similar Threads

  1. Samsung Apps Update Notification
    By lworrilow in forum Samsung Galaxy S4
    Replies: 3
    Last Post: 03-22-2014, 09:11 PM
  2. Replies: 15
    Last Post: 03-06-2014, 12:50 PM
  3. Replies: 1
    Last Post: 03-01-2014, 10:03 PM
  4. Replies: 4
    Last Post: 02-27-2014, 07:45 PM
  5. Replies: 0
    Last Post: 02-27-2014, 12:52 PM
LINK TO POST COPIED TO CLIPBOARD