Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 1 of 1
  1. Thread Author  Thread Author    #1  

    Default Root problem with ICS 4.0.4 LG Optimus 2x

    I really would appreciate help so I write the text in pieces step-by-step in order to try to explain.

    I have a LG Optimus 2x.
    I had Gingerbread and rooted the mobile with SuperOneClick and it worked perfektly.

    Then I updated to Ice Cream Sandwish 4.0.4 and the root broke, like for so many else after upgrading a ROM.
    However, the telephone works just fine, except for that I need /want to have it rooted.

    *****************************
    I have Superuser installed (app) but when looking into the programme it sais "no apps in list", even
    though i have Link2SD installed (and it worked before).

    I tried to Root the telephone again by the same procedure as I did with Gingerbread,
    with SuperOneClick, but the programme sais that it FAIL.
    I cannot Unroot the telephone either, SuperOneClick get stuck on both "rebooting" and then (after rebooting manually) stuck on #5.

    BusyBox installer cannot install either, tried all versions on list. "Installing BusyBox v1.20.2 failed".
    And Root Checker (app) sais that I am not rooted.

    I tried using Superuser Update Fixer but that sais that the telephone IS rooted.
    But when using Link2SD it has no access to Superuser and no question about Allow or Deny appears. The list is empty.

    I've gone through prety much every "how to root" on Youtube about LG Optimus, without any luck AFTER the upgrade to ICS.

    Please, can someone please give me a clear Step-by-Step instruction in what fil (SU?) to use and where to install it.
    How do I get into / flash a LG Optimus 2x in order to unzip the SU.zip on SD?

    Thank you!!!

Similar Threads

  1. ICS Released for Korean LG Optimus 2X
    By anidev in forum Android 4.0 Ice Cream Sandwich
    Replies: 0
    Last Post: 08-30-2012, 07:26 PM
  2. Problem with ics on skyrocket
    By c1inside in forum General Help and How To
    Replies: 0
    Last Post: 05-02-2012, 08:47 PM
  3. Screen problem with ics
    By hanielserrato in forum Barnes & Noble Nook Color
    Replies: 2
    Last Post: 04-19-2012, 01:59 PM
  4. problem i need help with finding apps on my lg optimus t
    By jenbug21569 in forum T-Mobile Optimus T
    Replies: 1
    Last Post: 02-02-2012, 08:22 AM
  5. after rooting problems with lights on front
    By zombiearmy in forum Verizon LG Revolution
    Replies: 3
    Last Post: 11-08-2011, 11:36 PM

Posting Permissions