1. dhink's Avatar
    I have a very strange problem with my Samsung Galaxy S II. When I have a WiFi connection I'm able to sync all of my mail accounts, Yahoo, Google, & Exchange. When I'm connected to the mobile data network (AT&T) I can sync Yahoo & Google but not Exchange. I have no problem connecting to our exchange server via webmail through my browser while connected on the mobile data network. In my office, I turned WiFi off, opened email and and clicked refresh. My WiFi turned itself back on and connected to exchange. I disconnected from our WiFi network, turned WiFi off again and I got the message WiFi networks are available. If I'm out side of the office where there is no WiFi connection, I get the message unable to connect. I can change to one of my other mail account click refresh and my mail from those servers will download. I've gone through all of the mail setting for my exchange account on the phone and I'm not seeing anything that would restrict it from connecting to my exchange server via mobile data.
    03-07-2013 09:51 AM
  2. AinsleyZA's Avatar
    Hi Dhink,

    Have you received no feedback at all??
    I'm having the exact same problem and can find no support documentation for the problem.

    I'm from South Africa BTW, so I doubt this is a carrier related problem.
    04-22-2013 08:56 AM
  3. dhink's Avatar
    No feedback. I've had my IT dept check our mail server and they are not blocking connection types. Others in our organization who use iPhones don't have this issue and also others that have 3G phones are not having this issue. I updated my OS to JB and still the problem persists while on cellular data.

    Dan
    04-22-2013 01:06 PM
  4. Carnate's Avatar
    I'm having this exact same problem as well using a Nexus 4. This used to work fine but recently it changed. I'm using the stock android email app.
    07-04-2013 02:40 PM
  5. dhink's Avatar
    If your using Jelly Bean, make sure your mail program isn't set to block background data on mobile data. Once I changed this setting after I upgraded to Jelly Bean I'm able to receive my mail. Go to Settings, Data Usage, Exchange services, and make sure Restrict background date is NOT Selected. Doing this using on Ice Cream Sandwich had no effect but on Jelly Bean it resolved the issue for me at least.
    07-04-2013 11:26 PM
  6. Yonny Zafrani's Avatar
    Hi guys,
    Did someone manage to find a solution for that? I noticed that I'm able to access my account on a mobile network in some apps (myMail) but not on my native email app on my G2.
    06-28-2014 11:07 AM

Similar Threads

  1. Nexus stuck on 4.1.2; Can't connect to Google Servers on wifi
    By fragment137 in forum Google / Samsung Galaxy Nexus
    Replies: 5
    Last Post: 01-27-2013, 04:59 AM
  2. Can't connect to exchange on home wifi
    By msoprano13 in forum Sprint Galaxy S III
    Replies: 2
    Last Post: 07-21-2012, 07:29 AM
  3. Replies: 3
    Last Post: 12-10-2010, 01:32 PM
  4. Can't Connect to Server with 2.2
    By Gebo#AC in forum Motorola Droid X
    Replies: 3
    Last Post: 09-24-2010, 07:42 AM
  5. Unable to Connect to Exchange on WiFi
    By sirmichael in forum HTC Droid Eris
    Replies: 1
    Last Post: 07-15-2010, 04:49 PM
LINK TO POST COPIED TO CLIPBOARD