1. ultraguye's Avatar
    I'm new to android central and I've had my phone now for about a month and 2 weeks. About the first 3 weeks with the phone google play and youtube were basically useless, always connection time outs and just nothing working, youtube videos playing for 2 secs buffering for like a min then play for another two mins. I decided to do a factory data reset and that fixed it but it was a pain with getting back my apps pictures etc. It has been about days since i did the factory data reset and google play is slow and so is youtube. I watched a 37min video on youtube 2 days ago and it ran so smoothly now its just horribly, it works fine on wifi but I really don't want to do a factory data reset again, i tried clearing the cache and changing the time but nothing works please help!!!!!

    PS. Is it possible that i can upgrade to Jellybean 4.3 or even Kitkat ?
    11-03-2013 03:31 PM
  2. gman8845714's Avatar
    Possibly because it's a single core 800MHz processor or only having 512MB of ram. Either could be the issue being as it happened after you loaded more apps on the phone and it was subject to more use. This would explain why it worked well directly after factory reset. Maybe try clean master or a similar cache/ junk file cleaner. Then you would easily be able to free up ram and possibly solve your issue. Are you using your Verizon network or WiFi to use youtube? If your using your Verizon network try using WiFi, if this helps it most likely means you just have a poor data connection. If these don't help it is most likely just due to your short coming of processor speed and ram causing the lag. I mean honestly you get what you pay for and being as it is a $ 100 phone I wouldn't set my expectations to high. Good luck and I hope one of these solve your issue! I would be lost without YouTube on my phone so I feel for you!

    Posted via Android Central App
    11-03-2013 10:31 PM
  3. ultraguye's Avatar
    Thanks alot man, i did some research to find that straighttalk throttles their data once you hit 2.5 gb and after it works fine once again
    trumfelt1980 likes this.
    11-21-2013 09:48 AM
  4. James Massey1's Avatar
    well my phone is freezing in general on just like randoms apps like settings and others that come with the phone
    10-02-2015 01:25 PM

Similar Threads

  1. Galaxy Nexus stuck on boot screen
    By Don R in forum Verizon Galaxy Nexus Rooting, ROM's, and Hack's
    Replies: 5
    Last Post: 11-15-2013, 06:14 PM
  2. samsung galaxy note 10.1 neither charging nor turning on
    By ARCHITORIUM in forum Samsung Galaxy Note 10.1
    Replies: 1
    Last Post: 11-03-2013, 10:10 PM
  3. Need help making email work.
    By James Cooper 1 in forum General Help and How To
    Replies: 0
    Last Post: 11-03-2013, 01:58 PM
  4. Authentication error for my samsung Galaxy s3
    By Jahke Cagujas in forum Samsung Galaxy SIII I9300
    Replies: 0
    Last Post: 11-03-2013, 01:15 PM
LINK TO POST COPIED TO CLIPBOARD