09-03-2016 01:43 PM
45 12
tools
  1. Janine Guzman's Avatar
    I have a Note 3 and that worked perfectly
    10-20-2014 04:27 PM
  2. Katie Szmanda's Avatar
    The inductions I'm about to give are very hard to follow: settings- apps- Google play strore- remove updates. Now see if that worked
    Thank you!!!! Saved me from so much agony!!!!!!
    12-06-2014 08:49 PM
  3. Brooke Jett's Avatar
    THANK YOU!!!!
    12-15-2014 12:25 PM
  4. Chrissapher Blackbird's Avatar
    I had the same problem all I did was turn off power save Mode because it blocks background data
    01-13-2015 07:57 PM
  5. Sunil Atmakuri's Avatar
    this helped
    04-14-2015 09:46 PM
  6. Wicksy66's Avatar
    this worked for me . thanks
    04-25-2015 03:24 PM
  7. Larry Butchins's Avatar
    Erika: Tried that - nope!
    04-27-2015 10:24 AM
  8. Dianne Hetebry's Avatar
    Thank you for this. It was doing my head in. Now it is fixed!
    04-30-2015 04:30 PM
  9. codeviper's Avatar
    Easiest thing to do rather than go through a plethora of things try to uninstall googleplaystore in settings/apps/googleplaystore/ select uninstall.

    Then in your browser search for googleplaystore.apk the browser will show many selections, the one that has the newest version try that one.

    This is for Root Users who no longer have the choices described below. Could even work for non root users.
    06-24-2015 06:33 PM
  10. elliottawa's Avatar
    Thanks. I've had a hard time with this. You solved the problem. Many thanks.
    Elliott of Ottawa, aka. elliottawa
    07-21-2015 11:50 AM
  11. MarkBush2015's Avatar
    Best way is goto:
    Settings> Data Usage> the 3 Vertical dots in the top right of your scree> Restrict background data.

    Click enable restrict background data and then do same so it turns it back off, If you added a restriction to any app it seems to be a pain. but that should fix it. as to turning basic mode on and off its kinda the same thing but doing it a longer way (time wise)
    10-27-2015 08:13 AM
  12. Javrri's Avatar
    Why do play store need background data enabled to work?

    I have noticed that playstore uses a lot of data without my consent. I have a very limited data plan and it bothers me that playstore waste data to notify me that I have apps that is waiting to update. It wouldn't be that bad if it where some kilobytes but if I don't turn of playstores background data it robs me of several megabytes per day. I forgot about it for a while today and it used 15 mb for something, and I don't know what. What did it do? The other day, i woke up, turned on my phone and it used 23 mb directly. It didn't say that it updated anything. Nothing. I just know it used a lot of data, but not why. I have turned of automatic updates in the play store settings. And i did not even open the app when it took my data.

    Re-enabling background data for Play Store-uploadfromtaptalk1446068432416.jpgRe-enabling background data for Play Store-uploadfromtaptalk1446068442217.jpg

    What is this about. Anyone who knows?
    10-28-2015 04:42 PM
  13. CazPowell's Avatar
    The inductions I'm about to give are very hard to follow: settings- apps- Google play strore- remove updates. Now see if that worked
    This was the only thing that worked for me...tried the obvious that others have stated in the thread but even after deselecting 'turn off mobile data' it was still coming up with the same msg, gave this a go and problem solved! Thank u!
    11-16-2015 08:33 PM
  14. Kim Ferrell's Avatar
    Dude u rock! Worked for me!
    11-19-2015 05:12 PM
  15. vsayanam's Avatar
    Thank you for the information. Even Samsung did not give this!
    03-03-2016 10:43 PM
  16. Rohit Verma10's Avatar
    To solve this problem is nothing else works first go to the widgets at the end of your apps list and choose the power control widget and put it on your main screen. Once there check to see if the circling arrows sign that looks similar to the recycling sign is checked on, this controls your background data, if it isn't on check it on. If it is on and google play store still says enable background data then go to settings> apps> Google play store> then hit force stop. After doing so re-open Google play store and it should be working again.
    Works perfecly for mee bro thnx
    05-30-2016 10:04 AM
  17. Peter Nicholls's Avatar
    Brilliant Erica , had a mad bad day trying to sort that out on my S4 mini ! You nailed it , had to turn the thing of and restart ...Hero
    05-31-2016 04:30 AM
  18. Vince_MccrayT's Avatar
    Amazing fix !!!. Im sure this will help us alot ....Keep such posts coming in
    06-15-2016 02:06 PM
  19. ramadhas ganesan's Avatar
    Hi guys this is Ramadhas from Accenture
    I tried out all the instruction it's not working and finally I tried out another way am sure now it will work try this navigation
    SETTINGS -->Click Battery option once open the page click right side corner there will be option Battery optimization click the option
    Once open the page below one box will be there there ill be drop down not optimized and all apps click all apps there ill be list of apps in that select play store app and click u will get optimize and don't optimize select optimize option then open play store am sure it ill work (settings -->Battery --Battery optimization-->all apps -->select play store and click -->select optimize )
    08-03-2016 02:06 PM
  20. Zom_Bree's Avatar
    YEESSS!!!! Thank you!!!
    09-03-2016 01:43 PM
45 12

Similar Threads

  1. Half-working mobile data
    By jazzy_noodles in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 6
    Last Post: 02-19-2014, 03:55 PM
  2. Looking for a good signature app
    By Amy Furlong in forum Verizon Samsung Galaxy Note 3
    Replies: 0
    Last Post: 02-16-2014, 05:01 AM
LINK TO POST COPIED TO CLIPBOARD