1. Joanne Alberts's Avatar
    Hi

    I can imagine this question has been asked about a million times.

    I have a Samsung Galaxy s3 Mini running on Jelly Bean and I have a problem with my contacts. One...only one...has done what I want it to. The first contact on my address list has a little Google symbol AND and little Whatsapp symbol next to it, so I can start a Whatsapp conversation from the Phone Book. However, this hasn't happened to any other contacts and it's really bugging me. Here are the things I have tried:-

    Phone Book - Contacts to display - All
    Phone Book - Accounts - Whatsapp - Sync Contacts

    I have been looking online for about 2 days, and I can't figure it out. I don't know what I am doing wrong.

    Thanks in advance for any help you can give me!
    12-12-2012 05:01 AM
  2. amlanmathur's Avatar
    Hi Joanne

    just solved this problem. In whatsapp settings go to contacts and checkmark "show all contacts" . I'm not sure how or why some of my contacts were hidden but this led to all of them being shown.
    12-14-2012 08:00 AM
  3. Joanne Alberts's Avatar
    I have fixed this now...I uninstalled Whatsapp and then reinstalled it. Should have known turning it off and then on again fixes everything!
    12-18-2012 03:02 AM
  4. Shrinivas M's Avatar
    Hi,
    I have a Moto E running on KitKat and I have a problem with my contacts. contact photos are not getting update with Whatsapp contact photos. tried sync setting by selecting all.
    & i have tried uninstalled & re-installed whatsapp & cleared data & storage data catche clear everything. but no use!
    06-17-2014 02:56 AM
  5. Sagar Solanki's Avatar
    Hi,
    I have a Moto E running on KitKat and I have a problem with my contacts. contact photos are not getting update with Whatsapp contact photos. tried sync setting by selecting all.
    & i have tried uninstalled & re-installed whatsapp & cleared data & storage data catche clear everything. but no use!
    - - - Updated - - -

    Uninstalled and reinstalled watsapp. Bt no changes. Please help.
    06-22-2014 02:13 PM
  6. Alan Melapatt's Avatar
    three possibilities for this to happen
    1.unhide contacts in whatsapp
    2.Kitkat privacy in settings
    3.contacts-in it 'accounts'-auto sync app data.

    the third worked out for me
    08-14-2014 01:02 PM
  7. Annie Tariq's Avatar
    Hi,

    I am using Android 4.2. There is a contact in my contacts list which is also using viber and whatsapp. earlier I was able to see that the contact is on whatsapp and viber too in my contact list but now for that particular contact its not being shown under connections in contact list whereas for the rest of the contacts its working fine. Please help.
    08-23-2014 10:51 AM
  8. Ria Das's Avatar
    I faced the same problem and researched it.
    I saved a number with country code, for example +91 for india, the number got reflected in whatsapp. Try it out
    msr_RTP likes this.
    09-13-2014 11:54 PM
  9. wakeelm's Avatar
    ---------
    10-01-2014 02:44 AM
  10. wakeelm's Avatar
    ---------------
    10-01-2014 02:46 AM
  11. wakeelm's Avatar
    three possibilities for this to happen
    1.unhide contacts in whatsapp
    2.Kitkat privacy in settings
    3.contacts-in it 'accounts'-auto sync app data.

    the third worked out for me
    Please give more details regarding third solution
    10-01-2014 02:49 AM
  12. msr_RTP's Avatar
    I checked all setting and tried several options. This worked like Charm, make sure you have country code in-front of the phone number with '+' sign.
    02-10-2015 07:57 PM
  13. amareshshaukar's Avatar
    i have google nexus 5 i have a problem with myh contacts ,my contacts i need call anyone its call going from whatsapp call i need to call normal so plz help me as early as possible
    06-05-2015 06:11 AM
  14. riti_fb's Avatar
    Hi
    Today i fixed this issue on my Note 3.
    Go to Phone Setting
    Settings>> Installed Apps>> WhatsApp>>(Scroll down to)Permission Manager>>Read You Contacts>>Accept
    Now to to contacts page of WhatsApp and refresh the page.
    All your contacts will get sync.
    04-15-2016 03:25 AM
  15. my_2_boys's Avatar
    This worked perfectly. I have a Note5 and just updated it to Marshmallow and my Whatsapp Contacts wouldn't sync.
    I did this, and everything is back to normal. Thanks.
    04-18-2016 01:18 PM
  16. Vivechana's Avatar
    Hi
    Today i fixed this issue on my Note 3.
    Go to Phone Setting
    Settings>> Installed Apps>> WhatsApp>>(Scroll down to)Permission Manager>>Read You Contacts>>Accept
    Now to to contacts page of WhatsApp and refresh the page.
    All your contacts will get sync.
    Worked perfectly on note3. Thanks!
    06-29-2016 10:40 PM

Similar Threads

  1. merge Facebook contacts with google contacts
    By rpscott02 in forum Droid Bionic
    Replies: 7
    Last Post: 07-20-2013, 11:27 AM
  2. Sync contacts with Google?
    By coachdvc in forum HTC EVO 4G
    Replies: 15
    Last Post: 08-04-2010, 02:34 PM
  3. Replies: 8
    Last Post: 07-27-2010, 08:46 PM
  4. How to Sync contact pictures from Outlook with Google contacts?
    By eyecon82 in forum General Help and How To
    Replies: 1
    Last Post: 06-01-2010, 01:59 PM
  5. Replies: 3
    Last Post: 06-01-2010, 01:49 AM
LINK TO POST COPIED TO CLIPBOARD