Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 14 of 14
Like Tree2Likes
  • 2 Post By leo9
  1. Thread Author  Thread Author    #1  

    Question Update to 4.2.2 on Galaxy Nexus keeps failing

    Hi,

    I've been trying to update to 4.2.2 all day, but every time I try, Clockworkmod (most current one) gives me several errors error:

    1. the first being: "E: Invaling Command Argument"
    2. Then: "E: Failed to verify whole-life signature
    3. and: "E: signature verification failed"
    4. After which I have to accept to install this "untrusted zip" -- I select 'yes', obviously.
    5. After that, this last error occurs and the installation gets aborted: "assert failed: apply_patch_check( "/system/app/SystemUI.apk" blablabla...*load of text* blablabla... "(Status 7)"


    I honestly don't know what's going wrong, or whether this is just some stupid question...I already thought it might be a problem of Clockwordmod or the fact that I'm rooted, but I'm not sure, and I don't want to waste my time unrooting, updating and rerooting again if it turns out to not make a difference.

    If I have to uninstall Clockwordmod, could you please tell me how? Or should I just keep on trying?
    Manually updating isn't really an option for me...I tried it... once...and, well, I ended up stressing all day because I was afraid I completely ruined my phone xD



    Thanks in advance
    And sorry for any grammatical or spelling errors!


    (not completely sure whether this is important information, but well:
    I'm running stock Android 4.2.1 yakju on my GSM Samsung Galaxy Nexus; rooted and unlocked; installed Clockworkmod 6.0.2.3 through ROM Manager; flashed yakju over my original yakjuxw; and updated through that forced-update-trick where you clear all data of Google Services Framework; and have been messing around with apps like Ful! Screen and LMT lately (uninstalled both))
  2. #2  

    Unhappy Re: Update to 4.2.2 on Galaxy Nexus keeps failing

    I tried to.

    And I had the same problem...
    I installed the recovery stock of my 4.2.1 rom, and the throw the message "Error", someone know what happend with this update???
  3. #3  

    Default Re: Update to 4.2.2 on Galaxy Nexus keeps failing

    I got excited with the update my nexus 7 pulled today, but I got an 'error' message (with a broken droid on it's back) at the very start of installation. After restart it went back to 4.2.1 and no sign of an update to download.
    Running stock 4.2.1 on rooted 16g N7
  4. #4  

    Default Re: Update to 4.2.2 on Galaxy Nexus keeps failing

    I'm getting the exact same error on both my nexus devices, being the Galaxy Nexus and the Nexus 7. I guess so far no one seems to have an idea how to fix it...
  5. #5  
    tgp
    tgp is online now
    tgp's Avatar

    Posts
    459 Posts
    Global Posts
    2,385 Global Posts

    Default Re: Update to 4.2.2 on Galaxy Nexus keeps failing

    My Nexus 4 also gave the "Error" message when trying to install the update. It has an unlocked bootloader and was rooted, but otherwise completely stock. I had to do a factory reset for the update to install successfully.

    My wife has a Galaxy Nexus, and hers also has an unlocked bootloader and is rooted. The update installed just fine, and the phone didn't even lose root.
  6. #6  
    leo9's Avatar

    Posts
    2 Posts

    Default Re: Update to 4.2.2 on Galaxy Nexus keeps failing

    I'm getting what appears to be exactly the same error as MrFlipnote.

    First, some details of my system:

    Hardware: Nexus 7 wi-fi only
    Current Android version: 4.2.1
    Current kernel version: 3.1.10-g22b4fcd android-build@vpbs1.mtv.corp.google.com #1 Fri Nov 2 10:55:26 PDT 2012
    Current build number: JOP40D
    Locale: UK

    Bootloader unlocked.
    Rooted prior to this update.
    ClockworkMod Recovery v.6.0.2.3.
    SuperSU installed.

    I first attempted to install the update after receiving the official notification that the update had been downloaded and was ready for installation: I clicked on the notification message, followed the prompts, and received the same error messages whose details I will give below.

    Since then I have downloaded the update separately from -

    http://android.clients.google.com/pa...D.6ece895e.zip

    - then attempted to invoke an update as follows:

    On the (Ubuntu) PC, in a terminal:

    1. [cd to the location of the downloaded zip.]
    2. adb push 6ece895ecb23.signed-nakasi-JDQ39-from-JOP40D.6ece895e.zip /sdcard/
    3. adb reboot recovery

    That reboots the Nexus 7 to CWM Recovery mode. Then, on the Nexus 7:

    1. Select menu option: Install zip from sdcard > Choose zip from sdcard.
    2. Select folder "0", then scroll down to the pushed zip file and click it.
    3. Click "Yes - Install 6ece[...].zip

    Whereupon I get the errors listed below.

    Things I've tried (followed by a repeat of the process above):

    * In CWM, selecting option: Wipe cache parition.
    * In CWM, selecting option: Advanced > Wipe dalvik cache.
    * In CWM, selecting option: Fix permissions.
    * In CWM, selecting option: Install zip from sdcard > Toggle signature verification.

    None of those worked.

    The error messages as reported on-screen on the tablet are as follows, when I attempt the update with signature verification switched off (with verification turned on, I also get the "signature verification failed" error reported by MrFlipnote):

    -- Installing: /sdcard/0/6ece895ecb23.signed-nakasi-JDQ39-from-JOP40D.6ece895e.zip
    Finding update package...
    Opening update package...
    Installing update...
    Verifying current system...
    assert failed: apply_patch_check("/system/build.prop", "48f7593c2ff2fa85a147639fd7b77c3bc0607249", "7227890adedc4c5daca6cfe3ea1b6aca319fe6fd")
    E:Error in /sdcard/0/6ece895ecb23.signed-nakasi-JDQ39-from-JOP40D.6ece895e.zip
    (Status 7)
    Installation aborted.

    Here is my full CWM log (obtained by selecting CWM menu option: Advanced > Report error, then finding the log on my tablet, in /data/media/clockworkmod/recovery.log), which contains some more detail:

    Starting recovery on Sun Feb 17 06:48:19 2013
    can't open /dev/tty0: No such file or directory
    framebuffer: fd 3 (800 x 1280)
    ClockworkMod Recovery v6.0.2.3
    recovery filesystem table
    =========================
    0 /tmp ramdisk (null) (null) 0
    1 /sdcard datamedia /dev/null (null) 0
    2 /system ext4 /dev/block/platform/sdhci-tegra.3/by-name/APP (null) 0
    3 /cache ext4 /dev/block/platform/sdhci-tegra.3/by-name/CAC (null) 0
    4 /data ext4 /dev/block/platform/sdhci-tegra.3/by-name/UDA (null) -32768
    5 /misc emmc /dev/block/platform/sdhci-tegra.3/by-name/MSC (null) 0
    6 /boot emmc /dev/block/platform/sdhci-tegra.3/by-name/LNX (null) 0
    7 /recovery emmc /dev/block/platform/sdhci-tegra.3/by-name/SOS (null) 0
    8 /staging emmc /dev/block/platform/sdhci-tegra.3/by-name/USP (null) 0

    W:Unable to get recovery.fstab info for /datadata during fstab generation!
    W:Unable to get recovery.fstab info for /emmc during fstab generation!
    W:Unable to get recovery.fstab info for /sd-ext during fstab generation!
    I:Completed outputting fstab.
    I:Processing arguments.
    I:Checking arguments.
    I:device_recovery_start()
    Command: "/sbin/recovery"

    ro.boot.serialno=[I've deleted this from the log: a 16-character alphanumeric string]
    ro.boot.bootloader=4.13
    ro.serialno=[I've deleted this from the log: a 16-character alphanumeric string]
    ro.bootmode=unknown
    ro.baseband=unknown
    ro.bootloader=4.13
    ro.hardware=grouper
    ro.revision=0
    ro.emmc=0
    ro.boot.emmc=0
    ro.factorytest=0
    ro.secure=1
    ro.allow.mock.location=0
    ro.debuggable=1
    persist.sys.usb.config=mtp,adb
    ro.build.id=JZO54K
    ro.build.display.id=cm_grouper-userdebug 4.1.2 JZO54K eng.hudson.20121217.121437 test-keys
    ro.build.version.incremental=eng.hudson.20121217.121437
    ro.build.version.sdk=16
    ro.build.version.codename=REL
    ro.build.version.release=4.1.2
    ro.build.date=Mon Dec 17 12:15:08 PST 2012
    ro.build.date.utc=0
    ro.build.type=userdebug
    ro.build.user=hudson
    ro.build.host=koushik-lion
    ro.build.tags=test-keys
    ro.product.model=Nexus 7
    ro.product.brand=Google
    ro.product.name=nakasi
    ro.product.device=grouper
    ro.product.board=grouper
    ro.product.cpu.abi=armeabi-v7a
    ro.product.cpu.abi2=armeabi
    ro.product.manufacturer=Asus
    ro.product.locale.language=en
    ro.product.locale.region=US
    ro.wifi.channels=
    ro.board.platform=tegra3
    ro.build.product=grouper
    ro.build.description=nakasi-user 4.1.2 JZO54K 485486 release-keys
    ro.build.fingerprint=google/nakasi/grouper:4.1.2/JZO54K/485486:user/release-keys
    ro.build.characteristics=tablet,nosdcard
    ro.cm.device=grouper
    ro.opengles.version=131072
    wifi.interface=wlan0
    rild.libpath=/system/lib/libril-icera.so
    rild.libargs=-e wwan0
    persist.tegra.nvmmlite=1
    ro.audio.monitorOrientation=true
    debug.nfc.fw_download=false
    debug.nfc.se=false
    ro.sf.lcd_density=213
    ro.rommanager.developerid=cyanogenmod
    keyguard.no_require_sim=true
    ro.url.legal=http://www.google.com/intl/%s/mobile/android/basic/phone-legal.html
    ro.url.legal.android_privacy=http://www.google.com/intl/%s/mobile/android/basic/privacy.html
    ro.com.google.clientidbase=android-google
    ro.com.android.wifi-watchlist=GoogleGuest
    ro.setupwizard.enterprise_mode=1
    ro.com.android.dateformat=MM-dd-yyyy
    ro.com.android.dataroaming=false
    ro.cm.version=10-20121217-UNOFFICIAL-grouper
    ro.modversion=10-20121217-UNOFFICIAL-grouper
    ro.config.ringtone=Orion.ogg
    ro.config.notification_sound=Deneb.ogg
    ro.config.alarm_alert=Hassium.ogg
    wifi.supplicant_scan_interval=15
    tf.enable=y
    drm.service.enabled=true
    ro.carrier=wifi-only
    dalvik.vm.heapstartsize=8m
    dalvik.vm.heapgrowthlimit=64m
    dalvik.vm.heapsize=384m
    dalvik.vm.lockprof.threshold=500
    dalvik.vm.dexopt-flags=m=y
    net.bt.name=Android
    net.change=net.bt.name
    dalvik.vm.stack-trace-file=/data/anr/traces.txt
    init.svc.ueventd=running
    init.svc.recovery=running
    service.adb.root=1
    init.svc.adbd=running

    I:Checking for extendedcommand...
    I:Skipping execution of extendedcommand, file not found...
    I:using /data/media for /sdcard/.

    -- Installing: /sdcard/0/6ece895ecb23.signed-nakasi-JDQ39-from-JOP40D.6ece895e.zip
    Finding update package...
    I:Update location: /sdcard/0/6ece895ecb23.signed-nakasi-JDQ39-from-JOP40D.6ece895e.zip
    I:using /data/media for /sdcard/0/6ece895ecb23.signed-nakasi-JDQ39-from-JOP40D.6ece895e.zip.
    Opening update package...
    Installing update...
    Verifying current system...
    file "/system/build.prop" doesn't have any of expected sha1 sums; checking cache
    failed to stat "/cache/saved.file": No such file or directory
    failed to load cache file
    script aborted: assert failed: apply_patch_check("/system/build.prop", "48f7593c2ff2fa85a147639fd7b77c3bc0607249", "7227890adedc4c5daca6cfe3ea1b6aca319fe6fd")
    assert failed: apply_patch_check("/system/build.prop", "48f7593c2ff2fa85a147639fd7b77c3bc0607249", "7227890adedc4c5daca6cfe3ea1b6aca319fe6fd")
    E:Error in /sdcard/0/6ece895ecb23.signed-nakasi-JDQ39-from-JOP40D.6ece895e.zip
    (Status 7)
    Installation aborted.
    I:Can't partition non-vfat: datamedia
    I:Can't format unknown volume: /external_sd
    I:Can't format unknown volume: /emmc
    I:using /data/media for /sdcard.
  7. #7  

    Default Re: Update to 4.2.2 on Galaxy Nexus keeps failing

    UPADTE: that DID NOT work. haha. the update still gave me the same error. and I just got stuck on the boot animation screen. (waited 15 minutes, then did a battery pull ) I am doing a restore now, and will patiently wait for a better solution.


    I'm having the same issue. After I create a backup I am going to try flashing a stock system img and then try the update again per this link: [Q] 4.2.2 OTA "Error" - xda-developers

    Will update everyone with the results as soon as i'm done. ::fingers crossed:: wish me luck!
    Last edited by its_lucky; 02-17-2013 at 04:00 PM. Reason: UPDATE on situation
  8. #8  
    leo9's Avatar

    Posts
    2 Posts

    Default Re: Update to 4.2.2 on Galaxy Nexus keeps failing

    I've fixed the problem largely thanks to the following page, which explains that it is caused by the SHA-1 hash code (used as a kind of file version identifier) of one or more files on the system not matching the hash expected by the updater - because some program has unexpectedly modified the file:

    [GUIDE] Fix "assert failed: apply_patch_check" error - xda-developers

    In my case the problematic file was /system/build.prop, so I needed to find a clean copy of that file from my (as was) *current* version of Android, namely 4.2.1. That is no longer available from Google but it is available from this site:

    Nexus 7 Firmware – nakasi | Random Phantasmagoria

    I was a little dubious about downloading images from a third-party site, but it seems above-board and I've had no problems.

    I wanted the 4.2.1 JOP40D image file listed on that page, nakasi-jop40d-factory-6ac58a1a.tgz. Inside the .tgz file was a .zip file, and inside that was the system.img file that contained the file that I was after - but it wasn't easy to get to: I needed to mount the .img file first.

    I used this page -

    Unpack/repack ext4 Android system images AndWise

    - which explains how to use two programs called simg2img and make_ext4fs to mount .img files and make new .img files (I only needed the first). You can do this in any folder (I did it from my Downloads folder):

    mkdir sys
    ./simg2img system.img sys.raw
    sudo mount -t ext4 -o loop sys.raw sys/

    Then go into the newly created sys folder and find the file that you want.

    I took a copy of build.prop from there and used adb to push it to the /sdcard folder on my Nexus 7. On the Nexus 7, I then used ES File Explorer (as root) to rename the existing build.prop file to something else and paste the new build.prop in its place.

    Only at this point did I notice that there were already three backups of build.prop in the /system folder. It might have sufficed to take the most recent of those, and use that as my new build.prop. But since I'd already found this clean instance and had no idea about the state of those backups, I didn't try that approach.

    I then repeated the update process as described in my initial message (from "adb reboot recovery" onwards). This time, the update proceeded without any further hitches. I now have Jelly Bean 4.2.2! What I don't have is the Sunday afternoon that I wasted working out all of the above.
    Thanked by 2:
    its_lucky and yofa like this.
  9. #9  

    Default Re: Update to 4.2.2 on Galaxy Nexus keeps failing

    I hear ya! I also spent Sunday afternoon trying to figure it out, only to fail. heh.
    well, congrats on finding the solution! and thanks for the links and walkthrough!
    now I'm debating if I want to spend more time on what seems to be such minor update. if you don't mind my asking, in your opinion, was all that work worth it?
  10. #10  

    Default Re: Update to 4.2.2 on Galaxy Nexus keeps failing

    I followed AndroidPolice's adb walkthrough, very easy, lemme go hunt a link brb Ok, here it is; http://www.androidpolice.com/2013/02/13/the-nexus-4-finally-gets-android-4-2-2-jdq39-as-well-here-are-instructions-for-installing-it-manually/
  11. #11  

    Default Re: Update to 4.2.2 on Galaxy Nexus keeps failing

    hello there thanks for the guide...but will the future updates require the same steps to update?or will it update automatically (settings>about phone>software update)?
    and plz try to include a video ,thanks in advance
  12. #12  

    Default Re: Update to 4.2.2 on Galaxy Nexus keeps failing

    I have to format my nexus due to some problem and I send it to samsung service centre. Once collected I notice it only use android 4.0.4. Then I upgrade my nexus but it can only be updated until android 4.2.1 not until 4.2.2. Before this I'm running android 4.2.2.. can anybody help me how to fix that problem?
  13. #13  

    Default Re: Update to 4.2.2 on Galaxy Nexus keeps failing

    Get 4.2.2 for your device from this list of images from Google then follow Android Police's walkthrough (substitute the file names according to the image file that you're using, don't use the exact file names from the web page, as listed, exactly because I don't think they apply to your deviceI'm assuming you don't have a Nexus 4) to update via adb.
    ~~~SANDSTONE BLACK 64GB ONEPLUS ONE~~~
    ~~~WHITE 32GB NEXUS 5~~~
  14. #14  
    shah.jimish's Avatar

    Posts
    3 Posts
    Global Posts
    4 Global Posts

    Default Re: Update to 4.2.2 on Galaxy Nexus keeps failing

    I'd like to share my story of rooting and how I almost lost my phone by soft bricking it. Firstly a little about me, I am a commerce grad and have absolutely no idea about the technicalities involved in rooting and related activities. Whatever I have learned, I learned from YouTube and android forums...so please forgive me for being a ****, if you think so of me!

    I am using my GNex for about 7 months now and after using it in pure vanilla Android form, I decided to root it and fiddle with other ROMS.

    I downloaded and installed Nexus Root Toolkit by Wug. Everything went smooth and I insatlled apps which requires root access...like Titanium backup, AdAway et al

    Next came custom ROMS...I tried four of them (Carbon, ParanoidAndroid, Cyanogen and AOKP), but keep in mind that I researched thoroughly about the pros and cons of each ROM, I watched youtube videos and read all the reviews on innumerable forums.

    I took backup before installing a new one and never dirty flashed - wiped cashe and Delvik cache without fail. After flashing ROM, I used to restore my apps+data from Titanium.

    Life was happy and I never got any problem of any kind

    Then I flashed AOKP JB MR1 nightly (dont remember the date). ROM worked flawlessly and I was very happy. I thought that if this version is stable, It is time to move to the newer and more stable version. I downloaded via goo.im with compatible GApps and started to backup via TWRP. And bam! the first shock by my rooted GNex....backup failed. I tried three to four times and , it would fail, everytime.

    I was quite confident that since I had prevoius ROMs backup, there was no need to be worried. I went ahead and wiped off the data along with cache and delvic cache - without proper backup, and flashed a newer version of AOKP.

    And thats when my phone started to act strange. It kept bootlooping and never got past the Nexus' X symbol (its the default welcome screen of AOKP). Other backups restore would yield the same result and thats when I decide to go back to my very first backup (after rooting (JB 4.2.1)). Although it still kept bootlooping, but the frequency was much more less than of other custom ROMs.
    I managed to register into my google account and setup all the necessary apps from playstore (It took me three to four tries to complete everything). But it still kept bootlooping...

    Then it was time I went back to unrooting the device and start from scratch. But lo and behold! toolkit wont perform the unrooting. After researching more, I found about ODIN. And after installing ODIN on my pc, I managed to revive my phone back to its original form (I found 4.1.1 file and then I upgraded to 4.2.2 via OTA).

    Although, I am using 4.2.2 on my phone right now, it still feels a tiny bit slower as compared to the time before I rooted it. And it also reboots itself, especially when used for more than 30 mins or so. The running app freezes and reboots.

    Now, I am not from technical background and whatever I have done - rooting, flashing ROMs, using ODIN, I have learned from youtube and forums. But I think that somehow the backup data got corrupted.

    I dont know whom to blame, Titanuim backup or ROMs. Needless to say I am blaming myself as it was me who wanted to try out something different and newer on my GNex

    Please feel free to ask any question related to this post and I will try my level best to answer it to you.

Similar Threads

  1. Replies: 4
    Last Post: 10-04-2012, 12:45 AM
  2. How to get Jelly Bean on Galaxy Nexus
    By kswem in forum Introductions
    Replies: 2
    Last Post: 07-07-2012, 10:13 AM
  3. Hope do I stop ICS update warning on Galaxy Nexus?
    By BJB1 in forum General News & Discussion
    Replies: 0
    Last Post: 06-03-2012, 04:18 PM
  4. how to put movies on galaxy nexus
    By wellsj349 in forum Google / Samsung Galaxy Nexus
    Replies: 6
    Last Post: 02-15-2012, 10:28 PM
  5. Best Way to Video Call on Galaxy Nexus
    By TheNexusMan in forum Verizon Galaxy Nexus
    Replies: 15
    Last Post: 02-06-2012, 10:53 PM

Posting Permissions