Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 18 of 18
  1. Thread Author  Thread Author    #1  
    selimlok's Avatar

    Posts
    16 Posts
    Global Posts
    18 Global Posts

    Default Contacts slow to appear on my Samsung Galaxy s4 mini

    Hi all.
    I just purchased a Samsung Galaxy s4 mini and have realized that my contacts seem to appear on the screen very slow. It sometimes takes upto 2 minutes to appear.
    Some thing you all should know is that I have 2000+ contacts (mainly clients).

    At first I was using google contacts and i assumed this was causing it to lag due to using data to refresh... but I transferred all the contacts to the device itself... so it shouldn't lag anymore!

    When people even call... there name doesnt appear, and only the phone number shows, even though I have the number installed in my contacts.
    This is also the case with text messages. When I want to compose a new text, and search for a contact... it doesnt do anything for about a minute or two.

    I have opened the developer mode, and changed the animations to off, but this hasnt solved the problem.

    If anybody could please help with this it will be much appreciated.

    Thanks
    Selim
  2. #2  

    Default Re: Contacts slow to appear on my Samsung Galaxy s4 mini

    Quote Originally Posted by selimlok View Post
    Hi all.
    I just purchased a Samsung Galaxy s4 mini and have realized that my contacts seem to appear on the screen very slow. It sometimes takes upto 2 minutes to appear.
    Some thing you all should know is that I have 2000+ contacts (mainly clients).

    At first I was using google contacts and i assumed this was causing it to lag due to using data to refresh... but I transferred all the contacts to the device itself... so it shouldn't lag anymore!

    When people even call... there name doesnt appear, and only the phone number shows, even though I have the number installed in my contacts.
    This is also the case with text messages. When I want to compose a new text, and search for a contact... it doesnt do anything for about a minute or two.

    I have opened the developer mode, and changed the animations to off, but this hasnt solved the problem.

    If anybody could please help with this it will be much appreciated.

    Thanks
    Selim
    transfer your contacts back to google... and make sure that you have auto sync on for your contacts.. then reboot your phone... what service provider do you have?
  3. Thread Author  Thread Author    #3  
    selimlok's Avatar

    Posts
    16 Posts
    Global Posts
    18 Global Posts

    Default Re: Contacts slow to appear on my Samsung Galaxy s4 mini

    Hi there.
    I originally had all e contacts in google, and because this issue existed I then transferred all of them to the device and cancelled contact syncing.
    After doing this, problem still exists.

    My network is Vodafone.

    Cheers
  4. #4  
    Haalcyon's Avatar
    Banned

    Posts
    7,932 Posts
    Global Posts
    8,917 Global Posts
    ROM
    CM 10.2

    Default Re: Contacts slow to appear on my Samsung Galaxy s4 mini

    2000 client contacts. That's impressive and may be some kind of record.

    from my Sony Xperia Tablet Z or XTZ or "Ecstasy"
  5. Thread Author  Thread Author    #5  
    selimlok's Avatar

    Posts
    16 Posts
    Global Posts
    18 Global Posts

    Default Re: Contacts slow to appear on my Samsung Galaxy s4 mini

    Lol. Thanks.
    I wish I made a dolar off each of them per day.
    Now that would be awesome!
  6. Thread Author  Thread Author    #6  
    selimlok's Avatar

    Posts
    16 Posts
    Global Posts
    18 Global Posts

    Default Re: Contacts slow to appear on my Samsung Galaxy s4 mini

    So anyone have any ideas for my issues???

    Ive been searching for days and still have no resolution for this.
    Its very annoying.
  7. Thread Author  Thread Author    #7  
    selimlok's Avatar

    Posts
    16 Posts
    Global Posts
    18 Global Posts

    Default Re: Contacts slow to appear on my Samsung Galaxy s4 mini

    Im with Telstra in Australia... which is the best network around in this country.
  8. #8  

    Default Re: Contacts slow to appear on my Samsung Galaxy s4 mini

    Hello there.

    I found this thread which explains exactly what I am facing with my Galaxy S4 Mini. Contact or anything uses Contact (ie email, writing messages ..etc) is very very slow, taking a min or two to open. sometimes I get a pop-up, saying the operation is taking so long, you want to wait or cancel .

    I never had this problem with my S3 Mini, is this a known bug with Android 4.2.2 or am I missing something? I tried the Developer options trick, but it isn't helping. please help !!

    Thanks
  9. #9  

    Default Re: Contacts slow to appear on my Samsung Galaxy s4 mini

    I was having the same issue. I found out that having the contacts to display limited to my one GMail account fixed the problem. Previously I had several Contact lists being displayed.

    Go to Contacts>Settings>Contacts to Display and then choose which list you want displayed
    Thanked by 2:
    4uvakjmacdon 
  10. #10  

    Default Re: Contacts slow to appear on my Samsung Galaxy s4 mini

    Quote Originally Posted by Hassan A View Post
    Hello there.

    I found this thread which explains exactly what I am facing with my Galaxy S4 Mini. Contact or anything uses Contact (ie email, writing messages ..etc) is very very slow, taking a min or two to open. sometimes I get a pop-up, saying the operation is taking so long, you want to wait or cancel .

    I never had this problem with my S3 Mini, is this a known bug with Android 4.2.2 or am I missing something? I tried the Developer options trick, but it isn't helping. please help !!

    Thanks
    I had the same problem, but wiping the cache helped. go to settings - apps - all, find contacts and contacts storage and clear the cache. also in Contacts, hit the menu button - contacts to display - and click just the gmail contacts or your main list. It might help - it worked for me.
  11. #11  

    Default Re: Contacts slow to appear on my Samsung Galaxy s4 mini

    did you ever find an answer to your question?
  12. #12  
    tjgriffin's Avatar

    Posts
    9 Posts
    Global Posts
    73 Global Posts

    Default Re: Contacts slow to appear on my Samsung Galaxy s4 mini

    Anyone? I read there was a bug in 4.2 or 4.3, but that was like a year ago. I'm having this problem too. I have an unrooted VZN GN3 purchased at the end of Jan. It was working fine up until the last week or so. Now, sometimes it takes literally 2-3 minutes for an individual's contact info to display, sometimes it comes up right away. I don't know if this is related, but K9 Mail almost always times out opening a mailbox. The list of mailboxes/accounts come up fast, but when I click one, it tries a couple minutes, then times out. If the message list does come up, opening a message suffers the same problem. I tired clearing cache in both Contacts and Contact Storage. Email and phone, this making my phone useless. I've reboot (not factory reset), reboot my wifi router, cleaned junk files as much as possible. It does this in SAFE mode too. HELP!
  13. #13  

    Default Re: Contacts slow to appear on my Samsung Galaxy s4 mini

    I'm struggling with this too, but I have an HTC incredible 4G LTE. When I go into settings-apps-all-contacts storage, my cache is already at zero. So that doesn't solve the problem for me. Please, can anyone help?
  14. #14  

    Default Re: Contacts slow to appear on my Samsung Galaxy s4 mini

    I have over 3500 contacts, and my phone worked speedily until it went to Android 4.3... Number of contacts can't be the source of the problem.
  15. #15  

    Default Re: Contacts slow to appear on my Samsung Galaxy s4 mini

    I am having the same problem since I moved from Windows Phone to Android about 3 weeks ago. I have the same number of contacts now as I had with Windows; actually even less, as I did some house-keeping by deleting some contacts thinking that would solve the problem. The problem persists, perhaps it has to do with the firmware itself and we have to wait for Samsung to update it.
  16. #16  

    Default Re: Contacts slow to appear on my Samsung Galaxy s4 mini

    Quote Originally Posted by ps1234 View Post
    I was having the same issue. I found out that having the contacts to display limited to my one GMail account fixed the problem. Previously I had several Contact lists being displayed.

    Go to Contacts>Settings>Contacts to Display and then choose which list you want displayed
    Thanks a lot! It really helps.
    I went into "contact filters" and switched off displaying all the lists except the one in the phone itself.
  17. #17  

    Default Re: Contacts slow to appear on my Samsung Galaxy s4 mini

    Quote Originally Posted by selimlok View Post
    Hi all.
    I just purchased a Samsung Galaxy s4 mini and have realized that my contacts seem to appear on the screen very slow. It sometimes takes upto 2 minutes to appear.
    Some thing you all should know is that I have 2000+ contacts (mainly clients).

    At first I was using google contacts and i assumed this was causing it to lag due to using data to refresh... but I transferred all the contacts to the device itself... so it shouldn't lag anymore!

    When people even call... there name doesnt appear, and only the phone number shows, even though I have the number installed in my contacts.
    This is also the case with text messages. When I want to compose a new text, and search for a contact... it doesnt do anything for about a minute or two.

    I have opened the developer mode, and changed the animations to off, but this hasnt solved the problem.

    If anybody could please help with this it will be much appreciated.

    Thanks
    Selim
    Exact same thing with mine. It took 2 hours to download via Wi-Fi. Battery life is white now not green too.
  18. #18  

    Default Re: Contacts slow to appear on my Samsung Galaxy s4 mini

    Experiencing the same problem - started happening a few weeks ago, not sure what changed. I have 4-5k contacts.
    Tried all the examples listed here but none worked.

    Inside the contacts app do the following:
    Contacts->Settings->Only contacts with phones (checked)


    Config info:
    Verizon S4 Mini
    Android 4.4.2
    Contact Accounts: gmail, touchdown/exchange, Device, SIM, Linkedin, G+

Similar Threads

  1. Is there a way to automatically update apps?
    By lachdanan in forum HTC One M7
    Replies: 3
    Last Post: 09-21-2013, 07:26 PM
  2. "location set by gps" notice is always on the menu?
    By preppystud in forum Google Nexus 7 Tablet (2013)
    Replies: 1
    Last Post: 09-19-2013, 09:32 AM
  3. my phone stopped detecting my sdcard
    By Det Jimenez in forum General Help and How To
    Replies: 1
    Last Post: 09-18-2013, 09:42 PM

Posting Permissions