I have ''just 5 spacer phone'' and i think it is bricked, i have rooted it but i have no custom recovery. So basically this happend i downloaded [root]Chainfire3D application and i tried to install the driver for it and my phone rebooted but it stuck there and it wont turn on and its all like in this picture and its just showing the phone model here are picture of ''about phone'' screenshot i took earlier when my phone still worked . I can't boot it in recovery mode because i tried to use volume up+power and volume down+power and all 3 together, it still just boots till the phone logo and nothing else happens it can stay like that for hours. In this link the guy has exactly the same problem, but he can boot in some download mode, i dont know what that means and i can't because my phone doesnt have physical home button. And exactly like he is i can't turn off my phone either only way to do it with removing baterry heres the link ---->
I hope someone can help me, if you need more information please ask me