Results 1 to 2 of 2
  1. Thread Author  Thread Author    #1  

    Question My screen isn't functioning properly. I need help, anyone?

    It's been just 8 hours or less, the android phone never dropped from my hand and it never got any physical damage. The screen started to go crazy in the morning when I woke up, the screen wasn't working properly and it was crazy, later I hit the power button three times then the screen started to function. And at the lunch time it started again and now I can't use the screen. The notification bar (or something you pull to use wifi) isn't working. I can't pull it down to use Bluetooth or WiFi or Mobile Data (I don't have SIM yet). Well, it never happened like this before (even if it happened it caused me less damaged). The screen went crazy, even if I wasn't touching this thing the screen was functioning all by itself. It's Android 4.3 and it's latest update for my phone and the next OS is releasing next month.

    Phone: Sony Xperia Z (C6602).
    Has 3G but no 4G and I never used 3G network.

    Please help.

    Why is my phone's screen not working properly? Do I need to use function reset to use it again?
  2. #2  

    Default Re: My screen isn't functioning properly. I need help, anyone?

    Try long pressing the power button until it powers down, which simulates a battery pull.
    Pat
    Nook Color - CM10.1 ( Jelly Bean 4.2.2) on eMMC
    Google Galaxy Nexus - stock Jelly Bean 4.3
    Galaxy Nexus 10 - stock KitKat 4.4.2
    Galaxy Nexus 7 (2nd Generation) - stock KitKat 4.4.2
    Chromecast
    Nexus 5 - stock KitKat 4.4.2

Similar Threads

  1. Replies: 4
    Last Post: 04-01-2014, 07:27 PM
  2. How Do I Organize My Icons?
    By TomBrooklyn in forum General Help and How To
    Replies: 6
    Last Post: 02-16-2014, 09:32 AM
  3. Which Android App should install in my Phone?
    By VelmaNichols in forum Android Applications
    Replies: 2
    Last Post: 02-11-2014, 05:45 AM
  4. my HTC One doesnt play youtube videos
    By jefeaguerrido in forum HTC One Series
    Replies: 0
    Last Post: 02-11-2014, 02:08 AM
  5. need help rooting AT&T I537 S4A 4.3 build number ML2 not MK2
    By rob11605 in forum Samsung Galaxy S4 Rooting, ROMs & Hacks
    Replies: 0
    Last Post: 02-10-2014, 11:34 PM

Posting Permissions

B