1. cacciucco's Avatar
    Hi, I have a G2 running stock 4.2.2, I have had intermittent problems with Google Services eating up battery. Until a couple of weeks ago turning of network location seemed to fix the issue but now even with network location turned off Google Services are constantly shown as eating 40-50% battery in the general settings. I have not changed any settings or installed any new apps. Any suggestions?
    Thanks,
    C

    Posted via Android Central App
    02-11-2014 12:52 PM
  2. VDub2174's Avatar
    I honestly don't know what it could be either. I noticed that it happens from time to time but it hasn't happened to me in a while.
    02-11-2014 01:12 PM
  3. mjl574's Avatar
    Same issue--and no-longer-working fix--as the OP. Stock Galaxy Stellar running 4.1.2.

    Sent from my SCH-I200 using Tapatalk
    02-11-2014 02:45 PM
  4. cacciucco's Avatar
    Anyone had anything to add? The phone had gone back to normal for a while and now I am back to Google Services eating 55% of battery persistently with consequent battery drain. I have not changed anything. I know I am the only one with this issue but there doesn't seem to be much to be found on the forums.
    C

    Posted via Android Central App
    03-04-2014 10:55 AM

Similar Threads

  1. Google Nexus 5 is stuck on google start page
    By Carl Hudson in forum Google Nexus 5
    Replies: 20
    Last Post: 01-04-2017, 10:49 AM
  2. How to show battery percentage in notification bar
    By Umass021 in forum Motorola Droid MAXX
    Replies: 19
    Last Post: 05-18-2014, 05:26 AM
  3. T-Mobile: Idea about Service
    By bsannes in forum T-Mobile
    Replies: 20
    Last Post: 02-13-2014, 09:05 AM
  4. HTC ONE - Google play wont download anything HELP!!!
    By kitkat1337 in forum HTC One M7
    Replies: 1
    Last Post: 02-12-2014, 07:42 AM
  5. Google services force closing.
    By dhawk1202 in forum Motorola Droid MAXX
    Replies: 3
    Last Post: 02-11-2014, 07:29 PM
LINK TO POST COPIED TO CLIPBOARD