Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 7 of 7
  1. Thread Author  Thread Author    #1  

    Default Half-working mobile data

    Hi New here...

    I currently own a Samsung Galaxy Note II, Version 4.3.
    Getting straight to the point, ever since I got my phone the mobile data has been playing up - working in some areas and not working in others -

    It works when I use mobile data to browse internet pages: dolphin browser, google chrome, even facebook posts will load.
    But when I use mobile data to play/connect to games online, watch youtube videos (or any videos for that matter via mobile data) or connect to facebook messenger, the mobile data will not work. It will keep 'loading' for hours. I left my phone loading a youtube video (via the youtube app) in the morning and came back afternoon - still loading. And I can access the youtube website via google chrome easily, search for videos easily but can't actually play them...

    This half-working mobile data is quite problematic for me, but other than that I quite like my phone as it is. I don't know if this is a common or unique problem with other Android/Samsung users; I'm new to the world of phone problems and forums. I don't know what's wrong with my phone or what to do in order to rectify the problem. Any tips on how to resolve this situation will be greatly appreciated
  2. #2  
    Golfdriver97's Avatar

    Posts
    30,848 Posts
    Global Posts
    31,339 Global Posts
    Carrier
    Pure Nexus/Franco Kernel

    Default Re: Half-working mobile data

    Quote Originally Posted by jazzy_noodles View Post
    Hi New here...

    I currently own a Samsung Galaxy Note II, Version 4.3.
    Getting straight to the point, ever since I got my phone the mobile data has been playing up - working in some areas and not working in others -

    It works when I use mobile data to browse internet pages: dolphin browser, google chrome, even facebook posts will load.
    But when I use mobile data to play/connect to games online, watch youtube videos (or any videos for that matter via mobile data) or connect to facebook messenger, the mobile data will not work. It will keep 'loading' for hours. I left my phone loading a youtube video (via the youtube app) in the morning and came back afternoon - still loading. And I can access the youtube website via google chrome easily, search for videos easily but can't actually play them...

    This half-working mobile data is quite problematic for me, but other than that I quite like my phone as it is. I don't know if this is a common or unique problem with other Android/Samsung users; I'm new to the world of phone problems and forums. I don't know what's wrong with my phone or what to do in order to rectify the problem. Any tips on how to resolve this situation will be greatly appreciated
    Welcome to the forums.
    What carrier do you have?
  3. Thread Author  Thread Author    #3  

    Default Re: Half-working mobile data

    Quote Originally Posted by Golfdriver97 View Post
    Welcome to the forums.
    What carrier do you have?
    Ah, stupid me, I forgot to include that too :L
    My carrier is Optus, Australia.
  4. #4  
    Golfdriver97's Avatar

    Posts
    30,848 Posts
    Global Posts
    31,339 Global Posts
    Carrier
    Pure Nexus/Franco Kernel

    Default Re: Half-working mobile data

    Is the device new? Have you tried taking it in for an exchange?

    From a Sprint Moto X using AC Forums app
  5. Thread Author  Thread Author    #5  

    Default Re: Half-working mobile data

    No I've had it for a few months now (only now that I'm quite fed up with it), and I bought it online so I'm not sure how I would go about 'returning' it...
    I don't know if it's the phone that's not working or if it's just my carrier.
  6. #6  
    Golfdriver97's Avatar

    Posts
    30,848 Posts
    Global Posts
    31,339 Global Posts
    Carrier
    Pure Nexus/Franco Kernel

    Default Re: Half-working mobile data

    Quote Originally Posted by jazzy_noodles View Post
    No I've had it for a few months now (only now that I'm quite fed up with it), and I bought it online so I'm not sure how I would go about 'returning' it...
    I don't know if it's the phone that's not working or if it's just my carrier.
    It may be just the carrier.

    Sent from my Nexus 5 using AC Forums mobile app
  7. Thread Author  Thread Author    #7  

    Default Re: Half-working mobile data

    I also remembered that my phone's wifi hotspot isn't working as well. It'll connect but won't actually provide wifi.

    I'll see if I can change carriers. Thanks for your help

Similar Threads

  1. Bypassing Mobile Iron for Exchange
    By Carpon in forum Android 4.4 KitKat
    Replies: 3
    Last Post: 12-03-2014, 12:27 PM
  2. Moto X: Activating on T-Mobile
    By jaeokita in forum Moto X (2013)
    Replies: 18
    Last Post: 07-01-2014, 12:17 AM
  3. Loudspeaker not working
    By Maber711 in forum HTC One M7
    Replies: 3
    Last Post: 02-17-2014, 12:06 PM
  4. Saving Saved VM on my Cellphone, T-Mobile S4
    By LadyTravel in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 02-15-2014, 10:34 PM
  5. Data drops out while on HSPA+
    By iain555 in forum Samsung Galaxy Note 3
    Replies: 1
    Last Post: 02-15-2014, 04:17 PM

Posting Permissions