Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
  1. Thread Author  Thread Author    #1  

    Default S4 - Auto-disabling Wifi on slow connection <--- How do I disable?

    Hi, All.

    So I live in an area where data is offensively expensive (South Africa) and my fiancée likes to be stuck to her S4 far more than she should.

    I have Wi-Fi at home but sometimes I'm busy downloading torrents so the connection via it isn't that quick. Though, without letting her know, the phone automatically disables the Wi-Fi connection and switches over to data which she chews through really rather quickly.

    I've got no problem with her downloading the universe when connected to my ADSL but preferably not through cellular data.

    Can anybody tell me how I can go about disabling this "auto-disabling" of the Wi-Fi connection when it detects that it is slow? I couldn't find the option but I also find the S4's settings a tad disorganised.

    I don't have this happening on my phone (BB10) so I wasn't expecting this to happen and she doesn't check the symbol at the top to see whether it's on Wi-Fi or not.

    3rd world problems, am I right?!

    EDIT: It is a Samsung Galaxy S4 running 4.3.1, I think...

    Thanks a bunch!
    Cheers
  2. #2  

    Default Re: S4 - Auto-disabling Wifi on slow connection &lt;--- How do I disable?

    It should be under Settings, Connections, WiFi (or just long-press the WiFi toggle from the notification bar). There, press the Menu button and select "Advanced". You should see a list of options; make sure "Auto network switch" is NOT selected, that the WiFi timer is OFF, and that "Keep Wi-Fi on during sleep" is set to ALWAYS.
    Thanked by:
  3. Thread Author  Thread Author    #3  

    Default Re: S4 - Auto-disabling Wifi on slow connection &lt;--- How do I disable?

    Quote Originally Posted by SpookDroid View Post
    It should be under Settings, Connections, WiFi (or just long-press the WiFi toggle from the notification bar). There, press the Menu button and select "Advanced". You should see a list of options; make sure "Auto network switch" is NOT selected, that the WiFi timer is OFF, and that "Keep Wi-Fi on during sleep" is set to ALWAYS.
    Alrighty, thanks. I thought I checked there but will do it again this evening and get back to y'all.
  4. Thread Author  Thread Author    #4  

    Default Re: S4 - Auto-disabling Wifi on slow connection &lt;--- How do I disable?

    Turns out it was that option. I purposely didn't change it when I first found it because it said "Auto Switch between Wi-Fi networks and mobile networks.".

    Unfortunately this actually means that it will neither automatically switch from Cellular to Wi-Fi, nor the reverse...despite its actual function.

    Damned thing not explaining its function properly...

    Anyway, it appears to be working.

    Thanks again!

Similar Threads

  1. Replies: 28
    Last Post: 03-28-2014, 08:47 PM
  2. HTC One: Thoughts after a couple weeks on 4.4.2
    By Darth Mo in forum HTC One M7
    Replies: 21
    Last Post: 03-03-2014, 01:04 AM
  3. Replies: 163
    Last Post: 03-02-2014, 05:32 PM
  4. Replies: 7
    Last Post: 02-25-2014, 03:49 PM
  5. Major BS on Samsung repairs
    By BubbaJon in forum Samsung Galaxy Note 10.1
    Replies: 1
    Last Post: 02-21-2014, 09:31 AM

Posting Permissions