02-11-2017 04:12 PM
28 12
tools
  1. Andrew Quann's Avatar
    Even under "edit contact", I can't change how each contact is saved. Is there an option to change this? I would like the all to be saved to gmail instead.
    02-28-2014 07:11 AM
  2. Golfdriver97's Avatar
    Even under "edit contact", I can't change how each contact is saved. Is there an option to change this? I would like the all to be saved to gmail instead.
    Welcome to the forums.

    I think maybe if you went into your Google account by Settings>Accounts tapped on your gmail, that should bring up the list of what can be synced. If you uncheck then recheck the contacts checkbox that should force a sync. If the sync takes a couple minutes, it should be fine.
    Tom Joyce1 likes this.
    02-28-2014 09:25 AM
  3. Andrew Quann's Avatar
    This sync option on syncs contacts From Gmail to phone and my Gmail contacts is empty. I want to sync from phone to gmail as well as change the way the contacts are saved in my phone... from device to gmail. Can you help with that?
    02-28-2014 12:02 PM
  4. Golfdriver97's Avatar
    This sync option on syncs contacts From Gmail to phone and my Gmail contacts is empty. I want to sync from phone to gmail as well as change the way the contacts are saved in my phone... from device to gmail. Can you help with that?
    Settings>back up and reset. Is everything checked?

    Sent from my Nexus 5 using AC Forums mobile app
    02-28-2014 02:22 PM
  5. keysgate's Avatar
    no one seems to understand what you mean here, but I know exactly what you mean and it is so aggravating. When adding a new contact to the contacts, the default action is to save to device. I also want to change the default action to save to google contacts as the new default but can not find out how to set this. I have been all through the phone and cant figure this one out and its driving me nuts, because if I forget to change each new contact to save to google contacts, it saves the contact to the device and does not show up in contacts because I only want my google contacts to show when I view my contacts, very annoying. help someone
    Delirious D, zylstra and Mrs. J like this.
    03-25-2014 05:13 PM
  6. Ann Sholem's Avatar
    I have a LG G2 with exactly the problem you describe. Did you ever find a solution?
    Delirious D likes this.
    04-26-2014 11:49 AM
  7. ttbit's Avatar
    Mine always defaults to google. I could swear I had the choice to make it default. Have you tried resetting you defaults (under main settings/apps/contacts) and then creating a contact using google? Then try to reboot. I only looked this up as someone just asked me how I did it and I can't figure out what I did. I have an S4.
    04-26-2014 04:26 PM
  8. Aaron Bisson's Avatar
    I understand what you are saying. I had the same problem today. I bought the Galaxy S5 and thought I had all my contacts set to auto sync. So when my contacts on my S4 didn't sync up with my S5 I was a bit confused. I finally saw that they were all set to device. The way I fixed this was:

    1- Enter the contacts list
    2-Click menu button
    3-Click on "SIM management"
    4-Click "Copy contacts to SIM"
    5-After all the contacts have been copied then repeat steps 1-3
    6-Once in "SIM management" again click "Copy contacts from SIM"
    7-Click Google account
    8-Once all are copied sign into your gmail on a computer.
    9-Top left says Gmail. This is a drop down menu. Click it and then pick "Contacts"
    10-When this is loaded you should then see all your contacts.

    This allowed me to have all my contacts directly update onto my S5. From this point on your contacts will always be on google and ready to sync to any new phone ore google device you get.
    Cesar Navarro and JChapa13 like this.
    05-03-2014 10:19 PM
  9. zylstra's Avatar
    Aaron, thanks for the inspiration. However, there are cases where this method won't work. For example, if half of your contacts are Google and half are Device it would be tedious to select the ones on your Device. Furthermore you wouldn't know which ones were on your Device and which ones weren't.

    I suspect that you could disconnect your Google account, "Copy contacts to SIM", reconnect your Google account, then "Copy contacts from SIM".

    There is ,however, another way to move your device contacts to Google contacts.
    TheBritton likes this.
    07-31-2014 08:19 PM
  10. Dan Harmon's Avatar
    While googling an answer I came across a samsung site with a live chat, so I asked "Jasmine." She confirmed there's no way, on a GS4, to change the default contact location to anything but "Device."

    To add a contact to gmail, you MUST click on the "+" in Contacts, then click where it says "Device" and change it to "Google" then add your contact. Annoying but I guess I'll get used to it, now that I know I'm saving it to the danged phone by default. I thought we were past the age of posting on FB: "Help! Text me your name, my phone died and I got a new one!"
    10-03-2014 02:42 PM
  11. humale's Avatar
    You can try this: Contacts/Contacts to display and check your Google account.
    10-08-2014 08:32 PM
  12. Jen Lee1's Avatar
    Go to Contacts, Import from (chose sim or device, where you normally save them) and after that it will say chose location - choose Google
    10-09-2014 11:25 PM
  13. Markus Benz's Avatar
    Go to contacts -> settings -> merge contacts -> merge contacts with google.

    My phone is in german so i dont know the correct english translation. This will sync all contacts on your device with google.
    10-24-2014 05:41 AM
  14. TXShelbyman's Avatar
    I have version 4.4.4 and am not seeing this issue. Is this version available to you?
    11-01-2014 10:21 PM
  15. colinrlee1972's Avatar
    Hi everyone. On the Note 4 this can be done following the steps below: -

    1. Contacts
    2. Menu (top right under contacts tile)
    3. Select option "Move device contacts to"
    4. Select your preferred Google account

    Now when you create a new contact you should see an option to select your preferred place to save contacts.

    Hope this helps
    Leeverage
    11-15-2014 06:42 AM
  16. speedlever's Avatar
    I have v4.4.4 (NJ4) and mine defaults to device. I cannot find a way to change the default contact save-to location either.
    11-25-2014 12:08 PM
  17. shawneebear's Avatar
    Same issue S4 V4.4.4 and I cannot get my contacts to auto sync to google I have to use a dropdown which of course I forget to do 90% of the time it also did this on 4.4.2. I also have an S5 on 4.4.2 and it auto adds to google no problem. I have reset contact defaults stopped contacts reopened. I have reset the device. Had the device replaced. Same issue no matter what I do with the S4. I work for a cell carrier and know many people with the S4 they do not have this issue. I know people who work for cell phone warranty and problems they've seen it in other devices as well like the g3 but instead they said it was backing up to another source not the device whatever carrier they were using it was syncing to their backup system. This is driving me crazy I know quite a bit about devices and how they work but it seems that there is something I have overlooked. Samsung did not help with the issue they said it's suppose to do that. I found this amusing since I had someone right next to me with their s4 and it auto defaults theirs to their google account. I have already synced all my contacts to my google at this point but I just want to be able to add a contact by default to my google like I did with my s3 and s5 and which I know s4s do as well. Has anyone came up with a fix for this?
    12-17-2014 02:01 PM
  18. smileyculture's Avatar
    awesome!!
    04-11-2015 06:58 PM
  19. max keobounphanh's Avatar
    Same issue S4 V4.4.4 and I cannot get my contacts to auto sync to google I have to use a dropdown which of course I forget to do 90% of the time it also did this on 4.4.2. I also have an S5 on 4.4.2 and it auto adds to google no problem. I have reset contact defaults stopped contacts reopened. I have reset the device. Had the device replaced. Same issue no matter what I do with the S4. I work for a cell carrier and know many people with the S4 they do not have this issue. I know people who work for cell phone warranty and problems they've seen it in other devices as well like the g3 but instead they said it was backing up to another source not the device whatever carrier they were using it was syncing to their backup system. This is driving me crazy I know quite a bit about devices and how they work but it seems that there is something I have overlooked. Samsung did not help with the issue they said it's suppose to do that. I found this amusing since I had someone right next to me with their s4 and it auto defaults theirs to their google account. I have already synced all my contacts to my google at this point but I just want to be able to add a contact by default to my google like I did with my s3 and s5 and which I know s4s do as well. Has anyone came up with a fix for this?
    04-13-2015 12:21 AM
  20. Naintara Jiwnani's Avatar
    I have the opposite problem....
    I want the default to be saved as "DEVICE" but it saves to "Samsung Account. "

    Syncing with Outlook only happens if coontact is saved as a "Device" contact.
    Once saved - cannot move to DEVICE.

    Help Please...

    N* Samsung Note 3
    04-27-2015 04:56 AM
  21. Aivlysmil3's Avatar
    Hi, I had the same problem. It seems that my default was changed from device to Google when I kept changing it to Google when I was adding contacts. And to change all the contacts in device to Google at once, just click on merge account. Choose google acc. And all contacts from device will be changed to Google. I'm using S4 too
    05-07-2015 03:04 AM
  22. MrGeeDub's Avatar
    I have the same issue with my new Galaxy S6. I'm new to Android so this "Contacts on Device" vs "Contacts on Google" is a bit confusing and frustrating to me.

    By the wording, I assume that my Google contacts are NOT on my device. So if I lose network connection or I'm on airplane mode, I will not see my Google contacts? This is not the case because when I shut off my data or go into airplane mode I still see my Google contacts on my phone. So they ARE actually on the device, right? But if I go to Contacts - Settings - Contacts To Display and select "Phone", no contacts are there. So I have no contacts on my device?

    When I try to sync my contacts to Verizon Cloud (I need to do this in order to properly use the messaging app on my PC), it tells me I have no contacts on my device to sync, even though I have over 300 Google contacts that I see on my phone (but I guess these are not on my device, or are they).

    In order to avoid all of this BS, is there a way to keep device contacts continuously synced with the Google contacts so that they mirror each other? So that if I add or edit a contact on one, it does the same to the other? I've tried importing all of my Google contacts to the device and linking them, but this causes more issues then it solves. If you edit a linked contact on device it does nothing to the Google contact and vice versa. But if you delete the linked contact on one, it deletes the other. And adding a new contact on one does not add it to the other.

    Since I'm new to the Android operating system, maybe there's something here I'm missing. If anyone can shed some light on this issue, please let me know. Thanks.
    05-13-2015 01:09 PM
  23. jranderson50's Avatar
    My contact page does not have a menu button.
    05-27-2015 10:11 AM
  24. S Maduras's Avatar
    It was pretty easy to do on my S5 version 4.4.4 (im not upgrading to lollipop 5 until they work out the bugs)

    Since I did the same thing, entered my contacts to "Device" not realizing that it cannot be backed up on Google later, this is what I did:


    Tap-contacts, then tap menu (3 dots under the word contacts top right), then tap settings, then tap Contacts,
    then tap import/export, then tap (I know this is counter-intuitive but this is not a typo) tap Export To Device Storage,
    then tap OK to confirm.
    Then you should be back at the Settings, tap Import/Export again, this time tap Import FROM Device, then tap Google

    You are done.



    To Sync with Google, make sure your phone is linked or signed into Google or Google+

    To Sync right now to make sure it is working, on the S5, go back to Home, Swipe down from the top to bring down the settings, and look for the Sync button. swipe the buttons to the left if you don't see it. (You may need to add it, do that by clicking on the top right icon with 3 squares, go to the bottom, and drag the Sync button to the active menu)
    Anyway, once you click on the Sync button, log onto your Google account on your computer, go to your contact list, and there they are!

    Bonus is you can add a ton of contacts by using your computer, which to me, is way faster than adding using my phone, then you can sync and they will appear on your phone.
    06-05-2015 10:19 AM
  25. EdreesesPieces's Avatar
    It was pretty easy to do on my S5 version 4.4.4 (im not upgrading to lollipop 5 until they work out the bugs)

    Since I did the same thing, entered my contacts to "Device" not realizing that it cannot be backed up on Google later, this is what I did:


    Tap-contacts, then tap menu (3 dots under the word contacts top right), then tap settings, then tap Contacts,
    then tap import/export, then tap (I know this is counter-intuitive but this is not a typo) tap Export To Device Storage,
    then tap OK to confirm.
    Then you should be back at the Settings, tap Import/Export again, this time tap Import FROM Device, then tap Google

    You are done.



    To Sync with Google, make sure your phone is linked or signed into Google or Google+

    To Sync right now to make sure it is working, on the S5, go back to Home, Swipe down from the top to bring down the settings, and look for the Sync button. swipe the buttons to the left if you don't see it. (You may need to add it, do that by clicking on the top right icon with 3 squares, go to the bottom, and drag the Sync button to the active menu)
    Anyway, once you click on the Sync button, log onto your Google account on your computer, go to your contact list, and there they are!

    Bonus is you can add a ton of contacts by using your computer, which to me, is way faster than adding using my phone, then you can sync and they will appear on your phone.
    THANK YOU. This solution actually works for S4, if anyone googled for this topic and is looking for a solution.
    09-21-2015 07:35 PM
28 12

Similar Threads

  1. Google Now Launcher - Adding Additional Homescreen
    By NeilWhitear in forum Google Nexus 10 Tablet
    Replies: 8
    Last Post: 05-14-2015, 12:19 PM
  2. Replies: 17
    Last Post: 03-03-2014, 03:30 PM
  3. GS4 (4.3) Link contact to another facebook contact does not work?
    By Andrew Quann in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 0
    Last Post: 02-28-2014, 07:07 AM
  4. Has anyone been able to watch purchased movies from Samsung HUB in WatchON?
    By angry english in forum Samsung Galaxy Tab Pro 10.1
    Replies: 0
    Last Post: 02-28-2014, 06:46 AM
LINK TO POST COPIED TO CLIPBOARD