1. jlwm8609's Avatar
    Hi everyone,

    This afternoon, my Samsung Galaxy Ring SPH-M840 (Android 4.1.2., never rooted) decided to stop working. I noticed something was wrong when the screen was on, but was blank. I held down the power button to reboot, and the Samsung screen came on, but the screen went blank again. I went into system recovery mode and found the following error:

    E:failed to mount /system (Invalid argument)
    can't mount '/system (Invalid argument)
    E:failed to mount /system (Invalid argument)

    # MANUAL MODE #
    -- Appling Multi-CSC. . .
    E:failed to mount /system (Invalid argument)
    can't mount '/system (Invalid argument)
    E:failed to mount /system (Invalid argument)

    I backup my phone periodically, but there are a few photos and new contacts that I added to the phone since the last backup which may now be lost. I'd like to recover them, but looks like I may be out of luck since I can't get the thing to boot. Am I right?

    Thanks,

    -Joe
    03-02-2014 09:14 PM

Similar Threads

  1. AT&T Galaxy S4: Inconsistent Service and Warranty Replacement
    By Mike Zumbrun in forum AT&T Samsung Galaxy S4
    Replies: 14
    Last Post: 05-28-2015, 07:56 PM
  2. Samsung Galaxy S6
    By Anon8154066 in forum Rumored Devices Lounge
    Replies: 15
    Last Post: 03-22-2014, 02:29 PM
  3. Warranty expired 2/25/14. My N7 died. ASUS won't honor warranty.
    By roadrat in forum Google Nexus 7 Tablet (2012)
    Replies: 4
    Last Post: 03-02-2014, 09:49 PM
  4. Sharing video between 2 Galaxy devices.
    By William Floyd in forum Samsung Galaxy S4 Active
    Replies: 0
    Last Post: 03-02-2014, 07:00 PM
  5. Galaxy S4 video recorder vs compact camcorder
    By TreoRock in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 03-02-2014, 06:02 PM
LINK TO POST COPIED TO CLIPBOARD