Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 1 of 1
  1. Thread Author  Thread Author    #1  
    PF82's Avatar

    1 Posts

    Default Android Not Compatible with USB 3.0??

    Hi there, I have a Sony Tablet S running 4.0.3 (latest version they have released). I always used USB sticks to store photos etc. I plugged a new 64GB USB 3.0 in and got the message "USB Damaged/Try Reformatting". I originally thought it was an issue with the stick but it worked on Windows and after a scan it said there are no errors/faults.

    My 2.0 USB sticks work fine. And after searching a lot, most people were saying reformat, scan, power off etc. I powered off and on, selected the usb debugging in setting etc and still get the error.

    Then, I plugged another 64GB USB 3.0 into the tablet and get the same error. Therefore it seems the tablet simply wont work with USB 3.0? They are lexar sticks from reputable retailer.

    How do I fix this??

Similar Threads

  1. Replies: 14
    Last Post: 04-14-2014, 09:28 PM
  2. Replies: 1
    Last Post: 04-11-2014, 10:55 AM

Posting Permissions