Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 9 of 9
  1. Thread Author  Thread Author    #1  

    Default Not receiving email on mobile.network

    Hi everyone. Brand new to Android here - switched from Blackberry.
    New phone (cheap ZTE Grand X), and only 300 Mb data plan. My issue is that I cannot receive emails over mobile network unless I turn OFF Restrict Background Data.However, with this option unchecked I am using way to much data. I am using my phone the same as I used my Blackberry. Frequent email checking, minimal browsing, and frequent text messaging. I never reached 150 Mb data usage in a month in 3 years with blackberry. I am now on day 5 with my new phone (Jellybean 4.3) and have used 80 Mb of data. But I"ve been mostly at home and therefore using WiFi. I do not stream music or video. I went out for an hour last night. 40 minutes of that was spent driving so I did not use the phone. I was watching my daughters cheerleading practice and sent a couple of texts, and read a couple of news articles, and used 10 Mb of data. I opened up the data usage screen and watched the data usage creep up even while I was doing nothing. So it has to be background processes. I don't mind restricting background data IF I can still receive emails. I can text message fine. I do have email set to push. By the way it's both Gmail and the native email app that don't work. If I try to sync manually I get the error "cannot connect to server". Also, have updates set to WiFi only. I think I've given all the information I can. Any ideas? I've done some searching, and see that others have had this issue, but the proposed solutions did not work for me. Thanks in advance for any help.


    EDIT: I can now get the Gmail app to work by manually refreshing (even though it's set to push).
  2. #2  

    Default Re: Not receiving email on mobile.network

    You have to remember that older Blackberry phones had much fewer apps or service that synced with the web. I'd suggest two things:

    1. Check the settings of all of your apps that might sync with the web, like Facebook, Twitter, etc. Make sure those are set to refresh at the longest interval, or manually, so that they aren't frequently syncing in the background.

    2. Use the Power Control toggle bar widget that usually comes with the phone, or install a 3rd party toggle widget like Power Toggles, and use it to turn Auto-Sync on or off whenever you want. If I know I'm not going to be using my phone constantly, I often turn off Auto-Sync off until I need it. I also may turn off mobile data (3G/4G) as well, since I usually have no need for my phone to sync in the background if I'm not going to be looking at it. The stock Power Control toggle bar doesn't have a mobile data toggle, by the way, so use Power Toggles if you want that feature.
  3. Thread Author  Thread Author    #3  

    Default Re: Not receiving email on mobile.network

    Thank you for your response. As well, I am aware that Blackberry compressed it's data so that will also account for much less Mb. After reading your suggestions, I checked the data usage again. 72 Mb of the 80 Mb used was a result of Google Play Store, Chrome, and Android OS. Gmail, Facebook, and Twitter for example TOTALLED 5.5 Mb.

    EDIT TO ADD: Google Play Store used 40 of the 80 Mb. Seems extreme. Chrome used 20, and Android OS used 12 Mb (Android OS usage was all background)
  4. #4  

    Default Re: Not receiving email on mobile.network

    Do you have Google Play Store set to Auto-Update Apps? Open the Play Store, swipe in from the left, and tap Settings. Then look at the auto-update settings.
  5. Thread Author  Thread Author    #5  

    Default Re: Not receiving email on mobile.network

    It is set to update apps over WiFi only.
  6. #6  

    Default Re: Not receiving email on mobile.network

    Did your Google Play Store recently update to the most recent version, with the Material Design appearance? That might have used up some data.

    Posted via Android Central App
  7. Thread Author  Thread Author    #7  

    Default Re: Not receiving email on mobile.network

    I don't know. I didn't get a notification of the update that I remember. How can I check it.

    Again, I just had a doctor's appointment. It's about 2 minutes from my house. Spent about 10 minutes in the waiting room. Read 2 CNN articles, and again used 10 Mb. I need to figure this out or I'll be paying a fortune for overage charges!

    Can I stop Google Play Store when I'm out on the go? What will it impact? Again, I'm new to Android, and usually figure things out on my own. However, I need some help this time so I can get it worked out before I reach my data limit. Again, thanks for your responses.

  8. #8  

    Default Re: Not receiving email on mobile.network

    I would still recommend using a toggle widget to manually toggle Auto-Sync on or off, as suggested a few posts previously. When you want to sync stuff, turn it on. When everything has been synced, turn it off.
  9. Thread Author  Thread Author    #9  

    Default Re: Not receiving email on mobile.network

    Yeah I think I will try that. Thanks for the suggestions folks.

Similar Threads

  1. Cannot receive MMS from iPhones
    By Toddzio in forum Ask a Question
    Replies: 1
    Last Post: 08-13-2014, 10:56 PM
  2. G3 Email for exchange is very slow
    By dentalexel in forum LG G3
    Replies: 1
    Last Post: 08-13-2014, 09:26 PM
  3. Problems sending and receiving SMS (T-Mobile)
    By leannelizabeth1 in forum Google Nexus 5
    Replies: 6
    Last Post: 08-13-2014, 08:50 PM
  4. no audio playing on blackberry vm-605
    By Mountain Dew Me in forum Ask a Question
    Replies: 1
    Last Post: 08-13-2014, 06:24 PM
  5. Help! My Gmail address doesn't appear in my stock email app.
    By datawalla in forum AT&T Samsung Galaxy Note 3
    Replies: 0
    Last Post: 08-13-2014, 05:36 PM

Posting Permissions