Results 1 to 3 of 3
  1. Thread Author  Thread Author    #1  
    ajpri's Avatar

    Posts
    57 Posts
    Global Posts
    58 Global Posts

    Default ART + Camera

    I believe I found a bug with Android 4.4.2 and art.
    Device: Nexus 5
    Version: 4.4.2 (KOT49H)

    When I try to use the camera with ART, it will force close on startup. It happens with Camera, Snapchat, and Instagram. As soon as I switched back to Dalvik, all issues were fixed. Sorry this is a terrible post, but has anyone had this issue?

    Posted via Android Central App on my Nexus 5 (4.4.2)
  2. #2  

    Default Re: ART + Camera

    Quote Originally Posted by ajpri View Post
    I believe I found a bug with Android 4.4.2 and art.
    Device: Nexus 5
    Version: 4.4.2 (KOT49H)

    When I try to use the camera with ART, it will force close on startup. It happens with Camera, Snapchat, and Instagram. As soon as I switched back to Dalvik, all issues were fixed. Sorry this is a terrible post, but has anyone had this issue?

    Posted via Android Central App on my Nexus 5 (4.4.2)
    Yes, but very infrequently. I use snapchat, instagram and the camera frequently. I am running ART also. I think it has happened to me twice. A simple power down and problem solved. It's been well over a month since it last happened.

    Posted via Android Central App
    Problem solved, problem staying solved!
  3. #3  

    Default Re: ART + Camera

    Quote Originally Posted by ajpri View Post
    I believe I found a bug with Android 4.4.2 and art.
    Device: Nexus 5
    Version: 4.4.2 (KOT49H)

    When I try to use the camera with ART, it will force close on startup. It happens with Camera, Snapchat, and Instagram. As soon as I switched back to Dalvik, all issues were fixed. Sorry this is a terrible post, but has anyone had this issue?

    Posted via Android Central App on my Nexus 5 (4.4.2)
    I have been using ART for over a month and have not had any issues with the stock camera app. However, I do not have either Snapchat or Instagram installed. Have you tried clearing the data and cache in the app? Tried uninstalling the other apps temporarily to see if that fixes it?
    Pat
    Nook Color - CM10.1 ( Jelly Bean 4.2.2) on eMMC
    Google Galaxy Nexus - stock Jelly Bean 4.3
    Galaxy Nexus 10 - stock KitKat 4.4.2
    Galaxy Nexus 7 (2nd Generation) - stock KitKat 4.4.2
    Chromecast
    Nexus 5 - stock KitKat 4.4.2

Similar Threads

  1. My camera is now screwed
    By SCjRqrQCnBQ19QoYCtdl in forum HTC One
    Replies: 32
    Last Post: 04-18-2014, 10:38 PM
  2. Nexus 5 Camera Auto Focus does not work
    By dubya.t in forum Google Nexus 5
    Replies: 14
    Last Post: 04-18-2014, 01:24 PM
  3. Front Camera
    By Connervt in forum Moto G
    Replies: 2
    Last Post: 01-04-2014, 07:58 AM
  4. Camera quick action
    By johnnyshinta in forum Motorola Droid MAXX
    Replies: 17
    Last Post: 01-03-2014, 05:00 PM
  5. camera lock out
    By Dennis Smith2 in forum Other ZTE Android Phones
    Replies: 0
    Last Post: 01-02-2014, 10:32 AM

Posting Permissions

B