1. PH3N0M3N's Avatar
    I've recently updated my Samsung Galaxy S4 to android 4.4.2 kitkat. Since then I've been unable to connect to the internet through mobile data. It can be activated/deactivated, but when activated I cannot connect to any websites.
    Any ideas how to fix this?
    03-30-2014 03:57 PM
  2. troshs's Avatar
    Check with your carrier. They may have to refresh something on the network. Also try to take your SIM out if you have one and put it in another phone or just take it out and put it back in. Hope this helps

    Posted via Android Central App
    Archer_dangerzone likes this.
    03-30-2014 09:32 PM
  3. PH3N0M3N's Avatar
    I've tried this today. Nothing changed, still doesn't work.
    Any other ideas?

    Later edit: After trying to reset my internet & mss settings, ever if I haven't changed anything, it seems that now the mobile data is working. Maybe it was only a carrier glitch. Don't know for sure. Hopefully it will last.
    03-31-2014 06:31 AM
  4. troshs's Avatar
    Usually that's what it is but they're too good to admit it. Glad it's working. Let us know if it quits again.

    Sent from my SAMSUNG-SGH-I337 using Tapatalk
    04-01-2014 01:30 PM
  5. TBWombat's Avatar
    My Device: Samsung Galaxy S4 (Sprint)
    I'm glad you fixed your issue. I also had a problem with mobile data. If I turned off wifi it would not switch over to mobile data. It seems to be quite common with this KitKat update. I can't testify to whether or not it worked prior to the 4.4 because I got it last week and the update was already on the phone. I can tell you that I'm positive the mobile data wasn't working until today. I tried everything -- turning on and off Airplane mode, calling Sprint to double-check that mobile data was enabled for my line, and making sure all of the settings were correct in the phone. To be honest, I still don't have the mobile data icon in the quick settings menu, it goes directly from the bluetooth icon to the reading mode icon. However, I can get to the mobile data settings the long way (through the settings menu).

    I took it to a sprint service center yesterday, and they were VERY dismissive of me because the mobile network happened to be down when I walked in and they were being flooded with upset customers. I say "flooded" because the three of us that were in the store apparently were too much for the 3 employees to handle. I just left and decided to check more Android forums. I found one that suggested a Wipe Cache Partition and a Factory Reset. How To Factory Reset Samsung Galaxy S 4 & Wipe Data

    I backed up my device and then did the Factory Reset. I waited for it to update and then wiped the cache partition. Mobile data now works for me!
    I'm not sure if both resets were necessary, it may have been fixed just from the Factory Reset, but it's what worked for me.

    I hope this helps anyone with a similar issue. My apologies for the length. Hopefully Android will fix KitKat soon!
    04-23-2014 09:38 AM
  6. Archer_dangerzone's Avatar
    Thanks for the tip Troshs. I took out the battery as well as the SIM, and when I restarted mobile data began to work again. Your post is much appreciated.

    Cheers
    04-25-2014 09:14 AM
  7. P D2's Avatar
    i have the same issue. I can not switch to mobile data from WiFi sometimes even if i toggle it on and off. Kind of annoying. It was right after i updated to KitKat. i just reboot the phone
    05-15-2014 06:46 PM
  8. DebbieHeaney's Avatar
    Similar problems here when trying to use Mobile Data.
    It will work for a while then stop working. a reboot gets it going again for a while.
    05-16-2014 09:16 AM
  9. itismonica's Avatar
    I finally stopped at Best Buy and had the Samsung rep download a 'fix', so far it's working. My phone would not go to network if I had it on wifi, had to reboot. Often, the network was 'showing' but then I couldn't make calls. It's only been an hour, but it's working. I guess it's a problem with S4's on Sprint. Best Buy said that Sprint is offering upgrades even if it's not your time. I might just go with the Note 3. What a pill. Samsung says it's not their fault, Sprint says to wait it out.
    06-18-2014 08:11 PM
  10. mikecoppins16's Avatar
    Had the same problem. Mine was with SIM pin code. Removed SIM and then replaced it, switched on phone and all ok but as soon as I switched phone off, same problem. Solution was to disable the SIM pin and all was well.
    08-05-2014 05:13 AM
  11. superfred77's Avatar
    Inside your mobile network settings, try to change the type of network that you're using, remove LTE by choosing the similar connection w/o LTE. I'm with Telus, in Canada and it seems to be a hardware issue.
    08-15-2014 05:29 PM
  12. myla dimafelix's Avatar
    good day!

    after updating my S4, i can not use my mobile data? help me on how can i use it again..

    please give me instruction on to mobile data will be activated?

    many thanks,
    09-15-2014 10:09 PM
  13. Venomous Duck's Avatar
    This is not a carrier problem. It is obviously a bug in kitkit. Both my Verizon and t mobile phones have data connection issues. Both are usually solved by closings all open tasks. Rarely a reboot. Both phones have also become VERY slow and laggy since kitkat.
    10-09-2014 09:12 PM
  14. Wasif Khan1's Avatar
    When ever i used Mobile Data then there is some dim lines on my Screen during the Mobile Data using wht this appeared tell me the solution also tell me how i can simple change 4.4.2 back into 4.2.2 tell me simple method
    12-30-2014 10:33 AM
  15. Habib Seid's Avatar
    I've recently updated my Samsung Galaxy S4 to android 4.4.2 kitkat. Since then I've been unable to connect to the internet through mobile data. It can be activated/deactivated, but when activated I cannot connect to any websites.
    Any ideas how to fix this?
    08-22-2015 06:43 AM
  16. Mai Doua Vue's Avatar
    I've recently updated my Samsung Galaxy S4 to android 4.4.2 kitkat. Since then I've been unable to connect to the internet through mobile data. It can be activated/deactivated, but when activated I cannot connect to any websites.
    Any ideas how to fix this?
    08-28-2015 10:23 PM
  17. Oshri sibony's Avatar
    I've tried this today. Nothing changed, still doesn't work.
    Any other ideas?

    Later edit: After trying to reset my internet & mss settings, ever if I haven't changed anything, it seems that now the mobile data is working. Maybe it was only a carrier glitch. Don't know for sure. Hopefully it will last.
    12-28-2015 02:22 PM

Similar Threads

  1. Replies: 8
    Last Post: 04-08-2015, 12:18 AM
  2. Google and Samsung Sync Account Problems .....
    By vja4Him in forum T-Mobile Samsung Galaxy Note 3
    Replies: 3
    Last Post: 10-01-2014, 01:41 AM
  3. Replies: 4
    Last Post: 04-08-2014, 08:53 AM
  4. Galaxy S4 to Moto G?
    By Kolten Nay in forum Samsung Galaxy S4
    Replies: 2
    Last Post: 03-30-2014, 10:58 PM
  5. You have a request? We'd like to hear about it.
    By Golfdriver97 in forum General Help and How To
    Replies: 0
    Last Post: 03-30-2014, 03:18 PM
LINK TO POST COPIED TO CLIPBOARD