1. Pedro BT's Avatar
    I'm having this issue on my Moto G. Sometimes my battery is full or almost (like 95%) and then when I plug my phone via USB to the computer and turn on USB tethering, it appears on the screen a message alerting low battery and it shuts down. Then when the phone is up again, it shows 1% in the battery menu and starts charging again.

    Anyone's having this issue? How to fix it? Thanks
    05-25-2014 07:23 PM
  2. paul beckwith2's Avatar
    I'm having this issue on my Moto G. Sometimes my battery is full or almost (like 95%) and then when I plug my phone via USB to the computer and turn on USB tethering, it appears on the screen a message alerting low battery and it shuts down. Then when the phone is up again, it shows 1% in the battery menu and starts charging again.

    Anyone's having this issue? How to fix it? Thanks
    I don't have a solution but have the exact same problem (same phone too).

    Will watch the thread.
    05-30-2014 04:35 AM
  3. paul beckwith2's Avatar
    https://forums.motorola.com/posts/7a7b068df1?page=1

    This thread has more details on the issue.
    05-30-2014 05:08 AM
  4. RudraPratap Singh's Avatar
    As I am not owning this handset, I might not suggest you the right solution to your issue. As such no useful information is attained through the internet. But while searching this issue, I found that this is a common problem in majority of the Moto G users. In many areas, the only thing I found was steps to enhance the battery life of Moto G which I am sharing with you.
    Change the power settings to Low Power.
    Close or uninstall applications to improve battery life.
    Verify that your Moto G is running the most recent software.
    Perform a soft reset.(Restart your phone to allow the phone set accordingly)
    Verify that your charger is working..

    So, these are few batter power increasing steps. Else nothing important was found.
    05-30-2014 05:47 AM
  5. paul beckwith2's Avatar
    To, RudraPratap Singh

    Please read my previous post again. The original poster of this thread should jump to the following one for more details on the problem (here's the link again):

    https://forums.motorola.com/posts/7a7b068df1?page=1

    Page 8 (& possibly 12 I think too) is informative
    05-30-2014 09:31 AM
  6. RudraPratap Singh's Avatar
    To, RudraPratap Singh

    Please read my previous post again. The original poster of this thread should jump to the following one for more details on the problem (here's the link again):

    https://forums.motorola.com/posts/7a7b068df1?page=1

    Page 8 (& possibly 12 I think too) is informative
    I have read the topic. And I have found that Motorola is personally apologizing for the issue that is being faced by most of the owners. They have mentioned that they are working hard to remove that issue and will provide full assistance to its users in regards to that.
    06-03-2014 02:28 AM

Similar Threads

  1. Couldn't install on USB storage or SD card
    By Richie Goldsworthy in forum General Help and How To
    Replies: 8
    Last Post: 01-18-2015, 02:49 PM
  2. Cerberus not working after Kitkat update
    By jim2112 in forum Verizon Samsung Galaxy Note 3
    Replies: 5
    Last Post: 07-24-2014, 04:47 AM
  3. Official Sprint 4.4 Update and keeping Root Access when upgrading?
    By storino03 in forum Sprint Galaxy S III
    Replies: 2
    Last Post: 05-26-2014, 07:32 AM
  4. How to root Droid Razr HD with kitkat
    By FuttBucker in forum RAZR Rooting, ROM's, and Hacks
    Replies: 1
    Last Post: 05-25-2014, 10:30 PM
  5. Replies: 0
    Last Post: 05-25-2014, 12:11 PM
LINK TO POST COPIED TO CLIPBOARD