1. casey0999's Avatar
    Hello-
    Experiencing very slow access to the internet with this new device, which just got. It takes 4-5 seconds after I type a web site address before the results start appearing.

    Have run speedtest.net and all is well with Very fast up/down times and fast ping times. There do not appear to be other applications (Dropbox, Evernote, etc) running up or downloads.

    A laptop (and also my Galaxy S3) do not have these delays and are much faster.

    Would appreciate anyone's approach to troubleshooting this problem.

    Thanks
    06-21-2014 04:39 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Is this on wi-fi or mobile data, or both?
    06-21-2014 04:52 PM
  3. casey0999's Avatar
    Wifi, with a fast connection to Comcast
    06-21-2014 05:29 PM
  4. B. Diddy's Avatar
    Review this guide and see if any of the tips help: http://forums.androidcentral.com/amb...-problems.html.

    I would focus on the security settings first. Make sure the router is set to WPA2, AES.
    06-21-2014 06:07 PM
  5. casey0999's Avatar
    Thanks for your reply. I've read through that page, and most of those issues would negatively affect speedtest.net results, which show excellent results. Right now, I'm on the track of a possible DNS issue.

    Thanks again...
    06-22-2014 11:59 AM
  6. casey0999's Avatar
    Just a followup to say that I've found a problem in the DNS setup within my router.

    Fixing this to make sure that all DNS addresses are working and fast solved the problem, and now the Note is accessing the internet at rapid speeds.

    I was helped out by the Windows program called DNSBench by Gibson Research which led me to discover that one of the DNS addresses on my router was not responding. Windows lets you override these in your network adapter. Android? Not so easy, and I couldn't get any of the Fixed DNS android apps to work. Anyway, once I discovered and fixed the root problem in my Cisco router, all was well.

    Thanks to all...
    B. Diddy likes this.
    06-22-2014 02:52 PM
  7. B. Diddy's Avatar
    Excellent! Thanks for your detailed solution.
    06-22-2014 07:49 PM
  8. john_brockman's Avatar
    I'm Having The Same Problem But With My Mobile Data, I Would appreciate anyone's approach to troubleshooting this problem.
    08-27-2014 06:37 AM

Similar Threads

  1. MOTO X Internet connections Wifi/4G LTE
    By 2120SoMichiganAve in forum Moto X (2013)
    Replies: 10
    Last Post: 06-24-2014, 05:21 PM
  2. I'm loving the kitkat upgrade!
    By jordo487 in forum Samsung Galaxy Tab 3
    Replies: 8
    Last Post: 06-23-2014, 12:27 AM
  3. will my galaxy work in japan?
    By pinksuagrss in forum Ask a Question
    Replies: 5
    Last Post: 06-22-2014, 03:10 PM
  4. Samsung Galaxy S3 won't turn on, help
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 06-21-2014, 07:34 PM
  5. kitkat keyborad
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-21-2014, 06:37 PM
LINK TO POST COPIED TO CLIPBOARD