Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 16 of 16
Like Tree1Likes
  • 1 Post By philmair
  1. Thread Author  Thread Author    #1  
    philmair's Avatar

    Posts
    36 Posts
    Global Posts
    113 Global Posts

    Default Kitkat hates wifi !!!

    OK when I first upgraded the unstable wifi was a bit annoying. Now it's getting REALLY annoying.

    There are hundreds of forums where users are reporting wifi problems. Mainly the wifi drops and the wifi option is greyed out. Lots of "fixes" ranging from switching on and off flight mode to a factory reset. All useless of course because there is a fundamental bug in 4.x.

    So am I expecting an official fix soon ???? Don't be f@##@ stupid ... I'm a seasoned Android/Samsung user ... I expect nothing and won't be disappointed.

    Posted via Android Central App
    Galaxy Note 2 EE/T-Mobile (KitKat 4.4.2) + Galaxy Gear 2 Neo
    Galaxy Note 8.0 (KitKat 4.4.2)
  2. #2  

    Default Re: Kitkat hates wifi !!!

    So for those of us that have been dealing with this for a while, we've figured out that changing DCHP to static (while connected) solves the problem. To get there, go to your Wifi settings, press and hold your Wifi SSID to get the option to modify network. Then click show advanced options. There you will see DCHP. Press that to change to static.

    Hope this helps.

    Sent from my "no longer 120° or battery guzzling" Sprint Galaxy Nexus, thanks to help from the AC forum
    Thanked by:
  3. Thread Author  Thread Author    #3  
    philmair's Avatar

    Posts
    36 Posts
    Global Posts
    113 Global Posts

    Default Re: Kitkat hates wifi !!!

    gnr_2 ... many thanks .. I've given that a go. At work I have several SSIDs depending on location as well as one for home and others. So I've done this for the primary work wifi network ... it won't seem to let me repeat this for all SSIDs (greys out the Save button after the first SSID DCHP change).

    But I'll see what happens ... nice to discover even more "hidden" setting though !
    Galaxy Note 2 EE/T-Mobile (KitKat 4.4.2) + Galaxy Gear 2 Neo
    Galaxy Note 8.0 (KitKat 4.4.2)
  4. #4  

    Default Re: Kitkat hates wifi !!!

    You have to be connected to the SSID at the time! I was skeptical but it's worked for me for about a month.

    Sent from my "no longer 120° or battery guzzling" Sprint Galaxy Nexus, thanks to help from the AC forum
  5. #5  

    Default Re: Kitkat hates wifi !!!

    I am not an expert but if some have the problem and some, like me, don't is the variable KitKat or the cell phone?
  6. #6  

    Default Re: Kitkat hates wifi !!!

    I'm no expert either. I think the variable is the wifi connection that KitKat is trying to use. It does something similar with data connections back and forth between 3g and 4g.

    Sent from my "no longer 120° or battery guzzling" Sprint Galaxy Nexus, thanks to help from the AC forum
  7. Thread Author  Thread Author    #7  
    philmair's Avatar

    Posts
    36 Posts
    Global Posts
    113 Global Posts

    Default Re: Kitkat hates wifi !!!

    My phone and my tablet ... both with the same version of Kit kat .... behave differently. The phone has the wifi issue but the tablet is fine.

    Posted via Android Central App
    Galaxy Note 2 EE/T-Mobile (KitKat 4.4.2) + Galaxy Gear 2 Neo
    Galaxy Note 8.0 (KitKat 4.4.2)
  8. Thread Author  Thread Author    #8  
    philmair's Avatar

    Posts
    36 Posts
    Global Posts
    113 Global Posts

    Default Re: Kitkat hates wifi !!!

    Silly question, but .... has anyone heard anything about rolling out a WiFi fix? Its been a month now and applying the various workarounds (switching flight mode on/off works for me) several times every day is getting a bit tiresome.

    Sometime soon I'm going to start challenging my network provider with the "fitness for purpose" line and asking for a refund. So before I embark down this tedious route, I just want a final check that a satisfactory resolution isn't imminent.
    Galaxy Note 2 EE/T-Mobile (KitKat 4.4.2) + Galaxy Gear 2 Neo
    Galaxy Note 8.0 (KitKat 4.4.2)
  9. #9  

    Default Re: Kitkat hates wifi !!!

    Dude,

    Sorry to hear. What ROM are you using for your phone? I am using Slimroms on Samsung S2, Kit Kat version and i have no issue with wifi.
  10. #10  

    Default Re: Kitkat hates wifi !!!

    Wifi fixer and more

    Sent from my SAMSUNG-SGH-I317 using Tapatalk 4
  11. Thread Author  Thread Author    #11  
    philmair's Avatar

    Posts
    36 Posts
    Global Posts
    113 Global Posts

    Default

    Thanks for the replies.

    1. Standard ROM ... not rooted.
    2. Wifi fixer ... I'll try but ....

    ...that's missing the point. I've got an official phone with an official ROM with an official Kitkat update ... and it doesn't work and it hasn't worked for over a month.

    So why should I and 100s ( maybe 1000s ) of CONSUMERS have to put up with being sold products that don't work. This IS a criminal offence and it's about time we exercised our rights and stop just accepting ****.

    It's a matter of principle.

    Posted via Android Central App
    Galaxy Note 2 EE/T-Mobile (KitKat 4.4.2) + Galaxy Gear 2 Neo
    Galaxy Note 8.0 (KitKat 4.4.2)
    gnr_2 likes this.
  12. #12  
    Sicily1918's Avatar

    Posts
    98 Posts
    Global Posts
    145 Global Posts
    ROM
    Stock Android 4.4.4

    Default Re: Kitkat hates wifi !!!

    This is not a KitKat problem; I have two N4's, two 2012 N7's, and one 2013 N7, all on KitKat, none have experienced this issue.

    Seems like it's a Note2 (on KitKat) issue.

    Does it do it on all WiFi connections or just at home? You could try to update the router's firmware (if the latter) and see if that fixes it. Also, is there a WiFi battery saver app and/or setting you have going that could do this (e.g., "Keep WiFi on during sleep" in Advanced WiFi Settings -- I set it to "Always").
    Nexus4 - Stock 4.4.4
    Nexus7 - Stock 4.4.4
  13. Thread Author  Thread Author    #13  
    philmair's Avatar

    Posts
    36 Posts
    Global Posts
    113 Global Posts

    Default Re: Kitkat hates wifi !!!

    Quote Originally Posted by Sicily1918 View Post
    This is not a KitKat problem; I have two N4's, two 2012 N7's, and one 2013 N7, all on KitKat, none have experienced this issue.

    Seems like it's a Note2 (on KitKat) issue.

    Does it do it on all WiFi connections or just at home? You could try to update the router's firmware (if the latter) and see if that fixes it. Also, is there a WiFi battery saver app and/or setting you have going that could do this (e.g., "Keep WiFi on during sleep" in Advanced WiFi Settings -- I set it to "Always").
    Sicily1918 you are correct .. it is not simply a KitKat issue ... I have a Note8 with the same version of KitKat and there is no problem. It is just the Note2. Both use the same routers and both have the same WiFi/Battery settings. Hence my gripe is with the Carrier (or more specifically the carrier's version of KitKat for the Note2).

    I'll take the issue up with them - they either need to fix it in a reasonable timeframe or provide me with an acceptable alternative ... that's basic consumer law.
    Galaxy Note 2 EE/T-Mobile (KitKat 4.4.2) + Galaxy Gear 2 Neo
    Galaxy Note 8.0 (KitKat 4.4.2)
  14. #14  

    Default Re: Kitkat hates wifi !!!

    Quote Originally Posted by philmair View Post
    Thanks for the replies.

    1. Standard ROM ... not rooted.
    2. Wifi fixer ... I'll try but ....

    ...that's missing the point. I've got an official phone with an official ROM with an official Kitkat update ... and it doesn't work and it hasn't worked for over a month.

    So why should I and 100s ( maybe 1000s ) of CONSUMERS have to put up with being sold products that don't work. This IS a criminal offence and it's about time we exercised our rights and stop just accepting ****.

    It's a matter of principle.

    Posted via Android Central App
    So stop bying cutting edge technology and you wont be plagued by problems that come about when running software that wasent even written yet for your old device.

    And vote with your dollars.
    And hey, I haven heard of anyone having issues with flip phones for a long time. Seems like a good solid working purchase to me.

    This wole system is built by humans. Humans make mistakes. Lets sue them for every mistake. I mean its criminal. That kind of thibking strangles inovation. Is that what you truly want?

    I know it sucks when it happens to you. I was just told by inokin that they dont cover the 510 connector of my vape pin. So I quit vaping, screw them. No more dollars from me. But at the same time. If they dont want to cover it, thats their perogitive. I dont care because it made them not get way more money than that thing costs new over my lifetime.


    So exercise your rights, stop buying ****.

    Sent from my SAMSUNG-SGH-I317 using Tapatalk 4
  15. #15  

    Default Re: Kitkat hates wifi !!!

    Quote Originally Posted by philmair View Post
    Sicily1918 you are correct .. it is not simply a KitKat issue ... I have a Note8 with the same version of KitKat and there is no problem. It is just the Note2. Both use the same routers and both have the same WiFi/Battery settings. Hence my gripe is with the Carrier (or more specifically the carrier's version of KitKat for the Note2).

    I'll take the issue up with them - they either need to fix it in a reasonable timeframe or provide me with an acceptable alternative ... that's basic consumer law.
    This is why I still run the os that the device was deaigned to run.

    Jelly for life on my note ii.

    Sent from my SAMSUNG-SGH-I317 using Tapatalk 4
  16. #16  

    Default Re: Kitkat hates wifi !!!

    Quote Originally Posted by Sicily1918 View Post
    This is not a KitKat problem; I have two N4's, two 2012 N7's, and one 2013 N7, all on KitKat, none have experienced this issue.

    Seems like it's a Note2 (on KitKat) issue.

    Does it do it on all WiFi connections or just at home? You could try to update the router's firmware (if the latter) and see if that fixes it. Also, is there a WiFi battery saver app and/or setting you have going that could do this (e.g., "Keep WiFi on during sleep" in Advanced WiFi Settings -- I set it to "Always").
    I don't have a Note 2 and the main thing experiencing this problem if you do research on it, is the Nexus7 2013 which was the first thing released with KitKat. Also, none of the other phones had issues until they were updated with KitKat so maybe it's a KitKat problem. It might ultimately be related to routers or something else but it whatever the issue, it wasn't an issue until KitKat entered the picture.

Similar Threads

  1. Flashing European kitkat onto censored Chinese model - need L50u baseband drivers
    By banjo67xxx in forum Sony Xperia Z2 Rooting, ROMs, & Hacks
    Replies: 2
    Last Post: 09-14-2014, 12:15 PM
  2. Replies: 3
    Last Post: 07-18-2014, 08:05 AM
  3. WiFi Invalid Certificate - T-Mobile
    By henryfool3 in forum HTC One (M8)
    Replies: 5
    Last Post: 07-18-2014, 12:01 AM
  4. Downgrading from KitKat
    By neil154 in forum Verizon Galaxy S3
    Replies: 3
    Last Post: 07-17-2014, 10:49 PM
  5. after Kit Kat update, wifi sometimes doesn't turn on after phone wakes up
    By yourphonemyphone in forum Verizon Galaxy Note 2
    Replies: 7
    Last Post: 07-17-2014, 09:41 PM

Posting Permissions