Results 1 to 21 of 21
  1. Thread Author  Thread Author    #1  

    Default Map Vlingo to Long-Press Search?

    Since Vlingo made their Voice Search app free yesterday, and since we can't get the new features that Google added to their Voice Search app until Froyo hits...

    Is there a way to map Vlingo to my Long Press Search hardware button to make it the default voice command application?
  2. #2  

    Default

    I'd love to know the answer to this one myself. I'm tempted to install it, even though it may become obsolete as soon as Froyo gets loaded with the new Google Voice input features.

    Nuance is working for me pretty well, insofar as Bluetooth voice dialing, and I'm concerned about possibly mucking up the works by putting in software that competes for system hooks.
  3. Thread Author  Thread Author    #3  

    Default

    For now, I just added a micro-widget to the front page of my X, but I'd really like to not have to do that.
  4. #4  

    Default

    /bump for same answer as above
  5. #5  

    Default

    When I long press it prompts me to "Complete action using" and then allows me to choose Vlingo or Voice search. There is a check box that allows "Use by default for this action". This is on the Droid Incredible running 2.1.
  6. #6  

    Default

    Quote Originally Posted by vicw926a4 View Post
    I'd love to know the answer to this one myself. I'm tempted to install it, even though it may become obsolete as soon as Froyo gets loaded with the new Google Voice input features.
    Trust me, unless Google performs some miraculous overhaul by the time you get 2.2, the new voice app can't hold Vlingo's jock. Vlingo beats the native app, hands down.

    When you install Vlingo, it sets itself up as a long press option. If there's already a default program set up, go to applications settings and choose that program. Then clear out the option to launch by default. When you long press, it will give you the option to set the default program, one of which will be Vlingo.
    Thanked by:
  7. #7  

    Default

    Quote Originally Posted by Cobravision View Post
    Trust me, unless Google performs some miraculous overhaul by the time you get 2.2, the new voice app can't hold Vlingo's jock. Vlingo beats the native app, hands down.

    When you install Vlingo, it sets itself up as a long press option. If there's already a default program set up, go to applications settings and choose that program. Then clear out the option to launch by default. When you long press, it will give you the option to set the default program, one of which will be Vlingo.
    Thanks for that. It was as you said on my DX, except that I had to power cycle the phone first. Initially, when I long pressed the search button, the DX just semi-froze, except that a Home took it back to normal, without doing a search.

    I'm also a fan of Vlingo, having used it on my iPhone. I did note a couple of differences already between it and the Nuance software that is built-in to the DX. On making a call, Vlingo easily copes with the Last Name, First Name sort arrangement that I have on my DX, so I can say "John Smith", even though it appears in the Contacts as "Smith, John", whereas Nuance just can't figure that out, unless I say it as "Smith John".

    On the downside for Vlingo, it doesn't seem very practical for no touch dialing via Bluetooth, since, unlike Nuance, it insists on a key press to verify phone number selections.
  8. #8  

    Default

    I noticed you have to power cycle after installing Vlingo. When I first installed it, it would sit at the voice input screen and wouldn't understand anything I said.

    The lack of voice confirmation limits the ability to use Vlingo as a hands free dialer.
  9. #9  
    Corey's Avatar

    Posts
    255 Posts
    Global Posts
    430 Global Posts

    Default

    Quote Originally Posted by vicw926a4 View Post

    On the downside for Vlingo, it doesn't seem very practical for no touch dialing via Bluetooth, since, unlike Nuance, it insists on a key press to verify phone number selections.
    I haven't played around with it too much, but it looks like there's an Auto-Dial option in the Settings. I believe the default is set to "When Confident" but it can be changed to Always or Never as well. That may help fix that problem.

    I've been trying for about half an hour to get Vlingo mapped to my search button on my DX, but haven't found any success. Long pressing on the search button just brings up the stock google search, and I can't seem to find any setting to change it. I've powered off the phone, gone through all the settings menus I can think of and have come up blank. Any help would be greatly appreciated.
    Witty euphemism, clever pun.
  10. #10  

    Default

    Like I said, go to the Application settings and under Google Voice Search (or whatever it's called), clear the "opens by default" setting. This will allow you to choose Vlingo when you long press search.

    Vlingo can autodial, but that's an inadequate solution.
  11. #11  
    Corey's Avatar

    Posts
    255 Posts
    Global Posts
    430 Global Posts

    Default

    Quote Originally Posted by Cobravision View Post
    Like I said, go to the Application settings and under Google Voice Search (or whatever it's called), clear the "opens by default" setting. This will allow you to choose Vlingo when you long press search.

    Vlingo can autodial, but that's an inadequate solution.
    Voice Search is showing No Defaults Set, yet a long press still brings up the Google Voice Search automatically. I'm stumped.
    Witty euphemism, clever pun.
  12. #12  

    Default

    Quote Originally Posted by Corey View Post
    I haven't played around with it too much, but it looks like there's an Auto-Dial option in the Settings. I believe the default is set to "When Confident" but it can be changed to Always or Never as well. That may help fix that problem.

    I've been trying for about half an hour to get Vlingo mapped to my search button on my DX, but haven't found any success. Long pressing on the search button just brings up the stock google search, and I can't seem to find any setting to change it. I've powered off the phone, gone through all the settings menus I can think of and have come up blank. Any help would be greatly appreciated.
    I saw that, but I don't have that much confidence in the voice recognition to pick out the right name and number. Nuance announces that info before proceeding, so there is an opportunity to cancel out before an unwanted call.

    I'm not certain yet, but it seems as if the presence of Vlingo on my DX may be causing a problem with incoming calls via the Bluetooth hands-free. My voice can be heard by the caller, but I can't hear them. I think every call I've received since I installed Vlingo has had that problem, but I need to continue testing. Outbound calls seem OK.
  13. Thread Author  Thread Author    #13  

    Default

    One thing the new Google Voice Actions does that Vlingo doesn't is music control. That's big for me.

    Also, I don't see any defaults set in the app manager for Voice Search, but as said above, it does launch by default when I long press the search key.
  14. Thread Author  Thread Author    #14  

    Default

    Okay, I figured it out. I cleared the data and cache of the Voice Search app, and chose to force stop it from the app manager. Next time I long pressed, I got the app chooser, and the ability to make Vlingo my default.

    EDIT: I stand corrected, it went right back to Voice Search after I finished trying this out.
  15. #15  

    Default

    I am actually hoping to map Vlingo to the bluetooth voice dialer activation button... Anyone have any luck doing this?
  16. #16  

    Default

    Quote Originally Posted by drewmg View Post
    Okay, I figured it out. I cleared the data and cache of the Voice Search app, and chose to force stop it from the app manager. Next time I long pressed, I got the app chooser, and the ability to make Vlingo my default.

    EDIT: I stand corrected, it went right back to Voice Search after I finished trying this out.
    I can confirm that on DROIDX. Here were my steps:
    Uninstall Vlingo
    Force a stop on the Voice Search App
    Restart the DROIDX
    Startup and d/l and install Vlingo.

    On the first long-press search button I got two things: prompt for Google and a "choose the application" screen. I chose Vlingo and set it as the default, yet the long-press search always invokes the Google box. It has totally hijacked that key.
  17. #17  

    Default

    I get the same thing, so I just use the widget.

    Sent from my DROIDX using Tapatalk
  18. #18  
    4cdndctn's Avatar

    Posts
    62 Posts
    Global Posts
    103 Global Posts

    Default

    Quote Originally Posted by drewmg View Post
    Okay, I figured it out. I cleared the data and cache of the Voice Search app, and chose to force stop it from the app manager. Next time I long pressed, I got the app chooser, and the ability to make Vlingo my default.

    EDIT: I stand corrected, it went right back to Voice Search after I finished trying this out.
    drewmg, just below where you clear the data and cache is a default option in which it will indicate you have selected Voice Search as a default app. You need to clear that. Upon doing so, the next time you long press the search button, you'll be presented with multiple choices.

    Good luck!
  19. #19  
    jaycook777's Avatar

    Posts
    3 Posts
    Global Posts
    10 Global Posts

    Default

    Droid X. Android 2.2

    Nope. I do not have a default listed in either Vlingo or Voice Search. Under "Launch By Default" it says "No defaults set." On both apps.

    Home Screen>Settings>Applications>Manage Applications>All>Vlingo or Voice Search.

    I would really like to be able to hold down the far right button (search) and get Vlingo and not Google Voice Search. Thanks for any help, Jay.
  20. #20  
    jaycook777's Avatar

    Posts
    3 Posts
    Global Posts
    10 Global Posts

    Talking Remapping search button to activate Vlingo.

    Finally, I found an app that does this. It's called HomeSmack.

    I can now long-press the search button and Vlingo will open.

    Droid X running 2.2.
  21. #21  
    markm's Avatar

    Posts
    27 Posts
    Global Posts
    187 Global Posts

    Default

    Exactly what I was looking for, but it says that it is unlikely to work on Motorola devices unless you install the long search hack which requires the phone to be rooted. Not ready to leap in to the rooting the phone game yet on my 1 week old Droid 2. I brought down Button Shortcut which let me map Vlingo to the camera button. I use Vlingo a lot more than the camera.
    Rgds/Mark M.

Posting Permissions

B