Page 1 of 2 12 LastLast
Results 1 to 25 of 39
  1. Thread Author  Thread Author    #1  
    macjazzy's Avatar

    Posts
    69 Posts
    Global Posts
    80 Global Posts

    Default Need a text messenger app that works on wifi

    Inside the shop at my work Verizon has no signal at all. The other carriers have great signals for some reason but Verizon....nothing.

    When people call, sometimes it will ring, but I need to rush outside to answer, although most of the time it goes straight to voicemail. Text messages are hit or miss.

    We have a wifi router in the shop that my phone connects to. So I thought if I could get a wifi text messenger app then my wife and other important people can get in touch with me if they need.

    Is there an app that I can recieve and send text messages via my wifi signal that other people can send to and recieve from me through their regular cell phone service? Even if I have to use a different number.
    Last edited by macjazzy; 05-31-2011 at 08:02 AM. Reason: spelling
  2. #2  
    srkmagnus's Avatar

    Posts
    6,743 Posts
    Global Posts
    6,746 Global Posts
    ROM
    Stock 4.4 (KitKat)

    Default

    Quote Originally Posted by macjazzy View Post
    Inside the shop at my work Verizon has no signal at all. The other carriers have great signals for some reason but Verizon....nothing.

    When people call, sometimes it will ring, but I need to rush outside to answer, although most of the time it goes straight to voicemail. Text messages are hit or miss.

    We have a wifi router in the shop that my phone connects to. So I thought if I could get a wifi text messenger app then my wife and other important people can get in touch with me if they need.

    Is there an app that I can recieve and send text messages via my wifi signal that other people can send to and recieve from me through their regular cell phone service? Even if I have to use a different number.
    I think Google Voice will do just that. Sign-up for an account and give it a try. You may also check the Google Voice Faqs to see if this is possible if you don't want to sign-up without knowing.

    You might have to be given a second number if you don't want to port your current number to Google Voice. If it's only a few people you are worried about getting a hold of you in an emergency, then a second number might not be so bad.
    Last edited by srkmagnus; 05-31-2011 at 08:20 AM.
  3. Thread Author  Thread Author    #3  
    macjazzy's Avatar

    Posts
    69 Posts
    Global Posts
    80 Global Posts

    Default

    Don't I need an invite for Google Voice?
  4. #4  

    Default

    Quote Originally Posted by macjazzy View Post
    Don't I need an invite for Google Voice?
    You may not have to anymore. Give it a shot. If you need an invite lemme know. I think I have some. I know it does work over Wi-fi as I have used it when the network went down before. It does have a different number as its your Google Voice number but in your situation it would be fine.
    Thanked by:
  5. Thread Author  Thread Author    #5  
    macjazzy's Avatar

    Posts
    69 Posts
    Global Posts
    80 Global Posts

    Default

    Thanks for the advice, I was able to sign up without an invite, and I downloaded the android app for it, which says I can send and recieve texts via wifi, although I can not figure out how to do that from the app.

    Any help doing that would be greatly appreciated.
  6. #6  
    srkmagnus's Avatar

    Posts
    6,743 Posts
    Global Posts
    6,746 Global Posts
    ROM
    Stock 4.4 (KitKat)

    Default

    Open the Google Voice app and press Menu > Compose to send a text

    If the Compose tab is not there go to Menu > Labels > Text

    To receive just have your wife send a text to the Google Voice number you were given. Have her test it just to make sure everything works fine. Hope this helps.
  7. Thread Author  Thread Author    #7  
    macjazzy's Avatar

    Posts
    69 Posts
    Global Posts
    80 Global Posts

    Default

    srkmagnus, thanks for the idea, I did try that, it went through but her test text did not come back to my phone, I can access her texts via my computer, but so far not from the app.
  8. #8  
    srkmagnus's Avatar

    Posts
    6,743 Posts
    Global Posts
    6,746 Global Posts
    ROM
    Stock 4.4 (KitKat)

    Default

    From the Google Voice page on the computer:

    Options (top right corner of the page) > Voice Settings > Edit > Text Settings

    Check the box to enable text messages for the phone number you have activated. Give that a try.
  9. #9  

    Default

    Quote Originally Posted by macjazzy View Post
    srkmagnus, thanks for the idea, I did try that, it went through but her test text did not come back to my phone, I can access her texts via my computer, but so far not from the app.
    Try going under the settings on your PC. There is a section called Voice and Text I think. Mine works but I also have my voicemail going through Google Voice which I enjoy because it also sends me a transcribed version of the VM to my gmail. Then I can read the VM if I am busy. Anyway, I think it basically sets it up to forward which may be why my texting come to the phone as well.

    Or try looking through the settings in the app. Under Sync and notifications I have notify via text msg checked. Not sure what the defaults are.
  10. Thread Author  Thread Author    #10  
    macjazzy's Avatar

    Posts
    69 Posts
    Global Posts
    80 Global Posts

    Default

    Ok, I am breaking this down A bit, all the texts are being sent straight to my regular sms app (go sms) which I am not getting them because that app uses cell signal, which I have none of, instead of Wifi, which is the reason for trying this.
    When I go to the google voice app, is shows no incoming texts, and no way to send a text except to teh google voice mail I got in my inbox welcoming me to google voice.
    I am pretty sure it is a setting in something, but obviously I don't have it right.
    Anyone?
  11. #11  
    srkmagnus's Avatar

    Posts
    6,743 Posts
    Global Posts
    6,746 Global Posts
    ROM
    Stock 4.4 (KitKat)

    Default

    Did you try the settings CloeHokie and I posted?
  12. #12  

    Default

    Quote Originally Posted by macjazzy View Post
    Ok, I am breaking this down A bit, all the texts are being sent straight to my regular sms app (go sms) which I am not getting them because that app uses cell signal, which I have none of, instead of Wifi, which is the reason for trying this.
    When I go to the google voice app, is shows no incoming texts, and no way to send a text except to teh google voice mail I got in my inbox welcoming me to google voice.
    I am pretty sure it is a setting in something, but obviously I don't have it right.
    Anyone?
    When I open my Google Voice I can do the following.

    Hit menu, and pick labels. Then it should show a list. Pick Text.

    When you are in the text section you should be able to hit menu again and see an option for compose. I just tested mine.
  13. Thread Author  Thread Author    #13  
    macjazzy's Avatar

    Posts
    69 Posts
    Global Posts
    80 Global Posts

    Default

    When I go through the selections like you posted, Cloe Hokie, when I hit menu, from the text screen the options I have are "refresh", "lables", " balance", "search", "settings", "help"

    The only way I get a button that says compose is if I am on the screen with the one message I have recieved on my phone, which was the welcome message, and when I select compose there it looks like it is going to send a text to thenumber the welcome message originated from.
  14. #14  
    srkmagnus's Avatar

    Posts
    6,743 Posts
    Global Posts
    6,746 Global Posts
    ROM
    Stock 4.4 (KitKat)

    Default

    Go to Labels and choose Text. From there press Menu > Compose. Enter the number you want to send a text to and compose the message.
  15. #15  

    Default

    I have a similar problem on my iPhone and use Google Voice /w Skype to ensure if I get a call some bit of the phone rings. You can configure GV to forward to Skype after your cell phone sends it to GV for voicemail.
  16. Thread Author  Thread Author    #16  
    macjazzy's Avatar

    Posts
    69 Posts
    Global Posts
    80 Global Posts

    Default

    I am really just trying to get this set up to be able to send and recieve texts via wifi, which from what I have read, I can do on Google Voice, but so far I have not been able to figure out how to confiure it to work that way.
  17. #17  
    srkmagnus's Avatar

    Posts
    6,743 Posts
    Global Posts
    6,746 Global Posts
    ROM
    Stock 4.4 (KitKat)

    Default

    Let's try and problem solve.

    Have you enabled text messaging from the PC web page?

    Can you get to the compse message via the app?
  18. #18  

    Default

    Quote Originally Posted by macjazzy View Post
    When I go through the selections like you posted, Cloe Hokie, when I hit menu, from the text screen the options I have are "refresh", "lables", " balance", "search", "settings", "help"

    The only way I get a button that says compose is if I am on the screen with the one message I have recieved on my phone, which was the welcome message, and when I select compose there it looks like it is going to send a text to thenumber the welcome message originated from.
    Quote Originally Posted by srkmagnus View Post
    Go to Labels and choose Text. From there press Menu > Compose. Enter the number you want to send a text to and compose the message.
    Yeah that should work. Pick labels where you said you saw it. And from there you should see Text.
  19. Thread Author  Thread Author    #19  
    macjazzy's Avatar

    Posts
    69 Posts
    Global Posts
    80 Global Posts

    Default

    When I select labels, then text, there is no compose button, The only time I can get a compose button is when I am on the inbox screen, and the only thing in my inbox is the welcom message from google.

    When I select compose from there it does ot give me the option of inputting a number to text to, in other words it will only let me text to the message in the inbox, which is the elcome message.

    Yes recieve texts is selected in the google voice home page on my computer, and my correct cell number is the phone listed as the forward to number, and it is listed as being a mobile phone.

    I am getting her texts to my phone, but I need to go outside the shop to get a cell signal. So they are not coming in via wifi, as I have a strong wifi signal that does not have any thing blocked or any filters on it.

    So as of right now, I can not send texts using google voice from my phone, and when I recieve them I am only getting them via normal cell signal, not wifi.

    I am recieving them into the phones sms app wich is "go sms", nothing shows up in the google voice app inbox.
  20. #20  
    srkmagnus's Avatar

    Posts
    6,743 Posts
    Global Posts
    6,746 Global Posts
    ROM
    Stock 4.4 (KitKat)

    Default

    Is your wife texting the Google Voice number given to you?
  21. Thread Author  Thread Author    #21  
    macjazzy's Avatar

    Posts
    69 Posts
    Global Posts
    80 Global Posts

    Default

    Yes she is. And her texts show up on google voice inbox on my computer.
  22. #22  
    srkmagnus's Avatar

    Posts
    6,743 Posts
    Global Posts
    6,746 Global Posts
    ROM
    Stock 4.4 (KitKat)

    Default

    I just sent a test to a co-worker with airplane mode on and wifi on. She received the text fine.

    Try uninstalling the app and reinstall it. Pay close attention to the setup process.
  23. Thread Author  Thread Author    #23  
    macjazzy's Avatar

    Posts
    69 Posts
    Global Posts
    80 Global Posts

    Default

    srkmagnus, I will try that right now. Thanks
  24. Thread Author  Thread Author    #24  
    macjazzy's Avatar

    Posts
    69 Posts
    Global Posts
    80 Global Posts

    Default

    uninstalled it, and reloaded it. Went through the whole set up, all the questions seemed straight forward. Set up seemed to go just fine.
    Still no send text icon when I select text from the folders, I went to the inbox, where I again have the welcome text from google. Although this time I selected it to send a text then highlighted the box and typed over the number for google voice, to my wives number. But I wasn't able to type her name and have it come up like the normal phone or messaging app.
    Anyway, I typed out a test message, had no cell signal, hit send, and got a message un able to send will send when service is available.
    I had a very strong signal to my wifi router, and was logged in, as I can get on line, and downloaded the app via wifi.
  25. #25  

    Default

    Quote Originally Posted by macjazzy View Post
    uninstalled it, and reloaded it. Went through the whole set up, all the questions seemed straight forward. Set up seemed to go just fine.
    Still no send text icon when I select text from the folders, I went to the inbox, where I again have the welcome text from google. Although this time I selected it to send a text then highlighted the box and typed over the number for google voice, to my wives number. But I wasn't able to type her name and have it come up like the normal phone or messaging app.
    Anyway, I typed out a test message, had no cell signal, hit send, and got a message un able to send will send when service is available.
    I had a very strong signal to my wifi router, and was logged in, as I can get on line, and downloaded the app via wifi.
    Ok.... What phone are you using?

    I know that you should be sending/receiving texts via GV from inside the GV app or web site.

    Also, I think you need to have had GV give you a NEW number rather than using your existing number, did you do that?
Page 1 of 2 12 LastLast

Posting Permissions

B