Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
+ Reply
Results 1 to 3 of 3
  1. Thread Author  Thread Author    #1  
    crstn55555
    crstn55555's Avatar
    Guest

    Default device isn't compatible

    So i tried to download some app on play store like snapchat, line, ask.fm, etc. But it said "your device isn't compatible with his version". I use Samsung Galaxy III, model number: GT-I9300, android version: 4.3. Anyone know why they said my device isn't compatible and how to fix it?
  2. #2  
    Golfdriver97's Avatar

    Posts
    31,136 Posts
    Global Posts
    31,634 Global Posts
    Carrier
    Pure Nexus/Franco Kernel

    Default Re: device isn't compatible

    Quote Originally Posted by crstn55555 View Post
    So i tried to download some app on play store like snapchat, line, ask.fm, etc. But it said "your device isn't compatible with his version". I use Samsung Galaxy III, model number: GT-I9300, android version: 4.3. Anyone know why they said my device isn't compatible and how to fix it?
    Welcome to the forums.
    You were able to find them on Play on your device?
  3. #3  

    Default Re: device isn't compatible

    I tried to install ask.FM and it said my device isn't compatiable ! Like why I installed it before I had no problem now that they updated it I can't install it .

Similar Threads

  1. Compatible headsets for M8
    By ron561 in forum HTC One M8 Accessories
    Replies: 7
    Last Post: 07-15-2014, 04:48 AM
  2. How to prevent bluetooth device reconnecting?
    By zBernie in forum Ask a Question
    Replies: 1
    Last Post: 06-27-2014, 09:34 AM
  3. latest youtube app not compatible with the lg ms690
    By Androidbot101 in forum LG Optimus M
    Replies: 5
    Last Post: 06-15-2014, 01:10 PM
  4. Replies: 2
    Last Post: 06-14-2014, 02:29 AM
  5. Replies: 2
    Last Post: 06-14-2014, 02:05 AM

Posting Permissions