1. Unregistered's Avatar
    Ive had my Galaxy S3 on T-Mobile for over a year now, and I've never had these problems until a few days ago.
    Just a few days ago, my phone's wifi started turning on automatically, but it wouldn't connect unless I manually turned it off and back on. I would put my phone to sleep and pick it back up a few minutes later just to see that the wifi was on, but disconnected.
    Also, around the same time, I noticed that when wifi was connected, the download speeds I received were less than 1 mbps, when my internet provider promises 30 mbps. This problem comes and goes, but it usually happens at night. None of my other devices seem to have this problem at all.
    Another thing I've noticed is that on my battery charts, Android System and Android OS have appeared as top battery users, and this happened around the same time the WiFi problems showed up. I've downloaded a battery monitor and a wakelock detector, but I cannot seem to find the problem. This problem occured without any updates or new apps downloaded on my phone, so I am very confused. All my WiFi settings are normal, even on the advanced screen. I'm not sure if all these problems are somehow connected, but they all appeared at the same time, although they may be completely unrelated. I would appreciate any help you guys have to offer.
    06-17-2014 01:00 AM
  2. Golfdriver97's Avatar
    Have you tried clearing the system cache in recovery? Here is how: [Guide] Rebooting into Recovery Mode for the Galaxy S2, S3, and Tab2.
    06-27-2014 09:41 AM

Similar Threads

  1. Replies: 1
    Last Post: 06-27-2014, 09:51 AM
  2. Personal Dictionary for Galaxy S3
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-27-2014, 09:28 AM
  3. Replies: 1
    Last Post: 06-17-2014, 12:54 AM
  4. Replies: 1
    Last Post: 06-17-2014, 12:40 AM
LINK TO POST COPIED TO CLIPBOARD