Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 7 of 7
  1. Thread Author  Thread Author    #1  

    Default Mms not working with galaxy mega 6.3. Help?

    I'm using straight talk with my at&t samsung galaxy Mega 6.3 (kitkat) and everything is working correctly except my sending and recieving picture messages. When I try to send, it just sets there "sending" abs when someone sends me a picture it won't pop up like it usually did, a download box comes up and when I click it, it says unable to download tri again later.
    My APN settings are accurate according to straight talk and my research online. Very very frustrating to say the least. So I downloaded this android central app in hopes someone will be able to help.
    (Btw everything worked including mms up until I added new air time 2 days ago)

    Samsung Galaxy MEGA 6.3 kitkat
  2. #2  
    Golfdriver97's Avatar

    Posts
    19,687 Posts
    Global Posts
    20,118 Global Posts
    ROM
    Liquidsmooth ROM

    Default Re: Mms not working with galaxy mega 6.3. Help?

    Shot in the dark here...have you tried a reboot?

    From a Carbon M8 and AC Forums app

    Phone Timeline
    'If we could change ourselves, the tendencies in the world would also change.' - Mahatma Gandhi
    Community Guidelines and also here
  3. Thread Author  Thread Author    #3  

    Default Re: Mms not working with galaxy mega 6.3. Help?

    I've done everything I know to do besides doing a factory reset which is what straight talk told me to do but I'm trying not too.
    Just found out today that my husband's phone is doing the exact same thing and he has an At&t Samsung Galaxy s3. So it can't be just my phone since his isn't sending/recieving either. Both of our apn's are the same.

    Samsung Galaxy MEGA 6.3 kitkat
  4. #4  
    Golfdriver97's Avatar

    Posts
    19,687 Posts
    Global Posts
    20,118 Global Posts
    ROM
    Liquidsmooth ROM

    Default Re: Mms not working with galaxy mega 6.3. Help?

    Quote Originally Posted by Amy Johnson80 View Post
    I've done everything I know to do besides doing a factory reset which is what straight talk told me to do but I'm trying not too.
    Just found out today that my husband's phone is doing the exact same thing and he has an At&t Samsung Galaxy s3. So it can't be just my phone since his isn't sending/recieving either. Both of our apn's are the same.

    Samsung Galaxy MEGA 6.3 kitkat
    Maybe a cache clear in recovery? This method will work for the S3, not sure about the Mega.

    [Guide] Rebooting into Recovery Mode for the Galaxy S2, S3, and Tab2.

    From a Carbon M8 and AC Forums app

    Phone Timeline
    'If we could change ourselves, the tendencies in the world would also change.' - Mahatma Gandhi
    Community Guidelines and also here
  5. #5  

    Default Re: Mms not working with galaxy mega 6.3. Help?

    amy Johnson the problem that you and me and other people are having is the kit kat 4.4.2 is messing a lot of android phones expecially the Mega i527-I myself have the galaxy mega i527 I cannot send or receive pics and I get a message that says (no mobile net works found)I called straight talk after 49 mins they had no answer-
    I sent my mega to RSI in Plano,Tx-RSI is a repair contractor for Samsung,RSI sent my phone back 12 days later-not only was the phone still not working-RSI cracked my screen-so I sent the mega back again-after 8 days RSI sent my mega back to me-they did fix the screen but not the picture problem..so I finally had enough of Samsung calling me ask me to send it back a 3rd time to RSI-I told Samsung just send me a replacement-Samsung Rep said he did not have that power to do so-Samsung Rep said a higher Rep with the power to send me a new phone-will be calling me-I waited 4 days-finally I got tited of waiting I said F-IT-I went on ebay bought a brand new Samsung mega i9205 for $307 which has the jelly bean and its unlocked-the good thing is it does not have all the at&t aps/bloatware..Oh btw I have read that most people who block Google app picasa that uploads your and mine pics for google to use for their money making ad,s that's installed in most android phones-are having issues with the kit kat update...reason I know is my wife has 4.4.2 on her galaxy s4 and she has not blocked her reg or naughty pics on Picasa and her phone works fine....
  6. #6  

    Default Re: Mms not working with galaxy mega 6.3. Help?

    I get the same problem
    MMS takes forever to send (if it ever does) and a lot of times pictures coming in won't load properly
    I just deal with it

    Posted via Android Central App with my Samsung Galaxy S5
  7. #7  

    Default Re: Mms not working with galaxy mega 6.3. Help?

    This happened to my phone after I upgraded to Kitkat 4.4.2. It would not send or receive mms messages. I did a soft reset and a hard reset. I even bought a new sim card and nothing worked. I did finally get it working and I will tell you how.

    I went to:
    Settings
    Mobile Networks
    Access Point Names
    and on the straight talk apn settings scroll down to APN type and add mms
    so instead of default, hipri it should now read default, hipri, mms
    click on the menu button and click save
    Restart your phone and it should work.

    Good luck
    Mms not working with galaxy mega 6.3. Help?-screenshot_2014-09-09-18-24-13.png
    Last edited by adelle822; 09-09-2014 at 05:40 PM.

Similar Threads

  1. Google Voice option with SwiftKey
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-21-2014, 08:47 AM
  2. Nexus 7 not showing up as a device
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-21-2014, 08:33 AM

Posting Permissions