1. AC Question's Avatar
    My previous phone was a Nokia Lumia520 and I was with Lebara as my provider. I spent a lot of time trying to get my data to work and it never did (I even called lebara for help, visited their site and alot of other forums and sites, including nokia's site). My nokia sadly broke recently and I now have a Jiake N9000 with the same sim card and provider. I have been trying to turn on my data and cannot even find where to turn it on. I would like to know if anyone could help me to turn on my data on the Jiake N900. Also is it possible my sim is faulty and I need to get a new one in order for my data to work ?
    06-24-2014 02:31 AM
  2. belodion's Avatar
    Try Settings>More>Mobile Network>Mobile Data. Enable the latter.

    Posted via Android Central App
    06-24-2014 03:47 AM

Similar Threads

  1. Error Downloading "app name" There is insufficient space on the device
    By ronald villegas in forum Google Nexus 7 Tablet (2013)
    Replies: 20
    Last Post: 07-27-2015, 05:12 AM
  2. Pattern not working on while charging
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-25-2014, 02:43 AM
  3. can't connect to data, send pictures or receive them
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 06-25-2014, 12:20 AM
  4. How do you unlock the AT&T S3 for use on TMobile?
    By JEGuitarist in forum AT&T Galaxy S III
    Replies: 2
    Last Post: 06-24-2014, 03:35 PM
  5. Ongoing BAR - for WIFI & DATA
    By pepsi61 in forum Ask a Question
    Replies: 1
    Last Post: 06-24-2014, 11:58 AM
LINK TO POST COPIED TO CLIPBOARD