Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 2 of 2
  1. Thread Author  Thread Author    #1  

    Default Galaxy S4 Active - Won't Charge and Killing Batteries

    I have had my Galaxy S4 active for only about 3 months. I was using my phone on Friday when I noticed the battery getting low. I plugged the phone in to charge and came back a few hours later to get it and it was completely dead. I put it back on charge all night and the phone will not charge at all. I tried numerous different plugs, different extensions, and even took the battery out and tried to restart the whole thing....nothing worked. The weird part is that I put an older battery in the active to see if it was the port or the battery. The battery was at about 50%. As soon as I put it in, it zapped the battery down to approx. 10% and kept draining it. I plugged it in and the battery showed to be charging but never did. Within 5 minutes that battery was dead too and wouldn't charge. I put it in another galaxy phone I have to see if I could get it to charge and now that battery won't take a charge either....WEIRD....Any ideas? I have a new one coming in, but I am needing to try and get a backup done before i send it off. I am just wondering what would be causing this/??? Any help would be appreciated. If it is something I caused I want to avoid it with the new phone!
  2. #2  
    Golfdriver97's Avatar

    Posts
    31,145 Posts
    Global Posts
    31,643 Global Posts
    Carrier
    Pure Nexus/Franco Kernel

    Default Re: Galaxy S4 Active - Won't Charge and Killing Batteries

    Quote Originally Posted by Miranda Freeman View Post
    I have had my Galaxy S4 active for only about 3 months. I was using my phone on Friday when I noticed the battery getting low. I plugged the phone in to charge and came back a few hours later to get it and it was completely dead. I put it back on charge all night and the phone will not charge at all. I tried numerous different plugs, different extensions, and even took the battery out and tried to restart the whole thing....nothing worked. The weird part is that I put an older battery in the active to see if it was the port or the battery. The battery was at about 50%. As soon as I put it in, it zapped the battery down to approx. 10% and kept draining it. I plugged it in and the battery showed to be charging but never did. Within 5 minutes that battery was dead too and wouldn't charge. I put it in another galaxy phone I have to see if I could get it to charge and now that battery won't take a charge either....WEIRD....Any ideas? I have a new one coming in, but I am needing to try and get a backup done before i send it off. I am just wondering what would be causing this/??? Any help would be appreciated. If it is something I caused I want to avoid it with the new phone!
    Welcome to the forums.
    Honestly, I have no idea what could be causing the excessive drain. The only thing I can think of is something is overworking and causing it, but even then that is a guess.

Similar Threads

  1. Kit Kat, GPS, and Waze
    By Skarlet32 in forum Verizon Galaxy S3
    Replies: 13
    Last Post: 08-06-2014, 06:21 PM
  2. Replies: 2
    Last Post: 06-24-2014, 03:14 PM
  3. How to set up mac and ip address on LG L9
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-24-2014, 11:53 AM
  4. Hiding apps on Galaxy S3
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-24-2014, 11:51 AM
  5. Battery issue?
    By sdm242 in forum Samsung Galaxy Tab 3
    Replies: 4
    Last Post: 06-24-2014, 10:16 AM

Posting Permissions