Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. Thread Author  Thread Author    #1  

    Default Google services not working.

    Okay, so I rooted my S2 and updated it to 4.4.3. When I switched it on, everything was working fine but my Play Store said "Authentication failed!.. Blah... Blah... Blah... Retry" but when I pressed retry button I wasn't able to reenter my already entered ID. Then I deleted all Google services and apps. (I thought they would roll back to their original state and then I would update) but they permanently got deleted. Then I tried to download Play Store's APK. Now it's closing instantly. I am also not able to add any Google account. When I try to create an account by using YouTube app, it instantly closes(not the app but account creation form). What to do now? Any help would be appreciated.
  2. #2  

    Default Re: Google services not working.

    4.4.3 on an S2? Is it a custom ROM?

    If so, did you download and install GAPPS?
  3. #3  
    Golfdriver97's Avatar

    Posts
    31,124 Posts
    Global Posts
    31,622 Global Posts
    Carrier
    Pure Nexus/Franco Kernel

    Default Re: Google services not working.

    My S2 stops at 4.3. However, reflashing Gapps in recovery should bring everything back.

    From a Carbon M8 and AC Forums app
    RumoredNow likes this.

Similar Threads

  1. Facebook link previews not working... phone, OS or app???
    By OCP22 in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 08-25-2015, 09:36 AM
  2. HTC One Issue with Google Play Music Unlimited
    By bmbriefs in forum HTC One M7
    Replies: 3
    Last Post: 07-04-2014, 06:36 AM
  3. galaxy s4 new battery not working :(
    By AC Question in forum Ask a Question
    Replies: 5
    Last Post: 06-27-2014, 07:47 PM
  4. Email on Android 4.4.2 not working
    By Unregistered in forum Ask a Question
    Replies: 2
    Last Post: 06-27-2014, 03:39 PM

Posting Permissions