Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 2 12 LastLast
Results 1 to 25 of 30
  1. Thread Author  Thread Author    #1  

    Unhappy Cubot GT90 constantly roaming (not mobile data)

    Hi there,

    We have had a mast issue in our area which is now resolved and have our signal back. However my new Cubot GT90 refuses to believe this and is constantly roaming with the signal when all other phones have full signal. Our family all are on Orange, bar one who is on EE. I've disabled all the data roaming stuff but this still persists and it is signal roaming. And I have tried the sim in my old sony xperia J and my old Nokia brick and the signal in them is full. Can anyone help?

    Henry
  2. #2  

    Default Re: Cubot GT90 constantly roaming (not mobile data)

    Going into Airplane and then switching the radios back on can force the network to reestablish with the phone.
  3. Thread Author  Thread Author    #3  

    Default Re: Cubot GT90 constantly roaming (not mobile data)

    So for that, just stick it into airplane mode, put the radio (presumably the radio app on the phone) on and then take them off after a bit?
  4. #4  

    Default Re: Cubot GT90 constantly roaming (not mobile data)

    Airplane shuts down all radios: cell, WiFi, Bluetooth, NFC.

    Just go into airplane, wait a minute and turn airplane off. (It's just a convience over having to shut down cellular radio individually.)
  5. Thread Author  Thread Author    #5  

    Default Re: Cubot GT90 constantly roaming (not mobile data)

    Quote Originally Posted by RumoredNow View Post
    Going into Airplane and then switching the radios back on can force the network to reestablish with the phone.
    It won't let me turn the radio on whilst in airplane mode :/
  6. #6  

    Default Re: Cubot GT90 constantly roaming (not mobile data)

    Quote Originally Posted by henryk812 View Post
    It won't let me turn the radio on whilst in airplane mode :/
    Just turn airplane mode off and all radios will go back to normal.
  7. Thread Author  Thread Author    #7  

    Default Re: Cubot GT90 constantly roaming (not mobile data)

    Quote Originally Posted by RumoredNow View Post
    Just turn airplane mode off and all radios will go back to normal.
    Okay, airplane mode on then off, put radio on, then see what happens?
  8. #8  

    Default Re: Cubot GT90 constantly roaming (not mobile data)

    Yep.
  9. Thread Author  Thread Author    #9  

    Default Re: Cubot GT90 constantly roaming (not mobile data)

    Quote Originally Posted by RumoredNow View Post
    Just turn airplane mode off and all radios will go back to normal.
    Or do I not need to open the radio app?
  10. #10  

    Default Re: Cubot GT90 constantly roaming (not mobile data)

    Really all you need is airplane mode on (shuts off all radios) then airplane mode off (returns all radios to how they were - i.e. if cell radio is normally on it will go on, if Bluetooth is normally off it will stay off, but now you COULD toggle it on and off).
  11. Thread Author  Thread Author    #11  

    Default Re: Cubot GT90 constantly roaming (not mobile data)

    Quote Originally Posted by RumoredNow View Post
    Really all you need is airplane mode on (shuts off all radios) then airplane mode off (returns all radios to how they were - i.e. if cell radio is normally on it will go on, if Bluetooth is normally off it will stay off, but now you COULD toggle it on and off).
    Done it and naff all has changed, its exactly the same the signal as it was before I did this :/
  12. Thread Author  Thread Author    #12  

    Default Re: Cubot GT90 constantly roaming (not mobile data)

    Quote Originally Posted by RumoredNow View Post
    Really all you need is airplane mode on (shuts off all radios) then airplane mode off (returns all radios to how they were - i.e. if cell radio is normally on it will go on, if Bluetooth is normally off it will stay off, but now you COULD toggle it on and off).
    Signal came good for ten seconds, went down again and back came the roaming R
  13. Thread Author  Thread Author    #13  

    Default Re: Cubot GT90 constantly roaming (not mobile data)

    Is there anything else I can do?
  14. Thread Author  Thread Author    #14  

    Default Re: Cubot GT90 constantly roaming (not mobile data)

    Quote Originally Posted by RumoredNow View Post
    Going into Airplane and then switching the radios back on can force the network to reestablish with the phone.
    No more help? :/
  15. Thread Author  Thread Author    #15  

    Default Re: Cubot GT90 constantly roaming (not mobile data)

    Quote Originally Posted by RumoredNow View Post
    Going into Airplane and then switching the radios back on can force the network to reestablish with the phone.
    Please can you help? :/
  16. #16  

    Default Re: Cubot GT90 constantly roaming (not mobile data)

    Sorry, lost data...

    Best thing is force 3G. Try this method. How to Force Android to Use Only 3G? - Silicon Station

    Remember the original setting to go back to if this doesn't work.

    Gotta run for now. Will check back later.
  17. Thread Author  Thread Author    #17  

    Default Re: Cubot GT90 constantly roaming (not mobile data)

    Okay it got a bit better but having the same issue and that stupid R is still there? Is my phone just screwed?
  18. #18  

    Default Re: Cubot GT90 constantly roaming (not mobile data)

    Quote Originally Posted by henryk812 View Post
    Okay it got a bit better but having the same issue and that stupid R is still there? Is my phone just screwed?
    I'm not familiar at all with a Cubot phone. I did see your carrier is Orange, yes? (It looks like the EE carrier is someone else's phone?) That is in the UK correct?

    Any chance they refarmed your frequencies to make room for LTE?

    Your 3G radio looks to only have 2 frequencies on it (2G has 4) and that might be the issue...
  19. Thread Author  Thread Author    #19  

    Default Re: Cubot GT90 constantly roaming (not mobile data)

    Quote Originally Posted by RumoredNow View Post
    I'm not familiar at all with a Cubot phone. I did see your carrier is Orange, yes? (It looks like the EE carrier is someone else's phone?) That is in the UK correct?

    Any chance they refarmed your frequencies to make room for LTE?

    Your 3G radio looks to only have 2 frequencies on it (2G has 4) and that might be the issue...
    Yes it is Orange, the EE carrier is my mum who switched from Orange to EE on a different contract earlier this year, yes we are in the UK hmm don't think so as up until the mast failure all was fine with my signal (its defo the phone) and right how can it be resolved?
  20. #20  

    Default Re: Cubot GT90 constantly roaming (not mobile data)

    At this point I'd check with the carrier. Do they have a local store that might know about the mast issue?

    My info shows me a mismatch between 3G radio and carrier frequencies. Only one matches and 3G uses two frequencies for uplink/downlink.
  21. Thread Author  Thread Author    #21  

    Default Re: Cubot GT90 constantly roaming (not mobile data)

    Quote Originally Posted by RumoredNow View Post
    At this point I'd check with the carrier. Do they have a local store that might know about the mast issue?

    My info shows me a mismatch between 3G radio and carrier frequencies. Only one matches and 3G uses two frequencies for uplink/downlink.
    I rang about the mast issue the other day and they said it would be fixed which it now is, hmm so what can I do about this mismatch?
  22. #22  

    Default Re: Cubot GT90 constantly roaming (not mobile data)

    Ask them specifically what frequencies are needed for 3G on their network. Ask them if it has changed recently.

    Your 3G radio needs WCDMA 850/2100MHZ. If there is a mismatch, you can't do anything... If there are some settings that need to be redone, they will help you do them.
  23. Thread Author  Thread Author    #23  

    Default Re: Cubot GT90 constantly roaming (not mobile data)

    Quote Originally Posted by RumoredNow View Post
    Ask them specifically what frequencies are needed for 3G on their network. Ask them if it has changed recently.

    Your 3G radio needs WCDMA 850/2100MHZ. If there is a mismatch, you can't do anything... If there are some settings that need to be redone, they will help you do them.
    I just find it strange how its worked perfectly till this issue arose :/ would it be best use my older phone for now?
  24. Thread Author  Thread Author    #24  

    Default Re: Cubot GT90 constantly roaming (not mobile data)

    To confuse you further, the signal is fine downstairs in my house!

    - - - Updated - - -

    But it does have these stupid moments
  25. #25  

    Default Re: Cubot GT90 constantly roaming (not mobile data)

    It may be good to switch to a proven phone for now.

    When work is done on masts (towers here in the US) it may be to roll out new equipment. Sometimes that shuffles the frequencies around so there is enough bandwidth to run various classes of data service (2G vs 3G vs LTE traffic). Sometimes it is new comm protocols and your settings need to be updated deep inside the phone settings. Without asking the carrier what might have changed, it is hard to know.
Page 1 of 2 12 LastLast

Similar Threads

  1. Facebook link previews not working... phone, OS or app???
    By OCP22 in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 08-25-2015, 09:36 AM
  2. Samsung Galaxy Tab 3 will not recognize USB Keyboard
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 07-10-2015, 08:15 PM
  3. Andriod 4.4.4 Exchange Issue - Emails not retrieving
    By Chad Gornicz in forum Google Nexus 5
    Replies: 8
    Last Post: 03-06-2015, 01:10 AM
  4. Google services not working.
    By Inderdeep Bajwa in forum Ask a Question
    Replies: 2
    Last Post: 06-27-2014, 04:20 PM

Posting Permissions