Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
+ Reply
Results 1 to 14 of 14
Like Tree2Likes
  • 1 Post By Andy Marshall1
  • 2 Post By ChrisM1968
  • 1 Post By FoxieJay
  1. Thread Author  Thread Author    #1  
    AC Question
    AC Question's Avatar
    Guest

    Default How do I fix, calendar on phone duplicating holidays?

    The calendar on my phone is duplicating all holidays.
    My Google calendar on my laptop only shows them once.

    Any advice on how to fix this?
  2. Best Answer
    Posts
    1 Posts
    Global Posts
    1 Global Posts

    It took a while but here is how I finally fixed this issue.

    On my pc under google calendars, even though the holidays were only showing up once there, I unsubscribed to Holidays in the United States. I synched the calendar on my phone and they were all gone. I then went back on my pc and re-subscribed to Holidays in the United States, resynched on my phone (I had to go back into calendars, display, and check the box for Holidays) and they were back but only one time.

  3. #2  
    srkmagnus's Avatar

    Posts
    13,676 Posts
    Carrier
    Stock 4.4 (KitKat)

    Default re:

    Quote Originally Posted by AC Question View Post
    The calendar on my phone is duplicating all holidays.
    My Google calendar on my laptop only shows them once.

    Any advice on how to fix this?
    Open the calendar app and open the settings. There should be am option to display calendars. Click that and check to see that there are no calendars checked that shouldn't be. I have my Gmail calendar, US Holidays and weather selected and don't have issues. Let us know if you are able to fix it.

    Sent from my Nexus 5 using AC Forums mobile app
  4. #3  

    Default re:

    S Planner - Calendars - Display - I have my task, family birthdays (from Google), Holidays in US, Holidays in UK and my Google calendar checked.

    The duplicates aren't because I have both US & UK Holidays as it duplicates both. For example Boxing Day is only in the UK, it shows twice, Christmas Day is in both, so shows up four times.
  5. #4  

    Default re:

    Just removed Gmail from my phone and re-added it. That fixed the problem.
    Illustrator Joe likes this.
  6. #5  

    Default re:

    I am having the same problem. I have my phone synced with my google account and no others. I have it set to show United States Holidays. If I look at my calendar on my desk top, I don't see duplicate holidays. But when I pull up my calendar on my SGS3, some (not all) of the holidays are duplicated. For example, July 4, Labor day, and Thanksgiving are all duplicated, but Veteran's day, Christmas, and Patriot's day are not. Does anyone out there know how to fix this? Thanks
  7. #6  

    Cool re:

    It took a while but here is how I finally fixed this issue.

    On my pc under google calendars, even though the holidays were only showing up once there, I unsubscribed to Holidays in the United States. I synched the calendar on my phone and they were all gone. I then went back on my pc and re-subscribed to Holidays in the United States, resynched on my phone (I had to go back into calendars, display, and check the box for Holidays) and they were back but only one time.
  8. #7  

    Default re:

    That suggestion ABSOLUTELY WORKED!!!
    Thanks
  9. #8  

    Default re:

    Worked for me too. Also helped a calendar show up on my phone that was only showing up on PC dedpite being selected to synch on my phone.
  10. #9  

    Default re:

    Wow Thanks so much your solution worked perfectly!!!!!!! The duplicate holiday thing was driving me crazy thanks so much again.
  11. #10  

    Default re:

    Didn't work for me. It just keeps displaying dupes or not after every sync.
  12. #11  
    Rukbat's Avatar

    Posts
    22,807 Posts
    Carrier
    Modified Stock 4.4.2

    Default re:

    Quote Originally Posted by Richard Thietje View Post
    Didn't work for me. It just keeps displaying dupes or not after every sync.
    Do you have more than one Google calendar linked (under Other Calendars). If both of them have holidays, it may show as duplicates.
  13. #12  

    Default re:

    I solved this by going to the stock Calendar app (not the Business Calendar app I use, which apparently is controlled by the stock Calendar app), pressing the lower left corner of my Note II to get a menu, selecting Calendars, then deleting the calendar that said "Birthdays". That got rid of the duplicates. Since birthdays already show up on my main/online Google calendar, syncing that with my Android phone brings those in to the Android calendar.

    I was also having a problem with holidays showing up twice in the Android calendar, and solved that problem by deleting the Holidays Calendar in the stock app. Now I have holidays showing only once, since they are also in my main/online Google calendar.
  14. #13  

    Wink re:

    Hello,

    I went into settings, then calendar & tasks. Unchecked all the gmails except one, holidays were then single. Thanks for leading me in the right direction.
    pkcable likes this.
  15. #14  
    pkcable's Avatar
    Q&A Jedi

    Posts
    1,875 Posts
    Carrier
    7.1

    Default Re:

    Quote Originally Posted by FoxieJay View Post
    Hello,

    I went into settings, then calendar & tasks. Unchecked all the gmails except one, holidays were then single. Thanks for leading me in the right direction.
    So glad this old thread is STILL able to help someone! Also Welcome to Android Central!

    Since you went ahead and bumped the thread anyways I marked the solution as "best answer" so it real easy to find for the next person!

Similar Threads

  1. Replies: 6
    Last Post: 12-22-2016, 12:21 PM
  2. Replies: 1
    Last Post: 12-22-2016, 11:26 AM
  3. what are the limits of running android on pc
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 12-22-2016, 10:36 AM

Posting Permissions