1. AC Question's Avatar
    Hi all,

    I have recently returned to the UK from living in South Korea where I had a S3 lte. I was connect to LG U+ and used only 4G ( apparently I couldn't connect with 3G just 4G not sure why). Since I have returned, I have not been able to connect to the internet properly. I cannot get 3G at all, I only get G and when connected can only receive whatsapp messages. I am able to use wifi, make calls but not send messages over 160 characters. I have contacted my service provider who tell me I have all the correct internet settings etc. I have little knowledge about phones and I have no idea what I can do to try and sort this out. I have tried to restore factory settings but again nothing seems to have worked.

    Any advice or a solution would be great!
    07-09-2014 03:31 AM
  2. B. Diddy's Avatar
    Did you make sure your APN settings were correct?
    02-26-2015 12:48 AM

Similar Threads

  1. How to use Chrome cast in hotel Read all plz
    By rxgadget in forum Google Chromecast
    Replies: 3
    Last Post: 07-10-2014, 08:19 PM
  2. Downloading apps on PC to put on S3
    By aymanshaikh in forum Samsung Galaxy S3 in Canada (Bell/Telus/Rogers)
    Replies: 3
    Last Post: 07-10-2014, 09:01 AM
  3. Replies: 1
    Last Post: 07-09-2014, 01:20 PM
  4. Apps unable to find location without GPS
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-09-2014, 01:18 PM
  5. samsung galaxy s2 update
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-09-2014, 01:16 PM
LINK TO POST COPIED TO CLIPBOARD