Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
+ Reply
Results 1 to 2 of 2
  1. Thread Author  Thread Author    #1  
    AC Question
    AC Question's Avatar

    Default ASUS Memo Pad 8 is definitely on but there is no display

    i have an asus memo pad 8. my tablet suddenly won't unlock. i tried pressing the lock and lower volume button together because it worked when it became still one time. i plugged it in, it won't charge. i also plugged it onto my laptop because some needed lower voltage if ever it won't charge. the weirdest thing is it keeps on ringing notifications but still, it won't unlock or restart. please help.
  2. #2  

    Default Re: ASUS Memo Pad 8 is definitely on but there is no display

    have you tried the trick of holding power and volume down at same time to get it to reboot?

    ok i just reread your post and see that you have tried the power and volume down. did you hold it for over 10 seconds though?

Similar Threads

  1. Random thoughts on Gear Live
    By AzD in forum Samsung Gear Live
    Replies: 7
    Last Post: 03-05-2015, 03:28 PM
  2. upside down camera on instagram,face...
    By Porec Zagreb in forum General Help and How To
    Replies: 1
    Last Post: 07-10-2014, 10:20 AM
  3. Need an inexpensive but good android for my 14 yo daughter
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 07-10-2014, 07:43 AM
  4. Replies: 8
    Last Post: 07-10-2014, 12:24 AM
  5. Galaxy S3 won't power on
    By kirbyg53 in forum Ask a Question
    Replies: 4
    Last Post: 07-09-2014, 10:20 PM

Posting Permissions