1. AC Question's Avatar
    hello all. i tried a few searches but got no answer to my issue. currently i bought a samsung MHL adapter so i could watch streamed movies and surf the net from the galaxy s5 to my hdtv. the problem is that when i do connect the mhl adapter to the phone i sometimes get screen snow or bits and pieces of the screen thats on my phone or just a blank screen. also i gradually lose internet connection the longer the mhl adapter is plugged into the phone to the point theres no connection possible. if i unplug the mhl from the phone i gradually get service/connection again.

    the odd part is if i put the phone on airplane mode and connect the mhl to the phone, it works! i do do plug the power adapter (even though the s5 and note doesnt need i from my reading) to ensure the battery's charging. my phones not root btw. my HDMI cable im using is the Monster HDMI gold brand fwiw.

    any idea on whats going on please? is it the mhl adapter, hdmi cable, or cause the phones not rooted?
    07-11-2014 03:05 PM
  2. wizzrah's Avatar
    hello all. i tried a few searches but got no answer to my issue. currently i bought a samsung MHL adapter so i could watch streamed movies and surf the net from the galaxy s5 to my hdtv. the problem is that when i do connect the mhl adapter to the phone i sometimes get screen snow or bits and pieces of the screen thats on my phone or just a blank screen. also i gradually lose internet connection the longer the mhl adapter is plugged into the phone to the point theres no connection possible. if i unplug the mhl from the phone i gradually get service/connection again.

    the odd part is if i put the phone on airplane mode and connect the mhl to the phone, it works! i do do plug the power adapter (even though the s5 and note doesnt need i from my reading) to ensure the battery's charging. my phones not root btw. my HDMI cable im using is the Monster HDMI gold brand fwiw.

    any idea on whats going on please? is it the mhl adapter, hdmi cable, or cause the phones not rooted?
    Hello!

    I had this problem with my One XL when using an MHL adapter as well. The WiFi would disconnect the moment I plugged it in. Have you tried data? Does that work? And it is the official Samsung MHL adapter, correct?
    07-11-2014 03:17 PM
  3. fst100's Avatar
    Hello!

    I had this problem with my One XL when using an MHL adapter as well. The WiFi would disconnect the moment I plugged it in. Have you tried data? Does that work? And it is the official Samsung MHL adapter, correct?
    hey there, what do you mean if i tried data? what i meant was the instant i connect the MHL into my S5, it'll gradually go from the 4G down to 3G to the point where it loses connection/no signal. if i unplug the MHL from the S5 the signal would go back to normal and get service. the MHL adapter i got was apparently a samsung model i bougt on ebay, but the one i got may be a chinese knock-off (the lable on the MHL says "SAMSUN" missing the letter "G". i also havent tried plugging in a 100mA charger (only got a 50mA charger). would that be the possible issue?
    07-15-2014 07:53 AM
  4. wizzrah's Avatar
    hey there, what do you mean if i tried data? what i meant was the instant i connect the MHL into my S5, it'll gradually go from the 4G down to 3G to the point where it loses connection/no signal. if i unplug the MHL from the S5 the signal would go back to normal and get service. the MHL adapter i got was apparently a samsung model i bougt on ebay, but the one i got may be a chinese knock-off (the lable on the MHL says "SAMSUN" missing the letter "G". i also havent tried plugging in a 100mA charger (only got a 50mA charger). would that be the possible issue?
    It could be the adapter itself. I was reading that the Samsung adapter didn't have these problems.

    There's a thread I found on XDA that describes similar problems to yours: MHL Cable and WiFi Cut Off - XDA Forum
    07-15-2014 10:58 AM
  5. fst100's Avatar
    this happens in just data. forgot to answer the one member who asked above. i dont have a router to use the wi-fi except if i use the phone as a hotspot, thats about it, but even with that on or off, when the MHL is connected it'll lose signal. currently reading the thread/link the other person posted.
    07-15-2014 11:07 AM
  6. wizzrah's Avatar
    this happens in just data. forgot to answer the one member who asked above. i dont have a router to use the wi-fi except if i use the phone as a hotspot, thats about it, but even with that on or off, when the MHL is connected it'll lose signal. currently reading the thread/link the other person posted.
    I think that other person is me (they were both me).

    So you don't use WiFi, just your phone as a hotspot. Gotcha. Was the adapter suppose to be new or was it used?
    07-15-2014 11:18 AM
  7. fst100's Avatar
    the adapter i just bought a generic "OEM" mhl adapter
    MHL+HDMI+HDTV+Adapter+Cable+for+Samsung+Galaxy+S5+S4+S3+NOTE3+Note+2+Tab+3+10+1+|+eBay]MHL HDMI HDTV Adapter Cable for Samsung Galaxy S5 S4 S3 NOTE3 Note 2 Tab 3 10 1 | eBay

    i just went and bought this one that appears to have the correct model number provided and costs roughly the same as getting it directly from Samsung.
    New+Samsung+HDMI+MHL+2+0+HDTV+Et+H10FAUWESTA+Adapter+for+Galaxy+S3+S4+S5]New Samsung HDMI MHL 2 0 HDTV Et H10FAUWESTA Adapter for Galaxy S3 S4 S5 | eBay

    hopefully this one works.
    07-15-2014 11:32 AM
  8. wizzrah's Avatar
    Okay, I think that might be it then. Looks better than what you bought before. Update me on whether that adapter fixed your problem or not. I'm curious to see the outcome.
    07-15-2014 11:39 AM
  9. fst100's Avatar
    I think that other person is me (they were both me).

    So you don't use WiFi, just your phone as a hotspot. Gotcha. Was the adapter suppose to be new or was it used?
    the one i bought i thought was an actual OEM from samsung but when i got it, i realize it was spelled "SAMSUN" and it costed $10 whereas the official OEM says SAMSUNG and has the valid model number on the box or somewhere and costs $30-40. i just bought the latter one and see if that helps. both were from ebay *gasp*
    07-15-2014 11:39 AM
  10. fst100's Avatar
    Okay, I think that might be it then. Looks better than what you bought before. Update me on whether that adapter fixed your problem or not. I'm curious to see the outcome.
    ok, if i forget or dont respond in 5-10 days reply with a bump so i get the notification :-)
    07-15-2014 11:44 AM
  11. wizzrah's Avatar
    ok, if i forget or dont respond in 5-10 days reply with a bump so i get the notification :-)
    Sure!
    07-15-2014 11:46 AM
  12. fst100's Avatar
    update:
    got my actual samsung MHL adapter and it works! connected the adapter to the phone and tv and no drop in 4G/3G. :-)
    07-21-2014 10:22 AM

Similar Threads

  1. Case Recommendations for the S5?
    By Pneeleysmom in forum Samsung Galaxy S5
    Replies: 41
    Last Post: 07-13-2014, 07:16 PM
  2. Will my Sprint phones work on Verizon?
    By terryh215 in forum Verizon
    Replies: 6
    Last Post: 07-13-2014, 01:19 AM
  3. Cannot restore any app using titanium backup
    By Mr nexus in forum Ask a Question
    Replies: 1
    Last Post: 07-11-2014, 03:05 PM
  4. Connecting to internet that is not my home Wi-Fi
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-11-2014, 02:58 PM
  5. Debranding the S5
    By lambada24 in forum Samsung Galaxy S5
    Replies: 0
    Last Post: 07-11-2014, 01:54 PM
LINK TO POST COPIED TO CLIPBOARD