Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 5 of 5
Like Tree2Likes
  • 1 Post By anon8380037
  • 1 Post By TheJosieB
  1. Thread Author  Thread Author    #1  

    Default Brand new galaxy ace - google play not working

    Hi,

    My mums just bought a galaxy ace and we've been going through the set up, connected to wifi and connected her google play to her gmail account and as soon as we connected her account it started loading however nothing has come up. We've restarted the phone, installed all updates and tried to load it again but nothing is happening.
    It's definitely connected to the internet as her emails and other apps are all working it's just google play that won't load. Can anyone help?

    Many thanks in advance.
    Josie
  2. #2  

    Default Re: Brand new galaxy ace - google play not working

    Quote Originally Posted by TheJosieB View Post
    Hi,

    My mums just bought a galaxy ace and we've been going through the set up, connected to wifi and connected her google play to her gmail account and as soon as we connected her account it started loading however nothing has come up. We've restarted the phone, installed all updates and tried to load it again but nothing is happening.
    It's definitely connected to the internet as her emails and other apps are all working it's just google play that won't load. Can anyone help?

    Many thanks in advance.
    Josie
    Hello and Welcome to Android Central.

    Do you mean no apps are appearing but you are logged in to Play on the Play app, or are you sending apps from a pc. It may not recognise your device yet. Try your mum's Play account on a pc if you can and search for your devices. There's also a help section link from the app.

    Sent from my SM-N9005 using Tapatalk Pro
  3. Thread Author  Thread Author    #3  

    Default Re: Brand new galaxy ace - google play not working

    Thank you for such a quick reply! We're on the device itself and when we open Gplay no apps are loading at all. From the moment we entered her gmail details and said go, nothing has loaded apart from the top search bar.

    So to my understanding from your email we should try going into her gmail only laptop and linking her device through there, is that correct?

    Many thanks,
    Josie
  4. #4  

    Default Re: Brand new galaxy ace - google play not working

    Quote Originally Posted by TheJosieB View Post
    Thank you for such a quick reply! We're on the device itself and when we open Gplay no apps are loading at all. From the moment we entered her gmail details and said go, nothing has loaded apart from the top search bar.

    So to my understanding from your email we should try going into her gmail only laptop and linking her device through there, is that correct?

    Many thanks,
    Josie
    No forget my rubbish above for now.


    It's probably the Download Manager app. It needs to be enabled, turned on. Have a look at that first.
    Settings General Applications Manager scroll to All - Download Manager.




    Sent from my SM-N9005 using Tapatalk Pro
    B. Diddy likes this.
  5. Thread Author  Thread Author    #5  

    Default Re: Brand new galaxy ace - google play not working

    It said it was disabled but we enabled and disabled it again am it's now working. Thank you for your help!
    anon8380037 likes this.

Similar Threads

  1. moto g gpe stucks at google logo
    By karthik in forum Ask a Question
    Replies: 0
    Last Post: 07-13-2014, 07:07 AM
  2. Replies: 0
    Last Post: 07-13-2014, 06:12 AM

Posting Permissions