1. AC Question's Avatar
    My water bottle leaked on my myouch 4g last night and when I woke up my phone was still on but it had no service so I restarted it. After that, I get a screen that has all of this on it...

    GLACIER PVT SHIP S-ON
    HBOOT-0.89.0006
    MICROP-0429
    RADIO-26.13.04.9_M
    eMMC-boot
    Jul 15 2011, 16:45:17

    HBOOT

    <VOL UP> TO PREVIOUS ITEM
    <VOL DOWN> TO NEXT ITEM
    <POWER> TO SELECT ITEM

    FASTBOOT
    RECOVERY
    FACTORY RESET
    SIMLOCK
    IMAGE CRC

    I have gotten it pat this screen a couple times. I went to fastboot and it brings me back to this screen. Rcovery brings me to a screen with a laying down mytouch and a green sign that looks something like downloading then to a screen with a mytouch and a red triangle with an exclamtion mark in it. I tried factory reset. Nothing. I really need help. I'm willing to work on it as long as it saves me the money of buying a new one. ANYTHING will help.

    Thanks in advance,

    Kelsey
    07-18-2014 01:17 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Get to the Recovery Menu and select Wipe Cache Partition, then Reboot System Now. See the steps here: Reset: T-Mobile myTouch 4G | T-Mobile Support

    Also, did you try to dry the phone out using the rice in a ziploc bag trick? Remove the battery, and put the phone and battery in separate Ziploc bags filled with uncooked rice. Seal them, and let them sit for 24 hrs. Then try the phone again.
    07-18-2014 02:29 AM
  3. Kelsey Brook's Avatar
    Yes I did let it sit in a rice bag for about the last 24 hours. I just took it out again today. I wiped the cache partition and rebooted the systems and it just sits black for a while so i took the battery out and restarted it and it brought me right back to the original white screen. any other ideas? or is my phone just really screwed?
    07-18-2014 01:14 PM
  4. Kelsey Brook's Avatar
    So i just did it a couple more times and this time i chose to wipe data and factory reset. It is turning on now! I hope it works fine!! thank you so much, I will let you know if everything is fixed!
    B. Diddy likes this.
    07-18-2014 01:18 PM
  5. Kelsey Brook's Avatar
    Alright it is turned on. i got some notifications and i am going through the set up of the phone now but there appears so be one more problem that will drive me even more crazy than my phone not working at all. it appears that the volume down button is broken or stuck. it keeps turning the ringer down to vibrate and holding it there to where the phone just keeps vibrating. is there any way to turn the volume buttons off or fix this?
    07-18-2014 01:27 PM
  6. Kelsey Brook's Avatar
    OK. So it is turned on and the volume button is still annoying. I am getting messages and calls just fine but it won't charge. Any idea how to fix this? It probably got wet when the phone got wet, but it looks dry now.
    07-18-2014 01:43 PM
  7. B. Diddy's Avatar
    Hard to know if these problems will resolve over time. The water damage to those various areas could be permanent. Was the charger connected at the time it got wet? If so, try a different cable. Otherwise, the port itself may have been damaged.
    07-18-2014 02:04 PM
  8. Kelsey Brook's Avatar
    Yes. It was connected. I tried a different cable and i you put it in just the right position then it charges. I'm going to hope this phone holds out through the weekend then invest in a new phone next week. Thank you for all of your help!
    07-18-2014 02:07 PM

Similar Threads

  1. Nexus 4: new ok google hotword Detection?
    By Clark Ye in forum Ask a Question
    Replies: 1
    Last Post: 02-27-2015, 09:24 PM
  2. Galaxy S5 Recent apps and backbutton dont light.
    By stuka75 in forum Ask a Question
    Replies: 2
    Last Post: 09-04-2014, 09:43 PM
  3. Nice article about the C720 6 months in
    By B. Diddy in forum Acer Chromebooks
    Replies: 4
    Last Post: 08-05-2014, 05:26 AM
  4. Camera is grainy
    By dragon718 in forum LG G3
    Replies: 5
    Last Post: 07-18-2014, 01:10 AM
  5. Replies: 9
    Last Post: 07-18-2014, 12:26 AM
LINK TO POST COPIED TO CLIPBOARD