Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
+ Reply Subscribe
Results 1 to 2 of 2
  1. Thread Author  Thread Author    #1  
    AC Question
    AC Question's Avatar
    Guest

    Default GS3 isn't working

    I'v got GS3
    I turned it off this morning but it won't back on
    It did turn on and froze on SAMSUNG screen for hours
    I've tried taking the battery out and plug it to the charger, also I changed the battery.
    can you help me?
  2. #2  

    Default Re: GS3 isn't working

    Welcome to Android Central! Try booting into Recovery Mode and wiping the system cache partition: [Guide] Rebooting into Recovery Mode for the Galaxy S2, S3, and Tab2.

Similar Threads

  1. Galaxy Mega Won't Work After Update
    By Brandonm12 in forum Ask a Question
    Replies: 4
    Last Post: 10-11-2014, 01:08 AM
  2. SOLVED / Play "This item isn't available in your country" - but I'm in the USA
    By Tim Radbourne in forum General Help and How To
    Replies: 8
    Last Post: 07-26-2014, 01:01 PM
  3. Hangouts Works w/ S5 but Not GN/2014
    By monicakm in forum Samsung Galaxy Note 10.1 (2014)
    Replies: 10
    Last Post: 07-25-2014, 10:42 AM
  4. ns mainframe will not work on android Y?
    By rdcordle in forum Ask a Question
    Replies: 0
    Last Post: 07-18-2014, 09:57 PM
  5. Any portable power banks that work well with this?
    By JnEricsonx in forum Samsung Galaxy Note 10.1
    Replies: 0
    Last Post: 07-18-2014, 07:20 PM

Posting Permissions