Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
+ Reply Subscribe
Results 1 to 2 of 2
  1. Thread Author  Thread Author    #1  
    AC Question
    AC Question's Avatar
    Guest

    Default I have an Android Tablet 10.1 and Google Play is not working on it.

    I have had this tablet for about two years now, and about five months ago I rooted it. Shortly after, Google Play kept coming up with errors and stopped working for me.
    Being the foolish person I am, I did a factory reset (and I think I un-rooted it) to see if it fixed. It didn't. Now, whenever I try to go on to Google Play, it'll ask for my password and username and after I enter it will say something like "Can't establish reliable connection to server. This could be a temporary problem. Try again or connect to another Wi-Fi network." I have, and that has not helped.

    Suggestions?
  2. #2  

    Default Re: I have an Android Tablet 10.1 and Google Play is not working on it.

    Try different wi-fi networks. Also make sure the device's date and time are correct.

Similar Threads

  1. Replies: 3
    Last Post: 11-13-2014, 04:48 AM
  2. Wifi off when sleeping. Do I need it.
    By tonyr6 in forum Google Nexus 5
    Replies: 5
    Last Post: 07-24-2014, 11:26 PM
  3. Replies: 2
    Last Post: 07-24-2014, 02:28 PM
  4. Replies: 2
    Last Post: 07-24-2014, 01:29 PM
  5. pictures not being received
    By somaca54 in forum Verizon Samsung Galaxy Note 3
    Replies: 0
    Last Post: 07-24-2014, 12:10 PM

Posting Permissions