1. AC Question's Avatar
    Why won't Google main website load on my S3?
    Up until today it always loaded and the news items opened. Not any more. Why???
    07-29-2014 06:04 AM
  2. lizardchest's Avatar
    Works fine for me on stock browser and chrome.
    What browser are you using? Who is your carrier? Are other websites loading? Are you on WiFi? Have you installed any apps recently? Are you referring to www.google. com, or some other specific address?


    First try from the home screen: menu> settings> more> application manager> all> internet (if your using stock browser)> clear data.
    07-29-2014 06:12 AM
  3. gromitt's Avatar
    Cleared data as suggested, but still no joy.
    Answers to your questions:
    Stock browser - 3 - All other websites will load - I'm on WiFi - no new apps installed only updates - referring to google.co.uk and google.com
    This has only happened today, before that it was fine. Look forward to your feedback.
    07-29-2014 08:50 AM
  4. lizardchest's Avatar
    Granted, I'm in the U.S., but I can still access google.co.uk and news.google.co.uk on my S3.
    What kind of error are you getting? Page loads forever or instantly denies connection? I'm sure you've already tried typing in the addy vs. using a bookmark.
    Have you tried loading the page on a different browser?
    Sorry for all the questions..
    07-29-2014 09:30 AM
  5. gromitt's Avatar
    I'm in the UK but it's the same S3.
    Page loads forever i.e blank page and only 5 or 6mm of blue loading line.
    Have tried: bookmark, typing in the address, coming from another search provider, and Chrome. All without success. Yesterday it wasn't a problem. Today it is impossible.
    If you don't ask, you'll never know.
    07-29-2014 10:56 AM
  6. lizardchest's Avatar
    Only other thing I can think of is view as mobile site vs. view desktop site....
    After that, all I've got left to offer is sympathy! Sorry!
    07-29-2014 11:05 AM
  7. gromitt's Avatar
    Thanks for your sympathy and thanks for trying.
    Nothing ventured, nothing gained.
    07-29-2014 01:30 PM
  8. gromitt's Avatar
    Just to let you know: this morning Google is loading and opening tabs as you would expect.
    Visually it looks different to how it was but that's immaterial as it is now functioning.
    No, I have no idea how this has come about I'm just pleased, if confused, that it has.
    lizardchest likes this.
    07-30-2014 04:10 AM

Similar Threads

  1. sync android problem - please help
    By papahook in forum Ask a Question
    Replies: 2
    Last Post: 07-30-2014, 06:10 AM
  2. Play Store Problems
    By Poch19 in forum Moto G (2013)
    Replies: 2
    Last Post: 07-29-2014, 10:43 AM
  3. S5 soft key problem
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 07-29-2014, 04:51 AM
  4. Remove Google Earth tab
    By Terrorizer in forum Google Nexus 7 Tablet (2013)
    Replies: 0
    Last Post: 07-29-2014, 02:52 AM
  5. S4 zoom camera blurring problem
    By vicky ahmad in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 0
    Last Post: 07-29-2014, 02:49 AM
LINK TO POST COPIED TO CLIPBOARD