Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
+ Reply
Results 1 to 3 of 3
Like Tree1Likes
  • 1 Post By B. Diddy
  • 1 Post By Rohini_fps
  1. Thread Author  Thread Author    #1  
    AC Question
    AC Question's Avatar

    Angry moto E speed issue

    I'm moto E user, its been just a month, my phone is getting slow and it says google services has stopped working
    help me, I don't want to factory reset my phone
  2. #2  

    Default Re: moto E speed issue

    Welcome to Android Central! Try booting into Recovery Mode and wiping the system cache partition, which won't erase any personal data. Although I'm not certain, I'm betting the steps for the Moto X will work for the E as well: https://motorola-global-portal.custh...p/30,6720,8696
    Rohini_fps likes this.
  3. #3  

    Default Re: moto E speed issue

    thanks a lot
    B. Diddy likes this.

Similar Threads

  1. iPod 5th 16gb, PS3 or Moto G?
    By Madd54 in forum The Android Central Lounge
    Replies: 5
    Last Post: 08-27-2014, 01:33 PM
  2. Game compatibility issues...
    By Beka27 in forum LG G3
    Replies: 13
    Last Post: 08-01-2014, 04:56 PM
  3. Alcatel one touch internet issues
    By morgan leew in forum Ask a Question
    Replies: 2
    Last Post: 08-01-2014, 04:43 PM
  4. Green Dot by Home Button on Moto X?
    By Ledsteplin in forum Moto X (2013)
    Replies: 8
    Last Post: 08-01-2014, 07:41 AM
  5. Kit Kat Issue
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-31-2014, 05:15 PM

Posting Permissions