1. AC Question's Avatar
    i have a samsung galaxy s3 mini. I have to keep it plugged in to have it on. While i had it plugged in, i was on the internet and it just shut off on me. I thought my battery exploded, so i got a new one. When my new battery arrived, I plugged it in for a couple of hrs, and my screen wont turn on, no vibrate, nothing. what do u think my problem is?
    08-02-2014 05:19 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! What do you mean when you say you thought your battery exploded? Did it actually leak? If so, the phone's contacts might have been damaged.

    For the new battery, try plugging the phone in to a wall outlet for 8-12 hrs, undisturbed, to make absolutely sure that the new battery is charged up.
    08-02-2014 05:29 PM
  3. ranD_J's Avatar
    My battery was puffy and it didnt leak. I thought my problem was the battery.
    08-02-2014 05:55 PM
  4. B. Diddy's Avatar
    Puffy battery is definitely bad. Try charging the new one up for 8-12 hrs as I previously suggested.
    08-02-2014 06:16 PM
  5. ranD_J's Avatar
    i plugged in my new battery for 12 hrs and it didnt turn on. what else can i do?
    08-03-2014 06:35 PM
  6. B. Diddy's Avatar
    Hard to say. Possibly a hardware failure in the phone. You may need to contact Samsung or a repair shop. Good luck!

    Posted via Android Central App.
    Please excuse any typos or autocorrect derps.
    08-03-2014 07:44 PM
  7. N4Newbie's Avatar
    You probably know this already but, honestly, some people have never been down this road before...

    Once your device is truly powered off, you need to hold the power button for several seconds (like 5'ish) to force it to power on and boot up.

    Just saying...

    Posted via Android Central App
    B. Diddy likes this.
    08-03-2014 08:20 PM

Similar Threads

  1. Replies: 18
    Last Post: 08-06-2014, 03:22 PM
  2. Replies: 2
    Last Post: 08-02-2014, 05:42 PM
  3. i need help with my android tablet
    By Niko Honkonen in forum Ask a Question
    Replies: 3
    Last Post: 08-02-2014, 04:59 PM
  4. Bill Me Later
    By chferg in forum Ask a Question
    Replies: 0
    Last Post: 08-02-2014, 04:07 PM
  5. sgs4 i337m no sound or mic after update HELP!!!!!
    By cdawg420 in forum Ask a Question
    Replies: 0
    Last Post: 08-02-2014, 01:35 PM
LINK TO POST COPIED TO CLIPBOARD