1. AC Question's Avatar
    I was trying to restore my Samsung Galaxy S3 because I bought it from a friend so I was restoring to factory bought. When I did this the phone had the blank screen and logo on it so i thought it was restoring but nothing has happened and it has stayed like this for a while now (about two hours). Has anyone else have this problem or know how to fix it? If you could help me that'd be great. Thanks!
    08-05-2014 01:28 PM
  2. anon8380037's Avatar
    Were you restoring it from the settings? You can also do it with the buttons when the phone is off.
    Try taking out the battery, maybe wait a few minutes, especially if it's hot.
    If you hold at the same time the volume UP button - Power - and Home button, wait a few seconds.
    A vibration and then a recovery screen comes up. Use the volume down key to highlight "wipe data/ factory reset" and press the power button to select. You then have to select again from a list, as a safety measure.
    [Guide] [Info] Custom recoveries versus Stock. Is there a difference?

    Sent from my SM-N9005 using Tapatalk Pro
    08-05-2014 02:12 PM

Similar Threads

  1. s3 stucck on logo
    By Asiya Zafar in forum Ask a Question
    Replies: 23
    Last Post: 08-07-2014, 04:42 AM
  2. I have problem with my new S5
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 08-06-2014, 12:56 AM
  3. Replies: 3
    Last Post: 08-05-2014, 07:25 PM
  4. Replies: 0
    Last Post: 08-05-2014, 12:40 PM
  5. Replies: 0
    Last Post: 08-05-2014, 12:24 PM
LINK TO POST COPIED TO CLIPBOARD