1. Melissa98's Avatar
    Help! I'm on my third brand new phone, my second sim card, and many many headaches... I consistently hit the home button, get the "Complete action using" prompt, offering touchwiz or touchwiz ready. I hit "touchwiz" and "always" then ok on the prompt about changing default settings, and it works for that session on the phone. But the next time I pick up the phone from sleep, it starts all over again! I've tried everything from going through the default application settings, to clearing the touchwiz cashe, to removing updates on Google search, to a factory reset. Some things work temporarily, but eventually go right back. Help!
    08-06-2014 09:41 AM
  2. Golfdriver97's Avatar
    If you go to Settings>apps>swipe over to all apps, scroll down, is there an entry for TW and TW ready?
    08-06-2014 09:46 AM
  3. UJ95x's Avatar
    You say this is your third phone. Were the others having the same issue or did you return them for different reasons?

    Sent from my Galaxy S4 running SOKP 4.4.2
    08-06-2014 10:11 AM
  4. Melissa Roberts's Avatar
    Yes. Touchwiz and touchwiz easy.
    08-06-2014 10:12 AM
  5. Melissa Roberts's Avatar
    Yes the others were doing the same thing
    08-06-2014 10:13 AM
  6. Melissa Roberts's Avatar
    I have Verizon, and no one there has a clue. Also spoke with two different Samsung techs who say they've never seen this.
    08-06-2014 10:14 AM
  7. Melissa Roberts's Avatar
    If you go to Settings>apps>swipe over to all apps, scroll down, is there an entry for TW and TW ready?
    Sorry, yes there is an entry for touchwiz and touchwiz easy.
    08-06-2014 10:20 AM
  8. anon8380037's Avatar
    So you tried this?

    08-06-2014 10:23 AM
  9. Melissa Roberts's Avatar
    So you tried this?
    Yes and it works temporarily but eventually goes back to doing the same thing.
    08-06-2014 10:29 AM
  10. Melissa Roberts's Avatar
    You say this is your third phone. Were the others having the same issue or did you return them for different reasons?

    Sent from my Galaxy S4 running SOKP 4.4.2
    Yes I got the s5 the day it came out, spent hours on the phone and in the store with techs. No one has an answer. They replaced with a refurbished phone, then a brand new one.
    08-06-2014 10:32 AM
  11. UJ95x's Avatar
    What if you were to try a third party launcher? Something like Nova or Apex. At least to see if those will stay as default.

    Sent from my Galaxy S4 running SOKP 4.4.2
    08-06-2014 10:33 AM
  12. Melissa Roberts's Avatar
    What if you were to try a third party launcher? Something like Nova or Apex. At least to see if those will stay as default.

    Sent from my Galaxy S4 running SOKP 4.4.2
    I've rebuilt my home screen so many times, I really didn't want to do it again, but I guess I could. Really want to know how I'm lucky enough to have this same issue on three different phones.
    08-06-2014 10:57 AM
  13. UJ95x's Avatar
    I've rebuilt my home screen so many times, I really didn't want to do it again, but I guess I could. Really want to know how I'm lucky enough to have this same issue on three different phones.
    Yeah, it can be annoying. But I don't think you can save your launcher from TouchWiz to import it to Nova

    Sent from my Galaxy S4 running SOKP 4.4.2
    08-06-2014 12:27 PM
  14. rainbow_goblin's Avatar
    I'm having exactly the same problem. It's frustrating as hell. I'm on my second phone so far because of this issue.
    08-06-2014 01:31 PM
  15. timaye208's Avatar
    Go to Settings>More>Application Manager>All and scroll down to SetDefaultLauncher. Clear cache and clear defaults.
    08-09-2014 02:27 PM
  16. eugeneworldwide's Avatar
    Hi guys, I have had this problem on the S4 and have recently deduced the situation. The main culprit is the Google Search app, but not he app itself, the version. Version 2 as per previous forums worked and upgradeing to v2+ created the problem the TouchWiz. On previous OS'ses loaded on the S4 you were able to uninstall updates back to v2 of Google Search. Solving the TouchWiz default launcher bug. Samsung recently published their OTA OS update, and in this they embedded the culprit by loading the newest Google Search version being 3+.
    Thus uninstalling Google Search updates after updating your OS wont have any influence now with aNDROID 4.4.2 AS the embedded Google Search is the wrong one. Making it a permanent bug. I am investigating downgrading the OS to see if it solves it. Any recommendations of this works will help greatly.
    BTW, setting defaults, clearing cache etc has no effect on the bug with the new OS.

    Thanks
    08-11-2014 02:42 AM
  17. tferro's Avatar
    Anyone have a solution for the Google search issue yet? This is driving me nuts
    10-19-2014 08:22 AM
  18. tferro's Avatar
    Finally found something that worked for me. In desperation, after reading about the Google search version issue, I went in and started clearing anything with multiple options for default.. I noticed that I was getting the same pop up whenever I would launch a browser because I had both Chrome and internet installed. I decided since I don't use Chrome much anymore that I would just uninstall it. That totally fixed my problem. I went back into touch wiz in the settings, and it finally allowed me to set it as the default, where it was not staying saved before, and all is fine now.
    10-19-2014 08:58 AM
  19. Aziz el's Avatar
    I found that an application was the origin of the issue on s5 mini
    you can go to parameter / applications / default application / welcome
    There you need to delete all the applications except touchwiz
    11-05-2014 09:42 AM
  20. Tako Tan's Avatar
    I had the same problem in my s5, until i figured it out which it was another app that prompted to be set as home default. For my case, it was Connect for Hotmail application that causing the problem. Under Setting>Applications>Default applications>Set defaults Home:

    There were three options which were
    1. TouchWiz Home
    2. TouchWiz easy home
    3. Connect to Hotmail

    What I did was i delete the Connect to Hotmail option from the selections and select TouchWiz Home as default and pressed the home button. Then the "Set as default" prompt never showed up since. Hope this is somehow helpful for you.
    06-25-2015 07:32 PM
  21. QuestMGD's Avatar
    Finally found something that worked for me. In desperation, after reading about the Google search version issue, I went in and started clearing anything with multiple options for default.. I noticed that I was getting the same pop up whenever I would launch a browser because I had both Chrome and internet installed. I decided since I don't use Chrome much anymore that I would just uninstall it. That totally fixed my problem. I went back into touch wiz in the settings, and it finally allowed me to set it as the default, where it was not staying saved before, and all is fine now.
    09-13-2015 04:52 PM
  22. QuestMGD's Avatar
    Thanks this solved it. Of all things, it was a stupid flashlight app that was causing the problem. Cleared all my screen settings trying to fix this problem, but at least in my case, it was mostly my fault for installing that stupid app.
    09-13-2015 04:55 PM
  23. Sejuwan's Avatar
    This did it! It was another application that was the culprit. After I deleted the app, my launcher works properly. Thank you!
    09-17-2015 02:30 PM

Similar Threads

  1. Removing songs from Galaxy S3
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-06-2014, 02:09 PM
  2. Black Screen For Samsung Galaxy S4
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-06-2014, 09:35 AM
  3. Samsung galaxy s3 navigation
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-06-2014, 09:25 AM
  4. Samsung Galaxy note 3
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-06-2014, 09:24 AM
  5. Replies: 0
    Last Post: 08-06-2014, 08:59 AM
LINK TO POST COPIED TO CLIPBOARD