1. IraPrognatusDeus's Avatar
    Hi. My Moto X has recently slowed down to the point where I can barely use my phone. I've already read up a lot, and I've cleared all messages, all recently installed apps, and the system cache. The UI is fine and the keyboard doesn't lag. If I open up an app, it opens on time. That's where it goes downhill. Everything takes decades to load. Instagram. Facebook. Google Chrome. Reddit. Play Store. Play Music. What do I do? My phone needs a hero!
    08-15-2014 11:48 PM
  2. UJ95x's Avatar
    Welcome to AC
    Your post/title combo are a bit confusing...is your phone lagging when in use or is it just taking a long time to connect to services?
    B. Diddy likes this.
    08-15-2014 11:50 PM
  3. B. Diddy's Avatar
    Good question. If the problem is with loading or syncing data, does this happen regardless of which network you're using? Is it the same on wi-fi as it is on mobile data? Is it the same on different wi-fi networks?
    UJ95x likes this.
    08-16-2014 02:29 AM

Similar Threads

  1. Using a Moto E. Should upgrade to Moto G?
    By arn_hsn xt1022 in forum Moto G (2013)
    Replies: 6
    Last Post: 08-17-2014, 05:12 AM
  2. Moto G- Third party app installation problem.
    By Sherlock_H in forum Ask a Question
    Replies: 1
    Last Post: 08-16-2014, 01:47 AM
  3. Has there been a leap in Android games lighting effects
    By Flippinin in forum Ask a Question
    Replies: 1
    Last Post: 08-15-2014, 11:19 PM
LINK TO POST COPIED TO CLIPBOARD