1. AC Question's Avatar
    This may just be due to the fact the battery is at 0% charge. But I had around enough charge to send a text message. Well, after I send it, the battery flashed with a "!" then the Samsung logo played followed by it powering off. I left it charging for about 30 minutes and it still continues to due a swift vibration with no evidence it's even charged. I can't even see a charging logo with it plugged in via USB or wall outlet.
    08-21-2014 01:54 AM
  2. wizzrah's Avatar
    Hello. So the phone just vibrates on its own? Were you able to charge the device completely?
    08-21-2014 01:55 AM
  3. JayEh's Avatar
    No. It vibrates if I press and hold the power button while there's a connection between the phone and a power source. I let it charge for around 30 or so minutes. But even so, I always assumed it should show a battery icon on the screen when plugged up.
    08-21-2014 01:58 AM
  4. JayEh's Avatar
    Any info at all?
    08-21-2014 02:20 AM
  5. JayEh's Avatar
    Nevermind. Bad charge cable.
    08-21-2014 03:23 AM

Similar Threads

  1. Missing photos on my Galaxy S5
    By Dickoniner in forum Samsung Galaxy S5
    Replies: 47
    Last Post: 04-03-2017, 11:47 AM
  2. Replies: 10
    Last Post: 02-17-2017, 09:31 AM
  3. Live wallpaper in lock screen
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-21-2014, 01:15 AM
  4. Samsung 1200PP root
    By Unregistered in forum Ask a Question
    Replies: 1
    Last Post: 08-21-2014, 12:03 AM
LINK TO POST COPIED TO CLIPBOARD