Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 10 of 10
Like Tree1Likes
  • 1 Post By UJ95x
  1. Thread Author  Thread Author    #1  

    Smile Avoided Bad Internet Connection Message

    Hi all, we're hoping somebody out there can help us with a new Cubot S208 smart phone we've just bought. We've been using it for a couple of weeks on various wi-fi networks and not experienced any problems until 2 days ago. We tried to connect to our home network which we'd connected to many times over the last 2 weeks but we got the Obtaining IP address message. This stays on the screen for ages, then the message says Avoided Bad Internet Connection. I tried out the phone on a neighbours wi-fi network (which has the same security type WPA-PSK with its own password), and this worked okay. We used it last night and it intermittently logged onto 1 or 2 different wi-fi networks in town, other networks we got the same error message as we're now getting at home Avoided Bad Internet Connection. So, here's what we've tried so far:

    - Took the handset back to factory settings
    - Tried connecting to our home wi-fi on its own (we switched off our wireless laptop in case it was causing the problem)
    - We deleted our home wi-fi connection and re-entered it on the handset

    And today we're still getting the same error message when trying to connect at home. Our wireless router BTW is a Belking54g (not sure if that's the problem?). Does anybody have any suggestions what we can do to rectify this problem as currently we're not able to use the handset at home for internet now. One other thing; we don't have a SIM card in the handset yet (in the process of buying one).

    We've seen lots of other comments online where other devices are getting exact same problem, and we've also seen some software online that suggets it can cure it but would appreciate some honest advice.

    Really hope somebody out there can help us. Thanks for listening :-)
  2. #2  
    UJ95x's Avatar

    Posts
    8,724 Posts
    Global Posts
    8,983 Global Posts
    ROM
    Slim Kat 4.4.4

    Default Re: Avoided Bad Internet Connection Message

    Welcome to AC
    Go to settings > wireless & networks > WiFi > Advanced settings. Make sure "avoid poor connections" is not checked.

    Sent from my Galaxy S4 running SlimKat 4.4.4
    "We live in a society exquisitely dependent on science and technology, in which hardly anyone knows anything about science and technology." - Carl Sagan
    Golfdriver97 likes this.
  3. #3  
    Golfdriver97's Avatar

    Posts
    21,797 Posts
    Global Posts
    22,237 Global Posts
    ROM
    Liquidsmooth ROM

    Default Re: Avoided Bad Internet Connection Message

    UJ suggested the same thing I was going to.

    Phone Timeline
    'If we could change ourselves, the tendencies in the world would also change.' - Mahatma Gandhi
    Community Guidelines and also here
  4. Thread Author  Thread Author    #4  

    Smile Re: Avoided Bad Internet Connection Message

    Hi there, thanks for the quick replies, unfortunately we dont have this setting on this handset.

    When we go into settings - wifi, immediately we're looking at the list of available wifi networks around us.
    If we select our home wifi, then Modify Network, then select Show Advanced Options, our options are Proxy Settings - Choose None or Manual, and the other option is IPv4 Settings, choose DHCP or Static. We've got our phone set up as None and DHCP.

    Have searched the phone's menu and cannot find the option you've suggested unfortunately.
    Don't suppose you have a plan B? Really appreciate your help with all this, thanks again
  5. #5  
    Golfdriver97's Avatar

    Posts
    21,797 Posts
    Global Posts
    22,237 Global Posts
    ROM
    Liquidsmooth ROM

    Default Re: Avoided Bad Internet Connection Message

    When you are in the list of connections, click menu. That will bring up the advanced menu UJ was referring to.

    Phone Timeline
    'If we could change ourselves, the tendencies in the world would also change.' - Mahatma Gandhi
    Community Guidelines and also here
  6. Thread Author  Thread Author    #6  

    Default Re: Avoided Bad Internet Connection Message

    Hi again, thanks for getting back to us. When I enter this advanced wi-fi menu I have the following options:

    Network notification (notify me when an open network is available)
    Keep wi-fi on during sleep
    Wi-fi optimization (Minimize battery usage when wi-fi is on)
    Then it lists the MAC address. Still can't see the setting I need. Could it be hidden elsewhere?
    Appreciate your help :-)
  7. #7  
    UJ95x's Avatar

    Posts
    8,724 Posts
    Global Posts
    8,983 Global Posts
    ROM
    Slim Kat 4.4.4

    Default Re: Avoided Bad Internet Connection Message

    Quote Originally Posted by BDRymell View Post
    Hi again, thanks for getting back to us. When I enter this advanced wi-fi menu I have the following options:

    Network notification (notify me when an open network is available)
    Keep wi-fi on during sleep
    Wi-fi optimization (Minimize battery usage when wi-fi is on)
    Then it lists the MAC address. Still can't see the setting I need. Could it be hidden elsewhere?
    Appreciate your help :-)
    Hmm. Not sure where else you could find that particular setting. It's been on every phone I've used before.
    Of the networks that you couldn't connect to, did they actually have a particularly "poor" connection in comparison to the ones you were able to?

    Sent from my Galaxy S4 running SlimKat 4.4.4
    "We live in a society exquisitely dependent on science and technology, in which hardly anyone knows anything about science and technology." - Carl Sagan
  8. Thread Author  Thread Author    #8  

    Smile Re: Avoided Bad Internet Connection Message

    Found the problem!
    After looking at posts online from people getting exact same problem I thought i'd take a look at my router settings as I have MAC address filtering set. And although my device was entered on the allowed list correctly when we bought it, and we've been using it for 2 weeks at home on our wifi connection with no problems, I noticed its wi-fi address was no longer in the router's allowed list. As soon as I entered the phone's MAC address into the allowed list the phone connected straight away.
    How did the MAC address removed itself from the list? I wonder if it might happen again but at least i'll know where to look.
    Thank you for all your help with this.
  9. #9  
    UJ95x's Avatar

    Posts
    8,724 Posts
    Global Posts
    8,983 Global Posts
    ROM
    Slim Kat 4.4.4

    Default Re: Avoided Bad Internet Connection Message

    Quote Originally Posted by BDRymell View Post
    Found the problem!
    After looking at posts online from people getting exact same problem I thought i'd take a look at my router settings as I have MAC address filtering set. And although my device was entered on the allowed list correctly when we bought it, and we've been using it for 2 weeks at home on our wifi connection with no problems, I noticed its wi-fi address was no longer in the router's allowed list. As soon as I entered the phone's MAC address into the allowed list the phone connected straight away.
    How did the MAC address removed itself from the list? I wonder if it might happen again but at least i'll know where to look.
    Thank you for all your help with this.
    Woohoo! Glad you got it working

    Sent from my Galaxy S4 running SlimKat 4.4.4
    "We live in a society exquisitely dependent on science and technology, in which hardly anyone knows anything about science and technology." - Carl Sagan
  10. #10  

    Default Re: Avoided Bad Internet Connection Message

    just wasted 2 hours searching until i found this line: under data/misc/dhcp

    I found that deleting the contents of /data/misc/dhcp and then restart your device would cleared the issue. im using 4.4

    I hope this helps someone

    thanks

Similar Threads

  1. Messages icon is deleted rom Galaxy Grand
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-25-2014, 06:14 AM
  2. Bluetooth Connection / Safe Mode
    By Ricky Babalu in forum LG G3
    Replies: 1
    Last Post: 08-25-2014, 01:35 AM
  3. Samsung Galaxy S 4 and Note 8 WiFi Connection Problems
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-25-2014, 12:17 AM
  4. Messaging app lowers sent picture quality (Cyanogenmod)
    By kmaster12345 in forum Ask a Question
    Replies: 0
    Last Post: 08-24-2014, 11:15 PM
  5. late messages
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 08-24-2014, 08:45 PM

Posting Permissions